Référence au texte dans une cellule [Résolu/Fermé]

Solalune - 28 nov. 2016 à 20:03 - Dernière réponse :  Solalune
- 28 nov. 2016 à 21:35
Bonjour,
J'ai un grand tableau Excel type planning qui reprend des codes de 5 caractères qui peuvent être suivis de commentaires (par exemple CXLS- ou CVBP-).
A coté, j'ai un tableau reprenant tous ces codes et je voudrais pouvoir compter le nombre d’occurrences de ceux-ci sans devoir les renoter dans la formule (remplacer donc = NB.SI.(plage;"*CXLS-*") par la référence à la cellule d'à côté). Je sais le faire pour qu'il me compte le nombre d'occurrences du texte exact mais je voudrais qu'il prenne également en compte les cellules pour lesquelles il y a un commentaire (par ex CXLS-à remplir).

Est-ce possible et comment? Merci pour votre aide!



Afficher la suite 

2 réponses

Vaucluse 20837 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - Modifié par Vaucluse le 28/11/2016 à 20:44
0
Utile
1
Bonjour
pas tout compris, un opeu au hasard, l'équivalent de votre NB.SI avec un texte à trouver placé en A1 pour l'exemple:

=NB.SI(Plage;"*"&A1&"*")
  • ...;A1&"*") commence par A1
  • ...;"*"&A1) finit par A1
  • ...;"*"&A1$"*") contient A1


crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
Merci, ça répond tout à fait à ma question!
J'ai juste adapté ton $ en & (une petite faute de frappe je suppose) dans la dernière formule.