Signaler

Wake on lan qui ne marche plus...

Posez votre question Bilin95 9Messages postés dimanche 27 novembre 2016Date d'inscription 2 décembre 2016 Dernière intervention - Dernière réponse le 3 déc. 2016 à 17:01
Bonjour..
Je me suis pris la tête tout le week-end sans avoir résolu mon problème.. je recherche des conseils constructifs pour trouver une solution :
Mon matériel : pc assemblé avec carte mère asus A88+ , freebox révolution et Windows 10 pro.
Cette semaine tout marchait bien, je pouvais réveiller à distance mon pc éteint avec des paquets magiques. Je n'ai fait aucune manip spectacle. Mais samedi impossible à réveiller. J'ai regardé mes paramètres de carte réseau dans Windows, mes paramètres routeur freebox (adresse fixe, port 9 ouvert, WOL activé..).. Mais rien a faire je trouve rien d'anormal.
J'ai ensuite installé un sniffer de paquets magiques . Celui ci voit bien les paquets arriver...
Pc éteint, quand j'envoie les paquets magique je vois bien la led de la carte réseau s'allumer .. mais rien ne se réveille....
Idem en configuration lan directe avec mon pc portable.
J'en deduirais que cela vient du bios? Mais je vois pas où.. ni pourquoi ça aurait changé.
(j'ai booté un live CD ubuntu en fin de semaine mais je pense pas que cela ait déréglé le bios)..

Je suis donc preneur de tout conseil et methodologie pour trouver le problème.
Je vous remercie d'avance pour vos avis éclairés
Afficher la suite 
Utile
+0
moins plus
Slt

Comment sont paramétrées, dans le gestionnaire de périphériques, tes options d'alimentation de la carte réseau ET ( onglet Avancé ) ses options Wake On Lan et magic packet ?

Si tout est ok mets à jour le pilote de la carte réseau en allant le chercher sur le site constructeur( pas par "Mettre à jour le pilote" via Windows qui croit toujours avoir le dernier)

Ajouter un commentaire
Utile
+0
moins plus
Merci Kaumune

Pour ma carte realtek GBE familly ,

j'ai coché toutes les cases dans gestion d'alimentation ( autoriser à éteindre ce périphérique, autoriser ce périphérique à sortir l'ordinateur de veille, autoriser uniquement avec un paquet magique).

Dans avancé j'ai mis:
Arreter-reveil par réseau =activer
Reveil sur paquet magique =activé.
Wol/arrêt vitesse réseau =10mbps en premier

Je regarde à présent pour essayer d'actualiser le pilote
kaumune 14382Messages postés lundi 26 novembre 2007Date d'inscription ContributeurStatut 7 décembre 2016 Dernière intervention - 28 nov. 2016 à 07:42
Ok c'est ce que j'ai aussi

Concernant le pilote, j'avais eu ce souci avec le pilote installé par W10

Ma version de pilote actuelle avec lequel ça fonctionne :


le tout dernier de chez Realtek installé et testé avec succès sur un autre PC

Ps : Il faut bien entendu aussi vérifier que l'option dans le bios est bien active
Répondre
Bilin95- 29 nov. 2016 à 19:08
Bonsoir kaumune
Désolé pour le temps de latence , les jounees sont chargées en ce moment.
J'ai réinstallé le dernier driver realtek en lieu et place du même (sans avoir desinstallé avant par contre). Ça ne change rien.
Mais nouvelle piste de reflexion .
Je me rappelle pourquoi j'ai voulu utiliser linux . Pour supprimer un vieux dossier windows.old avec seulement un fichier .sys verrouillé dedans.! Forcément j'ai pas noté son nom...
Donc première chose à vérifier je pense aussi les drivers, puis le bios (mais pourquoi aurait-il été modifié...).
Si c'est pas le pilote réseau, où chercher donc..
Merci encore et bonne soirée
Répondre
Ajouter un commentaire
Utile
+0
moins plus
Bonjour Kaumune
J'ai finalement retrouvé le nom du dossier que j'ai supprimé (mais pas le fichier sys qu'il contenait :(
si ça peut aider:

C:\Windows.old\windows\System32\DriverStore\FileRepository
kaumune 14382Messages postés lundi 26 novembre 2007Date d'inscription ContributeurStatut 7 décembre 2016 Dernière intervention - 1 déc. 2016 à 07:27
??? ce qu'il y a dans windows.old n'a aucune incidence sur le fonctionnement du PC

Tu en es où ?

Tu as :

vérifié l'option dans le bios ?

désinstallé et réinstallé proprement le driver ?
Répondre
Ajouter un commentaire
Utile
+0
moins plus
Bonjour kaumune,
Si cela peut peut-être avoir une incidence car justement ce fichier sys de Windows.Old était toujours utilisé par W10..
C'est de mémoire la seule manip importante que j'ai fait avant le problème de plus.
J'ai encore revérifier le bios de l'asus a88x plus. Il n'y a qu'une seule option wol visiblement.
Je vais aussi réessayer de reinstaller proprement le driver carte reseau aujourd'hui.
Merci
kaumune 14382Messages postés lundi 26 novembre 2007Date d'inscription ContributeurStatut 7 décembre 2016 Dernière intervention - 1 déc. 2016 à 10:43
POWER ON By PME (à activer)

Oui, pour moi c'est ça

Concernant la désactivation non souhaitée, j'ai eu le cas récemment sur mon PC

Comme toi, d'un coup, le WOL ne fonctionnait plus

Le problème était bien dû à l'option du BIOS mystérieusement désactivée

Vérifie aussi que cette option, dont tu parlais mais j'ai confondu avec Restore AC Power Loss, soit bien Enable

WOL (include AC Power Loss) [Disabled]
[Disabled]
Désactive la fonctionnalité WOL après une perte de courant (état G3).
[Enabled]
Active la fonctionnalité WOL après une perte de courant (état G3).
Répondre
Bilin95 9Messages postés dimanche 27 novembre 2016Date d'inscription 2 décembre 2016 Dernière intervention - 1 déc. 2016 à 20:13
Bonsoir ☺.
Je crois que ça avance : j'ai vérifié le bios, tout est ok. J'ai voulu essayé un reveil RTC par l'heure. Ça n'a pas marché.. Du coup j'ai éliminer la défaillance de la carte réseau. J'ai coupé l'alimentation 5min. . Et après débranchement du courant ça a fonctionné en WOL. La deuxième fois non. Je verrai si c'est stable ou pas. Mais j'ai pas compris pourquoi ça pise problème simplement pour un reveil.
Répondre
kaumune 14382Messages postés lundi 26 novembre 2007Date d'inscription ContributeurStatut 7 décembre 2016 Dernière intervention - 2 déc. 2016 à 07:25
Ca marche une fois après arrêt total du PC puis tu arrêtes le PC ( Démarrer === Arrêter) et ça ne marche plus ???
Répondre
Bilin95 9Messages postés dimanche 27 novembre 2016Date d'inscription 2 décembre 2016 Dernière intervention - 2 déc. 2016 à 21:50
Oui ça a fait ça 2 fois au début ainsi. Après avoir contrôlé ma multiprise ça marche depuis hier soir 4-5 fois correctement sans nouveau problème.. Peut-être l'l'alimentation qui déconne? Mais pourquoi ça gêne seulement pour le WOL?
Merci encore
Répondre
kaumune 14382Messages postés lundi 26 novembre 2007Date d'inscription ContributeurStatut 7 décembre 2016 Dernière intervention - 3 déc. 2016 à 07:12
Je commence à craindre pour toi un problème matériel sur la carte réseau ...
Répondre
Ajouter un commentaire
Utile
-1
moins plus
Salut,

Normalement Windows et les drivers non strictement rien avoir avec le WOL (hormis le faite de ne pas éteindre la carte réseau).

Pourquoi ? le WOL est le démarrage du pc par la carte réseau sur la carte mère par le bios.

Le système (et donc drivers) ne sont a aucun moment sollicité ou initialisé...

Le WOL ne se gère uniquement dans le bios, où l'option doit être activée.

https://openclassrooms.com/courses/wake-on-lan
kaumune 14382Messages postés lundi 26 novembre 2007Date d'inscription ContributeurStatut 7 décembre 2016 Dernière intervention - 1 déc. 2016 à 09:55
Normalement Windows et les drivers non strictement rien avoir avec le WOL 
Slt

Hé si, e pilote de la carte réseau impacte directement le bios

Le lien que tu fournis le stipule d'ailleurs bien en montrant la config à faire pour la carte réseau sous XP
Le WOL ne se gère uniquement dans le bios
Hé non

Tu peux l'activer tant que tu veux dans le bios, si les options ne sont pas ok dans le pilote, ça ne marchera jamais

;-)
Répondre
Bilin95 9Messages postés dimanche 27 novembre 2016Date d'inscription 2 décembre 2016 Dernière intervention - 1 déc. 2016 à 11:11
Merci encore kaumune ainsi qu'Arnaud pour son intervention.
Je regarde ce soir si mes 2 options Ac power loss sont bien activées.
J'ai vu également une option sur le manuel : EPU power saving mode. C'est important aussi?
Répondre
kaumune 14382Messages postés lundi 26 novembre 2007Date d'inscription ContributeurStatut 7 décembre 2016 Dernière intervention - 1 déc. 2016 à 11:21
C'est aussi un truc sur la gestion d'énergie

Chez moi, il est désactivé
Répondre
Pierrot059 1Messages postés samedi 3 décembre 2016Date d'inscription 3 décembre 2016 Dernière intervention - 3 déc. 2016 à 17:01
Bonjour, j'avais le même problème. Depuis plusieurs semaines, je m'arrache les cheveux pour trouver pourquoi mon wake on lan ne marche plus avec windows 10.

Maintenant, ça marche pour moi. Voila ce que j'ai fait :
=>Sous windows 10, dans panneau de config, gestion de l'alimentation, sur la gauche, cliquer sur "Choisir l'action du bouton d'alimentation". Puis, "Modifier des paramètres actuellement non disponibles". Cocher toutes les cases (activer le démarrage rapide, veille, veille prolongée, Verrouiler.
=> Menu Demarrage en bas à gauche (clic droit), gestion de l'ordinateur, gestion des peripheriques, Cliquer sur la carte reseau Realtek, puis clic droit, proprietes.
==> Dans l'onglet gestion de l'alimentation, j'ai coché les 3 options (autoriser l'ordinateur à eteindre ce perif, Autoriser ce periph a sortr de veille et autoriser uniquement un paquet magique à sortir l'ordinateur de veille).
==> Dans l'onglet Avancé,
Arrêter réveil par réseau = Activé
Ethernet a économie d’énergie = Désactivé
Ethernet Vert = Désactivé
Reveil sur paquet magique = Activé

Mon PC a une adresse IP Fixe. J'envoie le paquet magique via le port 9 qui est ouvert dans les paramétres de la box et redirigé vers l'adresse IP d'un raspberry pi qui me sert de relais wake on lan (voir ci dessous).

Mon pilote de carte reseau realtek est le dernier connu à ce jour, c'est à dire la version 10.12.1007.2016 du 7/10/2016.
Dans le bios de ma carte ASUS, j'ai une option pour activer le démarrage rapide INTEL. Je l'ai activée. Ainsi que l'option de wake on lan par PCI EXPRESS.
Je précise aussi que j'ai une BOX NUMERICABLE qui ne permet pas de démarrer un PC lorsqu'il est éteint. Cette box n'envoie pas le paquet magique aux périphériques qui ne répondent plus au ping depuis plusieurs minutes. J'ai dû installer un petit logiciel (wolproxy) sur un nano computer type raspberry pi qui est toujours allumé, et qui sert de relais aux paquets magiques et arrose tout mon réseau pour réveiller le périphérique de mon choix (ici mon pc).

Avec tout ça, je peux maintenant réveiller mon pc lorsqu'il est totalement arrêté ou en veille prolongé.
Répondre
Ajouter un commentaire

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !