Signaler

Probleme avec la formule "SI" [Résolu]

Posez votre question mow - Dernière réponse le 27 nov. 2016 à 15:10 par mow
Bonjour à tous,

Voila j'ai un petit problème avec excel et j'aurais besoin de vos lumières.
J'etabli une facture et j'aimerais dans une cellule lui demande de ne rien mettre si aucune référence n'est indique ( sur la maquette de la facture)
J'ai donc essayer sa : =SI(D22;"";"RECHERCHEV($C$22;produits;2;0)")
Mais cela ne marche pas et il y a un "0" qui apparaît ..
( la cellule D22 représente la case que je veux vide si aucune référence n'est indique dans la case C22 )
la case C22 est donc celle ou est renseigne la référence produit ( qui va le rechercher directement sur la feuille produit)
En claire je souhaiterais lui dire " si la cellule C22 est vide ( qui n'y a aucune référence d'indique) alors je veux que la case ( ou je saisit cette formule et donc la D22) reste vide ( car avec juste la formule =RECHERCHEV($C$22;produits;2;0) il laisse apparaître #N/A ( et c'est ce dernier que je ne veux pas voir apparaître )

Voila, voila j’espère avoir été claire ( ce n'est pas simple a explique)

Merci à vous !


Utile
+1
plus moins
Bonjour

Peux tu nous joindre ton fichier
Pour transmettre un fichier, il faut passer par un site de pièce jointe tel que cjoint.com

Va sur ce site : http://cjoint.com
Clic sur parcourir,
Cherche ton fichier,
clic sur ouvrir,
Clic sur "Créer le lien cjoint",
Copier le lien,
Revenir ici le coller dans une réponse..
Cordialement
Cette réponse vous a-t-elle aidé ?  
Donnez votre avis
Utile
+1
plus moins
Bonjour.

Déjà, en première lecture, il y a deux erreurs de syntaxe : la condition n'est pas explicitée, et il y a des guillemets intempestifs.

=SI(D22;"";"RECHERCHEV($C$22;produits;2;0)")
doit s'écrire
=SI(D22=0;"";RECHERCHEV($C$22;produits;2;0))

Et à la lecture de ton fichier, on verra si les caractères $ sont justifiés ...
Cette réponse vous a-t-elle aidé ?  
Donnez votre avis
Utile
+1
plus moins
Bonsoir

vous ne pouvez pas écrire en D22 une formule qui fait référence à D22
et donc le SI(D22="" ne convient pas, si j'ai bien lu votre message (référence circulaire)

s'il s'agit d'éviter le #N/A deux options:

excel à partir de 2007:

=SIERREUR(RECHERCHEV($C$22;produits;2;0);"")

et avant 2007 deux options:

=SI(ESTERREUR(RECHERCHEV($C$22;produits;2;0));"";RECHERCHEV($C$22;produits;2;0))

ou plus court, mais là il faut faire référence à la première colonne du champ nommé produit dont je ne connais pas l'adresse (ci dessous appelé "colonne")


=SI(NB.SI(colonne;C22)=0;"";;RECHERCHEV($C$22;produits;2;0))

crdlmnt
Cette réponse vous a-t-elle aidé ?  
Donnez votre avis
Utile
+1
plus moins
Merci a tous pour vos réponse mais mon 0 est toujours la ..
Voici le lien du document http://www.cjoint.com/c/FKAt4iwiOjJ

Merci a tous !
Cette réponse vous a-t-elle aidé ?  
Raymond PENTIER 43541Messages postés lundi 13 août 2007Date d'inscription ContributeurStatut 21 septembre 2017 Dernière intervention - 26 nov. 2016 à 21:47
Ton lien n'a pas l'air de fonctionner.
Peux-tu recommencer, en respectant scrupuleusement les instructions de jc80 ?
Répondre
mow- 26 nov. 2016 à 23:57
je comprends pas le lien marche bien normalement ... je le remet pour voir ? ===> http://www.cjoint.com/c/FKAt4iwiOjJ
Répondre
Raymond PENTIER 43541Messages postés lundi 13 août 2007Date d'inscription ContributeurStatut 21 septembre 2017 Dernière intervention - 27 nov. 2016 à 00:55
OK, c'est bon ...
Et je confirme : la formule =SI(C22=0;"";RECHERCHEV(C22;produits;2;0))
marche parfaitement bien !
Je te conseille de donner à la plage B4:B18 de la feuille "produit" le nom REFERENCE, que tu utiliseras comme source de liste déroulante de cellule dans ta colonne C
.
Répondre
mow- 27 nov. 2016 à 15:10
Je vais suivre vos conseils !
Merci beaucoup !!!
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour, avec une estvide()
Vaucluse 20342Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 19 septembre 2017 Dernière intervention - 27 nov. 2016 à 07:26
Bonjour
ce qu'on peut surtout confimer, pour l'avenir, c'est, comme déjà dit, qu'il n'est pas possible placer en D22 une formule qui commence par la même adresse, soit SI(D22....) interdit

Par ailleur en I27 le total sera probablement faux vu qu'il ne concerne que I18:I21! et en I29 la remise s'ajoute au total?

crdlmnt
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !