Signaler

Fonction NB.SI.ENS = 0 [Résolu]

Posez votre question zorg - Dernière réponse le 25 nov. 2016 à 16:57
Bonjour à tous,

Je me permets de vous solliciter au sujet d'un problème de formule sur Excel 2013.

Je dispose de deux feuilles, une pour les données brutes et une pour les calculs.

Mon problème est le suivant, lorsque j'utilise la formule :
=NB.SI.ENS('Métropole Lilloise'!$BF$4:$BF$75;'Listes Lille'!$C$47;'Métropole Lilloise'!$AG$4:$AG$75;'Listes Lille'!$AD$22), le résultat est "0" (je l'ai bien entendu vérifié, et il est faux).

Ce qui m'étonne d'autant plus, c'est que pour la formule :
=NB.SI.ENS('Métropole Lilloise'!$B$4:$B$75;'Listes Lille'!$C$5;'Métropole Lilloise'!$F$4:$F$75;"<5"), le résultat est bon. Je précise au passage, que pour cette dernière, le résultat était "0" (et donc faux) lorsque mon critère n°1 était "<5".

Le format de mes cellules est en Standard, ne sachant pas si cela pouvait influencer je l'ai modifié en "texte", mais ça n'a eu aucun effet.

Les données qui figure dans les plages "BF4:BF75" et "AG4:AG75" sont : "Oui", "Non", "NSP".
Les données de la plage "B4:B75" sont : "Femme" et "Homme".
Les données de la plage "F4:F75" sont des nombres pouvant aller de 0 à 10.

Auriez par hasard une idée à me proposer ?

En vous remerciant par avance,
Afficher la suite 
Utile
+1
moins plus
Bonjour
Les formules sont écrites correctement et sans le fichier il ne va pas être facile de vous aider!
si vous pouvez déposer un modèle sur:
http://www.cjoint.com
en en supprimant ou bidonnant tout ce qui pourrait être confidentiel
et revenir ici coller le lien donné par le site, on y verrait plus clair

à défaut, dites nous au moins ce que vous avez en
Listes Lille'!$C$47
Listes Lille'!$AD$22

pour assurer les correspondances avec
'Métropole Lilloise'!$BF$4:$BF$75 et $AG$4:$AG$75

et aussi, si vos données viennent de l'extèrieur, vérifiez qu'il n'y ait pas de caractères parasites (comme des blancs par exemple en fin ou début de texte)
à vous lire

crdlmnt
Ajouter un commentaire
Utile
+0
moins plus
Je vous remercie pour votre réponse, je vous joins le lien Cjoint :
http://www.cjoint.com/c/FKzoCrbTn8P

J'ai surligné en jaune les cellules utiles.

Avec mes remerciements
Vaucluse 18206Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 25 novembre 2016 Dernière intervention - 25 nov. 2016 à 16:11
Bien vu le fichier, mais ça ne permet pas de situer votre problème
si on prend votre formule du 1° message au pied de la lettre sans toutefois savoir où vous voulez la placer, on constate que vous cherchez avec NB.SI.ENS:
  • la valeur de C47 dans la colonne BF ça on peut le comprendre
  • la valeur de AD22 dans la colonne AG alors qu'en AD22 vous avez le résultat du décompte du nombre de oui dans la colonne et là on ne voit pas ou vous voulez en venir?


à vous lire
Répondre
zorg- 25 nov. 2016 à 16:57
Mais c'est bien sûr ! Effectivement je me suis emmêlé les pinceaux avec les cellules et ai remplacé C22 par AD22.

Je vous remercie et m'excuse pour la trivialité de cette question.

Bien cordialement
Répondre
Ajouter un commentaire

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !