Fonction si et recherche V [Résolu/Fermé]

sarame12 4 Messages postés jeudi 24 novembre 2016Date d'inscription 29 novembre 2016 Dernière intervention - 24 nov. 2016 à 22:18 - Dernière réponse : sarame12 4 Messages postés jeudi 24 novembre 2016Date d'inscription 29 novembre 2016 Dernière intervention
- 29 nov. 2016 à 11:09
Bonjour,
novice sur Excel j'ai réussi à maîtriser le cumul de fonction SI pour récupérer des valeurs comprise entre 2 données: exemple:=SI(ET(C9>10;C9<20);C2;SI(ET(C9>21;C9<30);C3;SI(ET(C9>31;C9<50);C4;"")))
là ou je me perds c'est lorsque chaque fournisseur à des données différentes à récupérer...
je pensais à un cumul de la fonction SI et recherche V mais j'ai beaucoup de mal..
Si quelqu'un peut me guider ce serait super...
merci!
si besoin un fichier joint avec un exemple
http://www.cjoint.com/c/FKyvPoJRpgh

merci d'avance!
Afficher la suite 
4Messages postés jeudi 24 novembre 2016Date d'inscription 29 novembre 2016 Dernière intervention

6 réponses

DjiDji59430 1766 Messages postés samedi 19 avril 2008Date d'inscription 11 décembre 2017 Dernière intervention - 25 nov. 2016 à 00:34
0
Utile
3
Bonjour,

Comme ça ?

http://www.cjoint.com/c/FKyxIcRwot3

Crdmt
sarame12 4 Messages postés jeudi 24 novembre 2016Date d'inscription 29 novembre 2016 Dernière intervention - 25 nov. 2016 à 17:26
Bonjour, je vous remercie la formule est parfaite, je l'ai appliquée sur mon tableau, elle fonctionne parfaitement. J'ai juste un souci lorsque je veux l'appliquer sur un cas un peu différent.
Je dois récupérer un km en fonction du produit et du fournisseur et ensuite avoir un résultat selon le produit et l'énergie consommée.
J'ai trouvé une fonction SI qui fonctionne mais dès que je fais glisser la formule sur d'autres fournisseurs cela ne fonctionne plus.
Un peu d'aide serait la bienvenue... n'hésitez pas si vous avez des questions
je vous remercie
http://www.cjoint.com/c/FKzqx1ehvxu
DjiDji59430 1766 Messages postés samedi 19 avril 2008Date d'inscription 11 décembre 2017 Dernière intervention > sarame12 4 Messages postés jeudi 24 novembre 2016Date d'inscription 29 novembre 2016 Dernière intervention - 26 nov. 2016 à 17:18
sarame12 4 Messages postés jeudi 24 novembre 2016Date d'inscription 29 novembre 2016 Dernière intervention > DjiDji59430 1766 Messages postés samedi 19 avril 2008Date d'inscription 11 décembre 2017 Dernière intervention - 29 nov. 2016 à 11:09
Merci Djidji pout ton aide. Mon problème est résolu.
Raymond PENTIER 44513 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 12 décembre 2017 Dernière intervention - 25 nov. 2016 à 00:59
0
Utile
1
Bonjour sarame12.

Si les références de ton message correspondaient au fichier joint, ce serait plus facile pour nous de comprendre ce que tu veux :
La cellule C9 est vide ! Je suppose que tu voulais écrire C13 ?
Heureusement, DjiDji59430 a réussi à interpréter tout cela et à te fournir une solution ...

Mais si j'interviens, c'est surtout pour t'indiquer qu'il vaut mieux remplacer
=SI(ET(C9>10;C9<20);C2;SI(ET(C9>21;C9<30);C3;SI(ET(C9>31; C9<50);C4;"")))
par
=SI(ET(C9>10;C9<20);C2;SI(C9<30;C3;SI(C9<50;C4;"")))
sarame12 4 Messages postés jeudi 24 novembre 2016Date d'inscription 29 novembre 2016 Dernière intervention - 25 nov. 2016 à 17:28
Bonjour, oui j'ai copié la formule d'un autre fichier, c'est pour cela. Merci pour ta suggestion de formule, effectivement c'est bien moins long.