Menu

Addition de vrai ou faux [Résolu/Fermé]

helydim 6 Messages postés mardi 15 mars 2016Date d'inscription 24 novembre 2016 Dernière intervention - 23 nov. 2016 à 23:03 - Dernière réponse : helydim 6 Messages postés mardi 15 mars 2016Date d'inscription 24 novembre 2016 Dernière intervention
- 24 nov. 2016 à 00:14
bonsoir;

je suis novice en excel
je cherche désespérément une formule pour additionner des vrai ou faux dans une même colonne afin de calculer la moyenne et la transcrire en % par la suite

a savoir que ces vrai et faux découle d'une formule qui est en réponse de la feuil 1 et que ma moyenne doit se trouver en feuil 2 sous la colonne des formules transcrite en vrai et faux
=SI(Feuil1!C1="buy";"VRAI";"FAUX")

j’espère avoir pu exposer mon problème assez clairement (bien que j'en doute )

pourriez-vous me dire comment faire?
un grand merci à vous
Afficher la suite 

6 réponses

eriiic 21368 Messages postés mardi 11 septembre 2007Date d'inscriptionContributeurStatut 19 février 2018 Dernière intervention - 23 nov. 2016 à 23:18
0
Utile
Bonjour,

=NB.SI(C:C;VRAI)/(NBVAL(C:C)-1)

-1 pour une ligne de titre
eric
Gyrus 3341 Messages postés samedi 20 juillet 2013Date d'inscription 9 décembre 2016 Dernière intervention - 23 nov. 2016 à 23:20
0
Utile
1
Bonsoir,

Exemple avec les résultats "VRAI" et "FAUX" en Feuil2!A1:A100,
Pour la somme des "VRAI" :
=SOMMEPROD((A1:A100="VRAI")*1)
Pour la somme des "FAUX" :
=SOMMEPROD((A1:A100="FAUX")*1)

A+
helydim 6 Messages postés mardi 15 mars 2016Date d'inscription 24 novembre 2016 Dernière intervention - 24 nov. 2016 à 00:14
MERCI MERCI MERCI

super à vous de votre attention
helydim 6 Messages postés mardi 15 mars 2016Date d'inscription 24 novembre 2016 Dernière intervention - 23 nov. 2016 à 23:33
0
Utile
1
bonsoir eriiic
un grand merci pour votre réponse si rapide
je viens de tester votre formule sur mon fichier excel
hélas en vain

je ne sais si c'est moi qui m'y prend mal ou si j'ai une erreur dans mon fichier,

mais la réponse que j'obtiens est 0
j'ai 119 ligne avec des vrai et faux
je me suis mise sur la 120em pour inscrire votre formule
(j'ai fais un copier-coller)

où est-ce que je me trompe?

en avez-vous une idée?

encore merci à vous pour l'attention portée a mon problème

Hely
eriiic 21368 Messages postés mardi 11 septembre 2007Date d'inscriptionContributeurStatut 19 février 2018 Dernière intervention - 23 nov. 2016 à 23:36
Il faudrait peut-être dire l'erreur...
je me suis mise sur la 120em pour inscrire votre formule
Ben non puisque la formule regarde toute la colonne ça fait une référence circulaire indésirable.
Mets-dans une colonne à coté ou bien précise la plage au lieu de C:C
Et tu as le droit de remercier le 2nd intervenant, ne serait-ce que pour signaler que tu as lu.
helydim 6 Messages postés mardi 15 mars 2016Date d'inscription 24 novembre 2016 Dernière intervention - 23 nov. 2016 à 23:46
0
Utile
Un immense merci tant à eriiic qu'a Gyrus

Super contente, le problème est résolu

Merci pour votre attention et la rapidité de vos réactions

Bonne soirée à vous