Signaler

Addition de vrai ou faux [Résolu]

Posez votre question helydim 6Messages postés mardi 15 mars 2016Date d'inscription 24 novembre 2016 Dernière intervention - Dernière réponse le 24 nov. 2016 à 00:14
bonsoir;

je suis novice en excel
je cherche désespérément une formule pour additionner des vrai ou faux dans une même colonne afin de calculer la moyenne et la transcrire en % par la suite

a savoir que ces vrai et faux découle d'une formule qui est en réponse de la feuil 1 et que ma moyenne doit se trouver en feuil 2 sous la colonne des formules transcrite en vrai et faux
=SI(Feuil1!C1="buy";"VRAI";"FAUX")

j’espère avoir pu exposer mon problème assez clairement (bien que j'en doute )

pourriez-vous me dire comment faire?
un grand merci à vous
Afficher la suite 
Utile
+0
moins plus
Bonjour,

=NB.SI(C:C;VRAI)/(NBVAL(C:C)-1)

-1 pour une ligne de titre
eric
Ajouter un commentaire
Utile
+0
moins plus
Bonsoir,

Exemple avec les résultats "VRAI" et "FAUX" en Feuil2!A1:A100,
Pour la somme des "VRAI" :
=SOMMEPROD((A1:A100="VRAI")*1)
Pour la somme des "FAUX" :
=SOMMEPROD((A1:A100="FAUX")*1)

A+
helydim 6Messages postés mardi 15 mars 2016Date d'inscription 24 novembre 2016 Dernière intervention - 24 nov. 2016 à 00:14
MERCI MERCI MERCI

super à vous de votre attention
Répondre
Ajouter un commentaire
Utile
+0
moins plus
bonsoir eriiic
un grand merci pour votre réponse si rapide
je viens de tester votre formule sur mon fichier excel
hélas en vain

je ne sais si c'est moi qui m'y prend mal ou si j'ai une erreur dans mon fichier,

mais la réponse que j'obtiens est 0
j'ai 119 ligne avec des vrai et faux
je me suis mise sur la 120em pour inscrire votre formule
(j'ai fais un copier-coller)

où est-ce que je me trompe?

en avez-vous une idée?

encore merci à vous pour l'attention portée a mon problème

Hely
eriiic 20015Messages postés mardi 11 septembre 2007Date d'inscription ContributeurStatut 9 décembre 2016 Dernière intervention - 23 nov. 2016 à 23:36
Il faudrait peut-être dire l'erreur...
je me suis mise sur la 120em pour inscrire votre formule
Ben non puisque la formule regarde toute la colonne ça fait une référence circulaire indésirable.
Mets-dans une colonne à coté ou bien précise la plage au lieu de C:C
Et tu as le droit de remercier le 2nd intervenant, ne serait-ce que pour signaler que tu as lu.
Répondre
Ajouter un commentaire
Utile
+0
moins plus
Un immense merci tant à eriiic qu'a Gyrus

Super contente, le problème est résolu

Merci pour votre attention et la rapidité de vos réactions

Bonne soirée à vous
Ajouter un commentaire

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !