Signaler

Problème de connexion avec ssh [Résolu]

Posez votre question fatou.diene22 26Messages postés dimanche 24 février 2013Date d'inscription 25 novembre 2016 Dernière intervention - Dernière réponse le 25 nov. 2016 à 19:55
Bonjour j'ai configuré un serveur sftp qui marche bien j'arrive à me connecter avec filezila mais mon problème est que j'arrive pas à me connecter avec ssh à distance putty se ferme des que je me logue .
Voici mon fichier de configuration de mon serveur sftp

#sudo apt-get update
#sudo apt-get install openssh-server
#sudo groupadd sftponly
#cat /etc/group
#sudo useradd abc -d / -g 1001 -M -N -o -u 1001
#sudo passwd abc
#cat /etc/passwd
#sudo cp /etc/ssh/sshd_config /etc/ssh/sshd_config.bak
#sudo nano +76 /etc/ssh/sshd_config
Je me place à la 76 eme ligne du fichier et je remplace "Subsystem sftp /usr/lib/openssh/sftp-server" par Subsystem sftp internal-sftp
Ensuite à la fin du fichier j'ai ajouté les lignes suivantes:
" Match group sftponly
ChrootDirectory /var/www
X11Forwarding no
AllowTcpForwarding no
ForceCommond internal-sftp
"
Le reste je laisse tout par défaut j'enregistre te je quitte .
Enuite j'ai fait
sudo mkdir /var/www
cd /var/www
sudo mkdir test_readonly
sudo chmod 755 test_readonly
sudo mkdir test_readwrite
sudo chown root:sftponly test_readwrite
sudo chmod 775 test_readwrite
sudo mkdir test_noaccess
sudo chmod 733 test_noaccess
sudo /etc/init.d/ssh restart

Et la conexion avec filezila marche mon probleme est que je ne peux pas acceder à mon serveur à distance avec ssh putty se ferme desque je me logue
Qui pour m'aider?
Afficher la suite 
Utile
+0
moins plus
Salut,

ForceCommond internal-sftp

Est-ce une faute de frappe ou un copier/coller de ton fichier ?

Ajouter un commentaire
Utile
+0
moins plus
Bonjour,

Tu ne peux pas utiliser le même utilisateur pour SSH et SFTP, il faut créer des utilisateurs distincts.

C'est pour ça que putty se ferme lorsque tu te log.
Ajouter un commentaire
Utile
+0
moins plus
UnGnU c'est une fautre d'ecriture c'est ForceCommand internal-sftp au lieu de ForceCommond internal-sftp
Ajouter un commentaire
Utile
+0
moins plus
Bernabe0057 j'ai crée un autre utilisateur pour la connexion ssh mais putty se ferme des que l'uilisateur se logue et pourtant et pourtant si le mot de passe de l'utilisateur est erroné il te dit acces denied et te demande de retaper le mot de passe et des que c'est correcte putty se ferme automatiquement.
barnabe0057 8766Messages postés lundi 2 mars 2009Date d'inscription ContributeurStatut 30 novembre 2016 Dernière intervention - 24 nov. 2016 à 10:31
Il faut ajouter la directive AllowUsers ou AllowGroups avant la partie concernant SFTP.

exemple :

AllowUsers fatou barnabe0057 toto

Tu comprends ?
Répondre
fatou.diene22- 24 nov. 2016 à 10:44
Non je ne comprend pas
Répondre
barnabe0057 8766Messages postés lundi 2 mars 2009Date d'inscription ContributeurStatut 30 novembre 2016 Dernière intervention - 24 nov. 2016 à 10:52
Il faut que tu dises à SSH quels sont les utilisateurs autorisés à se connecter, ça se fait avec la directive AllowUsers dans le fichier /etc/ssh/sshd_config

Encore une fois je précise qu'il faut des utilisateurs différents pour SSH et pour SFTP.
Répondre
Ajouter un commentaire
Utile
+0
moins plus
la je comprend un peu plus donc supposons que je voulais dire à ssh que les utilisateurs autorisés à se connecter avec ssh sont : fatou, saliou et modou qu'est ce que je dois ajouter dans le fichier??
barnabe0057- 24 nov. 2016 à 12:13
Il faudra ajouter ceci :

AllowUsers fatou saliou modou

Ces trois-là ne pourront pas se connecter en SFTP, juste en SSH.
Répondre
Ajouter un commentaire
Utile
+0
moins plus
je l'ai fait j'ai crée 3 utilisateur feuz, dio12345 et sarr je les ai autorisé à se connecter avec sh en ajoutant la ligne suivante: AllowUsers feuz dio12345 sarr au fichier de configuration
/etc/ss/sshd_config
mais le probleme persiste putty se ferme directement des que l'utilisateur se logue correctement
Ajouter un commentaire
Utile
+0
moins plus
je l'ai fait j'ai crée 3 utilisateur feuz, dio12345 et sarr je les ai autorisé à se connecter avec sh en ajoutant la ligne suivante: AllowUsers feuz dio12345 sarr au fichier de configuration
/etc/ssh/sshd_config
mais le probleme persiste putty se ferme directement des que l'utilisateur se logue correctement
barnabe0057- 24 nov. 2016 à 13:29
Voilà à quoi doit ressembler ton fichier /etc/ssh/sshd_config :

# Package generated configuration file
# See the sshd_config(5) manpage for details

# What ports, IPs and protocols we listen for
Port 22

# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
ListenAddress 0.0.0.0
Protocol 2

# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
HostKey /etc/ssh/ssh_host_ecdsa_key
HostKey /etc/ssh/ssh_host_ed25519_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 1024

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin without-password
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile %h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
PasswordAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

X11Forwarding no
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
ClientAliveInterval 30
TCPKeepAlive yes
ClientAliveCountMax 1200
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net

AllowUsers feuz dio12345 sarr

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

# Subsystem sftp /usr/lib/openssh/sftp-server

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication. Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.

Subsystem sftp internal-sftp
Match group sftponly
ChrootDirectory /var/www
X11Forwarding no
AllowTcpForwarding no


# UsePAM yes
# GatewayPorts yes
Répondre
Ajouter un commentaire
Utile
+0
moins plus
pourtant c'est ce k j'ai fait sauf que j'ai mis entre guillemets
"Subsystem sftp internal-sftp
Match group sftponly
ChrootDirectory /var/www
X11Forwarding no
AllowTcpForwarding no
"

et je les placé à l fin du fichier juste après UsePAM yes
barnabe0057- 24 nov. 2016 à 14:30
Enlève les guillemets.
Répondre
Ajouter un commentaire
Utile
+0
moins plus
j'ai enlevé les guillemets mais toujours meme chose
UnGnU 228Messages postés lundi 2 mai 2016Date d'inscription 30 novembre 2016 Dernière intervention - 24 nov. 2016 à 14:48
Salut,

As-tu relancé les services après chaque modification ?
Répondre
Ajouter un commentaire
Utile
+0
moins plus
oui j'ai bien relançé les services après chaque modification
barnabe0057 8766Messages postés lundi 2 mars 2009Date d'inscription ContributeurStatut 30 novembre 2016 Dernière intervention - 24 nov. 2016 à 16:47
Est-ce qu'on pourrait voir ton fichier ?
Répondre
Ajouter un commentaire
Utile
+0
moins plus
Attend je monte ma clé usb pour recuperer le fichier de configuration et je le poste
Ajouter un commentaire
Utile
+0
moins plus
# Package generated configuration file
# See the sshd_config(5) manpage for details

# What ports, IPs and protocols we listen for
Port 22

# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
ListenAddress 0.0.0.0
Protocol 2

# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
HostKey /etc/ssh/ssh_host_ecdsa_key
HostKey /etc/ssh/ssh_host_ed25519_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 1024

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin without-password
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile %h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
PasswordAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

X11Forwarding no
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
ClientAliveInterval 30
TCPKeepAlive yes
ClientAliveCountMax 1200
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net

AllowUsers feuz dio12345 sarr

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

# Subsystem sftp internal-sftp

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication. Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.



# UsePAM yes
Subsystem sftp internal-sftp
Match group sftponly
ChrootDirectory /var/www
X11Forwarding no
AllowTcpForwarding no
# GatewayPorts yes
barnabe0057 8766Messages postés lundi 2 mars 2009Date d'inscription ContributeurStatut 30 novembre 2016 Dernière intervention - 25 nov. 2016 à 11:14
Tout est correct.

Tu as pensé à créer les utilisateurs feuz dio12345 sarr ???

Est-ce que ces utilisateurs font parti du groupe sftponly ?
Répondre
Ajouter un commentaire
Utile
+0
moins plus
Bernabe c'est ça mon fichier de configuration mais constaté que la ligne PasswordAuthentication yes c'est commenté par défaut chez moi et j'ai vu que c'est pas le cas chez toi j'ai pas aussi la ligne # GatewayPorts yes
Je ne sais po si c'est grave ou pas


J'ai aussi cré les users dio12345 feuz et sarr en les ajoutant au groupe sftponly avec les commandes suivants:
sudo useradd feuz -d / -g 1001 -M -N -o -u 1001
sudo useradd sarr -d / -g 1001 -M -N -o -u 1001
sudo useradd dio12345 -d / -g 1001 -M -N -o -u 1001


et j'ai définit le mot de passe pour chaque user
barnabe0057 8766Messages postés lundi 2 mars 2009Date d'inscription ContributeurStatut 30 novembre 2016 Dernière intervention - 25 nov. 2016 à 12:45
Comme je l'ai déjà dit, les utilisateurs SSH et SFTP doivent être distincts, à cause du chroot.

Donc il ne faut pas que dio12345 feuz et sarr fassent partie du groupe sftponly.
Répondre
barnabe0057 8766Messages postés lundi 2 mars 2009Date d'inscription ContributeurStatut 30 novembre 2016 Dernière intervention - 25 nov. 2016 à 12:48
Si la ligne PasswordAuthentication yes était commentée, le problème vient peut-être de là.

Tu peux laisser la ligne # GatewayPorts yes commentée, sauf si tu te trouves derrière une box (ou une passerelle quelconque).
Répondre
fatou.diene22 26Messages postés dimanche 24 février 2013Date d'inscription 25 novembre 2016 Dernière intervention - 25 nov. 2016 à 13:01
en ok donc si je comprend bien je doit creer d'autre user et ne pas les ajouter au groupe sftp only
supposons que je voulais creer un utilisateur pape pour la connexion ssh qu'est ce que je dois mettre à la place de sudo useradd feuz -d / -g 1001 -M -N -o -u 1001?
mais aussi j'ai pas la ligne # GatewayPorts yes ça ne figure pas j'au aussi décommenté la ligne PasswordAuthentication yes
Répondre
barnabe0057 8766Messages postés lundi 2 mars 2009Date d'inscription ContributeurStatut 30 novembre 2016 Dernière intervention - 25 nov. 2016 à 13:12
sudo useradd pape -d /var/www -Mn 
sudo passwd pape
Répondre
Ajouter un commentaire
Utile
+0
moins plus
ok d' acord attend je teste ça pour voir je te donnerai le résultat
fatou.diene22 26Messages postés dimanche 24 février 2013Date d'inscription 25 novembre 2016 Dernière intervention - 25 nov. 2016 à 14:55
je l'ai fait mais j'obtiens toujours la même erreur
sudo useradd -d /var/www -Mn pape
Répondre
barnabe0057 8766Messages postés lundi 2 mars 2009Date d'inscription ContributeurStatut 30 novembre 2016 Dernière intervention - 25 nov. 2016 à 15:05
sudo useradd -Mn pape
Répondre
fatou.diene22 26Messages postés dimanche 24 février 2013Date d'inscription 25 novembre 2016 Dernière intervention - 25 nov. 2016 à 15:14
toujours la même chose ça ne passe pas
Répondre
barnabe0057 8766Messages postés lundi 2 mars 2009Date d'inscription ContributeurStatut 30 novembre 2016 Dernière intervention - 25 nov. 2016 à 16:10
C'est le commutateur -n qui pose problème, il n'existe plus.

Il faut donc taper :

sudo useradd -M pape
Répondre
fatou.diene22 26Messages postés dimanche 24 février 2013Date d'inscription 25 novembre 2016 Dernière intervention - 25 nov. 2016 à 16:16
ça passe apparemment mais je veux k l'utilisateur se pointe sur le repertoire /var/www desqu'il se connecte donc je peux faire

sudo useradd pape -d /var/www -Mn
sudo passwd pape
?
Répondre
Ajouter un commentaire
Utile
+0
moins plus
ça marche maintenant j'ai fait la commande suivante pour la création des users sudo useradd -d /var/www -M pape

comme ça si l'utilisateur se connecte il se positionne directement dans le repertoire de partage /var/www

et j'ai ajouté dans le fichier de configuration
AllowUsers pape et ça marche tres bien maintenant merci beaucoup c'est vraiment gent merci infiniement
Ajouter un commentaire
Utile
+0
moins plus
maintenant j'ai constaté que je ne peux pas me connecter en tant que root sur ssh j'ai mis PermitRootLogin yes mais ça n'as pas réussi par contre les autres utilisateurs se connectent correctement alors que je dois creer un dossier chaque jour pour effectuer un backup et c'est fastidieux d'aller toujours sur la machine physique pour creer ce dossier
barnabe0057 8766Messages postés lundi 2 mars 2009Date d'inscription ContributeurStatut 30 novembre 2016 Dernière intervention - 25 nov. 2016 à 19:55
Pas besoin de se connecter en root, tu te connectes en tant que pape ou un autre utilisateur et tu utilises la commande sudo, non ?
Répondre
Ajouter un commentaire

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !