Signaler

Problème de lancement de Talend TOS_BD-win-x86_64 [Résolu]

Posez votre question AsmaData 6Messages postés vendredi 18 novembre 2016Date d'inscription 9 décembre 2016 Dernière intervention - Dernière réponse le 23 nov. 2016 à 13:44
Bonjour,

Après décompression du fichier installation de Talend avec 7-zip, et quand je veux lancer TOS_BD-win-x86_64, je reçois le message suivant (en pj).
En ce moment que je devrai faire? je n'ai pas saisi la situation.
merci
Afficher la suite 
Utile
+0
moins plus
Bonjour,

Il faudrait que tu installes un JDK et que tu configures les variables d'environnement JAVA_HOME et PATH.
Je t'invites à désinstaller au préalable toutes les versions de Java que tu peux avoir sur ton ordinateur.

Désinstallation de Java :
https://www.java.com/fr/download/help/uninstall_java.xml

Installation du JDK :
http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html

Configuration du PATH :
https://www.java.com/fr/download/help/path.xml
AsmaData 6Messages postés vendredi 18 novembre 2016Date d'inscription 9 décembre 2016 Dernière intervention - 19 nov. 2016 à 13:37
Merci KX,
j'ai passé par toutes ces étapes tout à l'heure, et je reçois le même message
pour JAVA_HOME C:\Program Files (x86)\Java\jre1.8.0_111
et pour
Path
C:\ProgramData\Oracle\Java\javapath;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Skype\Phone\;%JAVA_HOME%\bin
Répondre
KX 13755Messages postés samedi 31 mai 2008Date d'inscription ModérateurStatut 10 décembre 2016 Dernière intervention - 19 nov. 2016 à 14:26
Ton ordinateur est en 32 bits ? Parce que s'il est en 64 bits il aurait mieux fallu installer cette version là de Java, qui serait alors dans "Program Files" et non "Program Files (x86)"
De plus, il vaudrait mieux faire pointer JAVA_HOME sur le JDK et non sur la JRE :
C:\Program Files\Java\jdk1.8.0_111

Et enfin, et c'est le plus important, il faudrait mettre JAVA_HOME au début du PATH et non à la fin, car sinon C:\ProgramData\Oracle\Java\javapath (qui a priori ne sers plus à rien) va être pris en premier et c'est lui qui va lancer ton programme.

Répondre
AsmaData 6Messages postés vendredi 18 novembre 2016Date d'inscription 9 décembre 2016 Dernière intervention - 19 nov. 2016 à 20:34
Merci KX,
1- Mon système d'exploitation est 64 bits
mais je ne comprend pas pourquoi je trouve noté 32
system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32


2- J'ai changé la version de Java maintenant après désinstallation de l'ancienne
voila la JAVA_HOME C:\Program Files\Java\jdk1.8.0_112
et mon Path C:\%JAVA_HOME%\bin;\ProgramData\Oracle\Java\javapath;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Skype\Phone\
voila ce que je reçois , vraiment c'est embêtant.
An error has occured , see the log file...........
et dans le log file je trouve un long texte, voila une partie car malheureusement il n'ya pas ou joindre des photos, sauf si je vais lancer un nouveau post:
!SESSION Sat Nov 19 20:32:13 GMT+01:00 2016 ------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2016-11-19 20:32:13.045
!MESSAGE Could not find extension: org.talend.osgi.lib.loader
!SESSION 2016-11-19 20:32:12.865 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_112
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=fr_FR
Command-line arguments: -os win32 -ws win32 -arch x86_64

!ENTRY org.eclipse.osgi 4 0 2016-11-19 20:32:13.710
!MESSAGE Bundle org.talend.osgi.lib.loader not found.

!ENTRY org.eclipse.osgi 4 0 2016-11-19 20:32:13.720
!MESSAGE Bundle org.talend.maven.resolver@start not found.

!ENTRY net.jeeeyul.eclipse.themes 4 0 2016-11-19 20:32:13.912
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: net.jeeeyul.eclipse.themes [32]
Unresolved requirement: Require-Bundle: org.eclipse.ui
-> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.106.0.v20140812-1751"; singleton:="true"
org.eclipse.ui [451]
Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.106.1.v20140827-1737"; singleton:="true"
org.eclipse.ui.workbench [450]
Unresolved requirement: Import-Package: org.eclipse.e4.ui.internal.workbench.renderers.swt
-> Export-Package: org.eclipse.e4.ui.internal.workbench.renderers.swt; bundle-symbolic-name="org.eclipse.e4.ui.workbench.renderers.swt"; bundle-version="0.12.1.v20140903-1023"; version="0.0.0"; x-friends:="org.eclipse.ui.workbench"
org.eclipse.e4.ui.workbench.renderers.swt [140]
Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.workbench.swt; bundle-version="0.9.0"
-> Bundle-SymbolicName: org.eclipse.e4.ui.workbench.swt; bundle-version="0.12.100.v20140530-1436"; singleton:="true"
org.eclipse.e4.ui.workbench.swt [141]
Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.css.core; bundle-version="0.9.0"
-> Bundle-SymbolicName: org.eclipse.e4.ui.css.core; bundle-version="0.10.100.v20140424-2042"; singleton:="true"
org.eclipse.e4.ui.css.core [130]
Unresolved requirement: Require-Bundle: org.w3c.css.sac; bundle-version="1.3.0"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.ant.ui 4 0 2016-11-19 20:32:13.922
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.ant.ui [81]
Unresolved requirement: Require-Bundle: org.eclipse.ui.editors; bundle-version="[3.2.0,4.0.0)"; resolution:="optional"
-> Bundle-SymbolicName: org.eclipse.ui.editors; bundle-version="3.8.200.v20140401-1310"; singleton:="true"
org.eclipse.ui.editors [433]
Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.5.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.10.1.v20140828-0944"; singleton:="true"
org.eclipse.ui.ide [437]
Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.106.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.106.0.v20140812-1751"; singleton:="true"
org.eclipse.ui [451]
Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.106.1.v20140827-1737"; singleton:="true"
org.eclipse.ui.workbench [450]
Unresolved requirement: Import-Package: org.eclipse.e4.ui.internal.workbench.renderers.swt
-> Export-Package: org.eclipse.e4.ui.internal.workbench.renderers.swt; bundle-symbolic-name="org.eclipse.e4.ui.workbench.renderers.swt"; bundle-version="0.12.1.v20140903-1023"; version="0.0.0"; x-friends:="org.eclipse.ui.workbench"
org.eclipse.e4.ui.workbench.renderers.swt [140]
Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.workbench.swt; bundle-version="0.9.0"
-> Bundle-SymbolicName: org.eclipse.e4.ui.workbench.swt; bundle-version="0.12.100.v20140530-1436"; singleton:="true"
org.eclipse.e4.ui.workbench.swt [141]
Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.css.core; bundle-version="0.9.0"
-> Bundle-SymbolicName: org.eclipse.e4.ui.css.core; bundle-version="0.10.100.v20140424-2042"; singleton:="true"
org.eclipse.e4.ui.css.core [130]
Unresolved requirement: Require-Bundle: org.w3c.css.sac; bundle-version="1.3.0"
Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench.texteditor; bundle-version="[3.5.0,4.0.0)"; resolution:="optional"
-> Bundle-SymbolicName: org.eclipse.ui.workbench.texteditor; bundle-version="3.9.0.v20140411-1521"; singleton:="true"
org.eclipse.ui.workbench.texteditor [449]
Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.106.0.v20140812-1751"; singleton:="true"
Unresolved requirement: Require-Bundle: org.eclipse.ui.externaltools; bundle-version="[3.2.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.ui.externaltools; bundle-version="3.2.300.v20140327-1949"; singleton:="true"
org.eclipse.ui.externaltools [434]
Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.2.0,4.0.0)"; resolution:="optional"
-> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.10.1.v20140828-0944"; singleton:="true"
Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.2.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.106.0.v20140812-1751"; singleton:="true"
Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.2.0,4.0.0)"; resolution:="optional"
-> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.10.1.v20140828-0944"; singleton:="true"
Unresolved requirement: Require-Bundle: org.eclipse.ui.views; bundle-version="[3.2.0,4.0.0)"; resolution:="optional"
-> Bundle-SymbolicName: org.eclipse.ui.views; bundle-version="3.7.0.v20140408-0703"; singleton:="true"
org.eclipse.ui.views [446]
Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.106.0.v20140812-1751"; singleton:="true"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)


Merci pour votre patience et votre collaboration
Répondre
AsmaData 6Messages postés vendredi 18 novembre 2016Date d'inscription 9 décembre 2016 Dernière intervention - 23 nov. 2016 à 13:44
bonjour,
j'ai laché la version 6.3.0, il parait à cause de sa mauvaise décompression que se génèrent les problèmes de configuration.
J'ai installé la version 6.2.1, et jusqu'à maintenant tout va bien.
Je suis à la découverte de ce Talend
merci
Répondre
Ajouter un commentaire

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !