Menu

Sur Excel ou Access : Suppression compliquée [Résolu/Fermé]

chploux 7 Messages postés dimanche 7 septembre 2014Date d'inscription 22 novembre 2017 Dernière intervention - 17 nov. 2016 à 14:43 - Dernière réponse : chploux 7 Messages postés dimanche 7 septembre 2014Date d'inscription 22 novembre 2017 Dernière intervention
- 24 nov. 2016 à 16:47
Bonjour,

Voici mon problème, j'ai fait une extraction sur Access pour avoir tous les clients d'une certaine région, puis une jointure pour lister l'ensemble d'équipement du client en produit.

(je suis passée sur Excel pour vérifier mon fichier)

Ex :
client 1 - Produit X
client 1 - Produit Y
client 1 - Produit Z
client 2 - Produit D
client 2 - Produit Z
client 3 - Produit W
client 3 - Produit Y

Je souhaite supprimer tous les clients équipés du Produits Z, or quand je filtre par "Pas comme *Produit Z* ou que je fais un filtre, cela supprime la ligne mais pas le client.

Mon fichier devient tout a fait erroné :

client 1 - Produit X
client 1 - Produit Y
client 2 - Produit D
client 3 - Produit W
client 3 - Produit Y

Le résultat que je voudrai avoir :

C'est un tableau avec uniquement les clients n'ayant pas le produit Z donc :

client 3 - Produit W
client 3 - Produit Y

Par la suite je supprimerai les doublons, encore faut-il en arriver là ..

Je vous remercie pour votre temps et pour vos réponses,
Rita
Afficher la suite 

4 réponses

eriiic 21375 Messages postés mardi 11 septembre 2007Date d'inscriptionContributeurStatut 21 février 2018 Dernière intervention - 17 nov. 2016 à 16:18
+1
Utile
Bonjour,

ou filtrer sur :
=NB.SI.ENS(A:A;A2;B:B;"Produit Z")>0

eric
Cette réponse vous a-t-elle aidé ?  
chploux 7 Messages postés dimanche 7 septembre 2014Date d'inscription 22 novembre 2017 Dernière intervention - 17 nov. 2016 à 15:31
0
Utile
Je vais répondre à ma propre question, j'ai trouvé une solution un peu bricolée mais ça a marché ...

J'ai crée un tableau croisé dynamique de sorte à avoir un tableau comme ça


Porduit X Produit Y Produit Z
Client 1 1 0 1
Client 2 0 1 1
Client 3 1 1 0

Et je filtre par produit Z "0" ou "vide"

et j'obtiens ma liste de clients non équipés en produit Z

Voilà .. si jamais ça peut servir.
0
Utile
1
bonjour
est ce que le table client est reliée à la table produits?,
chploux 7 Messages postés dimanche 7 septembre 2014Date d'inscription 22 novembre 2017 Dernière intervention - 24 nov. 2016 à 16:47
Bonjour, désolée du retard et merci beaucoup pour tes réponses Eric
oui les deux tables sont reliées sur Acces ..
Je vais essayer avec ta formule