Signaler

Monter dossier de ma partition Windows dans home [Résolu]

Posez votre question Maia - Dernière réponse le 30 nov. 2016 à 19:03
Bonjour,

Tout d'abord veuillez me pardonner de ma miagre connaissance en informatique ainsi que de mon language peut être pas très clair

Voilà le topo , j ai un dual boot Windows-Linux , ma partition de Windows se monte automatiquement à chaque démarrage mais j'aimerai créer un raccourci d'un dossier de cette partition dans mon home , et donc qu'avec un simple clic ce dossier soit accessible au démarrage dans mon home .

Alors voilà mes questions
Il faut que je crée un répertoire dans mon home ? Par exemple
sudo mkdir /home/Mon Dossier Windows 


Et ensuite monter le dossier dans ce répertoire ?
Avec mount ?
Mais c'est là que je bloque

En l occurence ce dossier se trouve dans dev/sda2/Users/Mon dossier
Afficher la suite 
Utile
+0
moins plus
Ta partition windows se monte elle toute seule au démarrage ?

Si oui deux solutions :

1) Créer un lien symbolique avec la commande : ln -s /nom_du_dossier_source /home/nom_du_lien
2) Modifier le montage par défaut pour mettre a la place le dossier de ton souhait. C'est possible en utilisant l'application "Disques" par exemple.

Si non, voir point numéro 2.

Ne disposant pas de windows en dual-boot je ne pourrais pas te donner en détails la démarche, mais ça peut donner un bon début.
Ajouter un commentaire
Utile
+0
moins plus
Merci pour l'info je ne connaissais pas cette commande

J'ai fait "je pense" ce que tu m'as dit enfin ce que j ai compris du moins mais j ai le droit après la syntaxe
ln -s /media/denis/Windows/Users/denis la saumure/home/denis la saumure


ln: la cible 'saumure' n'est pas un répertoire
jisisv 3625Messages postés dimanche 18 mars 2001Date d'inscription ModérateurStatut 30 novembre 2016 Dernière intervention - 17 nov. 2016 à 14:37
Tu dois protéger les espaces des noms de fichiers/répertoires:
ln -s "/media/denis/Windows/Users/denis la saumure" "/home/denis la saumure/mon_joli_dossier"

ou
ln -s /media/denis/Windows/Users/denis\ la\ saumure /home/denis\ la\ saumure/mon_joli_dossier
Répondre
Maia- 17 nov. 2016 à 19:01
Merci de ton aide

J'ai 2 liens qui se sont crées dans mon /home mais ils sont brisés
Désolé j essaye de me servir des liens existant sur la commande ls mais pas facile à comprendre les syntaxes :(
Répondre
jisisv 3625Messages postés dimanche 18 mars 2001Date d'inscription ModérateurStatut 30 novembre 2016 Dernière intervention - 18 nov. 2016 à 16:26
A toi à adapter les chemins ! On ne va pas t'apprendre à faire pipi quand même. On est là pour donner des pistes, pas pour réfléchir à ta place.
Fais un
man 1 ls
Répondre
Maia- 18 nov. 2016 à 19:59
Oui je comprend bien et je t assure que j ai essayer de comprendre bon nombre de doc sur cette commande mais peut être un brin idiot mais ça n a pas marché .

J ai crée un dossier dans mon home Denis La Saumure et tapé cette commande
sudo ln -s /media/denis/Windows/Users/denis la saumure /home/denis la saumure


Mais voici la réponse

ln: la cible 'Saumure' n'est pas un répertoire


Je comprend parfaitement qu'il faut qu'on se débrouille par nos propres moyens et c'est ce que je souhaite mais j'avoue c'est compliqué et déroutant pour moi , je ne souhaite qu'une chose c'est que la console n est plus de secrets pour moi mais la route est longue quand je vois que je bloque sur une simple commande
Répondre
jisisv 3625Messages postés dimanche 18 mars 2001Date d'inscription ModérateurStatut 30 novembre 2016 Dernière intervention - 20 nov. 2016 à 07:38
Deux remarques
  • les noms de répertoires/fichiers contenant des espaces/tabulations doivent être protégés par des guillemets (simples ou doubles dans cette situation élémentaire)
  • la cible ne doit (peut) pas exister avant sa création , ce qui est assez logique

ohand@bata:~/tmp$ mkdir "L'horrible répertoire"
johand@bata:~/tmp$ ls -l L\'horrible\ répertoire/
total 0
johand@bata:~/tmp$ ln -s L\'horrible\ répertoire/ "Tout aussi&pourri"
johand@bata:~/tmp$ ls -l Tout\ aussi\&pourri
lrwxrwxrwx 1 johand johand 22 nov 20 07:32 Tout aussi&pourri -> L'horrible répertoire/


Sous Unix , ce n'est pas une bonne pratique d'utiliser des espaces/tabulations/guillemets et autres caractères spéciaux.... dans les noms d'objets de la hiérarchie de fichiers. Laisse cela aux neuneux Micro$oft qui n'utiliseront jamais une ligne de commande
Répondre
Ajouter un commentaire
Utile
+0
moins plus
Bon je reviens pour apporter quelques précisions

J'ai donc crée un dossier dans mon /home que j'ai appelé Windows avec la commande suivante

mkdir Windows


Puis lancé la commande suivante pour créer mon lien (raccourci)

ln -s /media/denis/Windows/Users/denis /home/denis/windows


Voilà tout simplement , excusez moi les gars mais l'histoire des " " et des espaces ça m'a embrouillé la tête , mais je suis très nul aussi je le reconnais .
Donc la commande 
ln -s (le chemin du raccourci ) Un espace entre les deux et ( le chemin de destination )
Ajouter un commentaire

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !