Signaler

Fonctions SI imbriquées [Résolu]

Posez votre question planeuse - Dernière réponse le 17 oct. 2016 à 13:10 par planeuse
Bonjour,

Je cherche à obtenir le résultat suivant mais ne parviens pas à trouver la formule adéquate.
Pouvez-vous m'aider ?
Merci

La cellule AP46 contient la lettre F ou I
Si AP46 = F et AP22 >=3218 alors 3218 x K3 sinon AP22 x K3 ou si AP46 = I et AP22 >=3218 alors 3218 x K2 sinon AP22 x K2

J'espère être suffisamment claire et suis à disposition pour toute précision.
Afficher la suite 
Utile
+0
plus moins
Bonjour,

Un truc du genre :


SI( AP46 = "F";SI(AP22 >=3218;3218*K3;AP22 * K3);SI(AP46="I";AP22>=3218;3218*k2;AP22*K2))

planeuse- 17 oct. 2016 à 12:41
Merci mais j'ai essayé et excel me renvoie que le nombre d'arguments est trop important.
Répondre
jordane45 17905Messages postés mercredi 22 octobre 2003Date d'inscription ModérateurStatut 25 juillet 2017 Dernière intervention - 17 oct. 2016 à 12:45
J'ai oublié un SI
Essaye ça :

=SI( AP46 = "F";SI(AP22 >=3218;3218*K3;AP22 * K3);SI(AP46="I";SI(AP22>=3218;3218*K2;AP22*K2)))
Répondre
planeuse- 17 oct. 2016 à 13:04
Ca marche !! Un énorme merci à toi. Tu as résolu le problème sur lequel je galère depuis... longtemps :)
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour


peut être averc (sous réserve de bonne compréhension)

=SI(AP46="F";K3*MAX(3218;AP22);SI(AP46="I";K2*MAX(3218;AP22);""))


Ou encore un peu plus court:

=MAX(3218;AP22)*SI(AP46="F";K3;SI(AP46="I";K2);0))

crdlmnt


planeuse- 17 oct. 2016 à 12:47
Merci, mais excel me renvoie une erreur dans la formule.
Répondre
Vaucluse 20047Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 25 juillet 2017 Dernière intervention - 17 oct. 2016 à 12:57
la première est apparemment correcte, mais si vous copier coller depuis le message, il risque d'y avoir un blanc à supprimer derriére la formule
la seconde compte en effet une parenthèse de trop, les fautes de frappe étant la grande spécialité!
=MAX(3218;AP22)*SI(AP46="F";K3;SI(AP46="I";K2;0))
_parenthèse retirée derrière le K2_
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !