Signaler

Test de logique excel [Résolu]

Posez votre question leadd - Dernière réponse le 14 oct. 2016 à 17:27 par fabien25000
Bonjour,

Je souhaiterai créer une formule qui prenne en compte les données suivantes :
En colonne B, je note des prix
En colonne C, je note des sociétés

Je souhaiterais que dans une cellule, une formule me compte combien doit telle société...
Par exemple j'ai la société durand en cellule C2, C3, C4, C7, C8, C9, C10, C21
Dans les cellules B2, B3, B4, B7, B8, B9, B10 et B21 j'ai le montant qu'ils doivent pour chaque ligne

Comment puis-je faire pour éviter une formule de dix mètres tel que :
=SI(C2="durand";B2;"")+SI(C3="durand";B3;"")....

Merci

PS : J'ai 122 lignes et 6 sociétés...
Afficher la suite 
Utile
+0
plus moins
je n'ai pas le niveau des expert qui répondent habituellement ici mais créerai un tableau par societe sur une autre feuille avec la conditionnelle si(feuil1!c2="durand";feuil&!B2;"") à étirer sur la hauteur du premier table et un =somme dans un tableau récapitulatif qui pourra te servir de matrice pour une recherchev...
Donnez votre avis
Utile
+0
plus moins
Bonjour

tes sociétés en $C$2:$C$10
tes prix en $B$2:$B$10
ta société à "sommer" en E2
formule en F2
=SOMME.SI($C$2:$C$10;E2;$B$2:$B$10)

CDlmnt
fabien25000 79Messages postés mercredi 5 octobre 2016Date d'inscription 28 juillet 2017 Dernière intervention - 14 oct. 2016 à 17:27
Bonjuor ccm
mes 7 tableaux en 1 ligne... si tu veux j'ai tableau sur lequel j'ai besoin de conseils: http://www.commentcamarche.net/forum/affich-33992363-peut-on-alleger-la-syntaxe-d-une-formule#p33996052
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !