Signaler

Format date publipostage [Résolu]

Posez votre question Onaya29 2Messages postés mercredi 12 octobre 2016Date d'inscription 13 octobre 2016 Dernière intervention - Dernière réponse le 14 oct. 2016 à 09:53
Bonjour,

J'ai à peu près le même soucis de date à quelques détails près.

J'ai un fichier Excel avec des dates de naissance, je veux faire un publipostage dans Word.
La colonne Excel est bien en format date et le champ dans Word est bien {MERGEFIELD "DN"\@ "dd/MM/YYYY"}


Alors mon publipostage est vicieux car il ne modifie pas toutes les dates c'est à dire :
23/12/1980 devient 23/12/1980
mais
03/10/1966 devient 10/03/1966

Plusieurs jours que je me torture l'esprit pour résoudre ce problème. Avez-vous des pistes ?

Merci pour votre aide.
Afficher la suite 
Utile
+1
moins plus
Hello,

Comme tu n'as pas encore reçu de réponse je viens t'aider.

Les problèmes de date avec le publipostage sont nombreux et fréquent.

C'est peut-être tes paramètres de régions qui posent problème ou alors des option directement dans word.

As tu essayer de mettre "jj/MM/YYYY" ? Ou "dd.MM.YYYY" Sauf erreur dans l'option de langue française les dates s'inscrivent avec des "." alors que en anglais c'est avec des "/". Sauf que dans certain pays anglophones les dates s'écrivent mois/jours/année.

Ce que je te recommande si tu es pressé, c'est de crée une nouvelle colonne dans Excel (que tu peux masquer) ou tu inscrit la date en format text avec la formule ci-dessous. Tu appelles cette colonne DATEN_TXT par exemple et tu l'utilise pour la date dans ton publipostage, sans format.

La formule si la date en A1 :
=Jour(A1)&"/"&Mois(A1)&"/"&Annee(A1)


Le problème c'est que le 1er janvier 2000 sera : 1/1/2000 au lieu de 01/01/2000

Cela peut s'arranger en compliquant la formule, mais regarde si cela est déjà OK pour toi ?


-Vous pouvez mettre en forme votre code grâce à la flèche en haut à droite de l'éditeur de texte.
Pensez mettre vos messages en [Résolu] et cliquer sur le + des conseil qui vous ont été utiles."
Onaya29 2Messages postés mercredi 12 octobre 2016Date d'inscription 13 octobre 2016 Dernière intervention - 13 oct. 2016 à 11:22
Hello,

Super, tu es génial ! Ça marche

Les 0 de 01/01/2000 ce n'est pas grave, ce n'est pas gênant pour ce que j'en fais.

Merci beaucoup pour ton aide.

Bonne journée.
Répondre
skk201 941Messages postés jeudi 11 septembre 2008Date d'inscription 16 octobre 2016 Dernière intervention - 14 oct. 2016 à 09:53
Hello,

Ravi de t'avoir aidé.

Si ça t'intéresse ou pour ceux que ça intéresse voici la formule pour contourner le problème des "0" dans les dates :

=SI(JOUR(A1)>9;JOUR(A1);"0"&JOUR(A1))&"."&SI(MOIS(A1)>9;MOIS(A1);"0"&MOIS(A1))&"."&ANNEE(A1)


N'oublie pas de mettre le sujet résolu
Répondre
Ajouter un commentaire

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !