Signaler

Formule SI avec des dates

Posez votre question kensha14680 6Messages postés vendredi 3 juin 2016Date d'inscription 23 septembre 2016 Dernière intervention - Dernière réponse le 23 sept. 2016 à 11:03
Bonjour à tous,
Je recherche une formule pouvant calculer le nombre de jours travaillés pendant une période de référence.
Ici la période de référence est la période légale soit ( de la date d'embauche au 31/05 suivant)
Exemple : pour une embauche au 15/04/16 la formule recherchée dans la case période de référence serait :
si (la date d'embauche est < au 31/05 alors 31/05/N sinon 31/05/N+1)
Ainsi dans la case nombre de jours travaillé on pourra mettre la formule :
Période de référence - date d'embauche .
Mais je n'ai pas la formule exacte car avec les dates je ne connais pas.
Je vous laisse le fichier afin que vous m'expliquiez la marche à suivre.
Je vous remercie pour votre aide.
http://www.cjoint.com/c/FIxitPvkCs4
Afficher la suite 
Utile
+0
moins plus
Bonjour,

Pour obtenir le nombre de jours entre 2 dates, il suffit :
1 - de faire la soustraction des 2 dates
2 - de remettre la cellule au format numérique standard (car Excel la met automatique au format date)

Par contre pour déterminer le nombre de jours travaillées il faut connaître le rythme de travail (nombre de jours par semaine / mois / année, travail jours ouvrés et/ou jours fériés, ...)
Ajouter un commentaire
Utile
+0
moins plus
Merci pour votre réponse .
C'est une annuallisation don 365 jours .
Mais si une personne rentre en cours d'année cela change suivant si il arrive avant ou après le 31/05.
Après effectivement il suffira de faire la soustraction .mais pour cela il me faut la perde de référence automatique
Ajouter un commentaire
Utile
+0
moins plus
Bonjour,

Voici ce qui a été possible , si vous avez des questions concernant les formule utilisés faite moi signe,
Le calcul des jours travaillé sont basés sur des semaine de 5 jours.
http://www.cjoint.com/c/FIxiP1wnQE2
Ajouter un commentaire
Utile
+0
moins plus
Bonjour

Une idée

=SI(C2<CNUM("31/05/"&ANNEE(C2));CNUM("31/05/"&ANNEE(C2));CNUM("31/05/"&ANNEE(C2)+1))
Ajouter un commentaire
Utile
+0
moins plus
Re,

Pour la date de fin de période :
=DATE(ANNEE(C2+214);5;31)

Et pour le nombre de jours, il faut ajouter 1 à la différence, le premier jour étant aussi un jour travaillé !

Edit : 365 ou 366 jours les années bissextiles ?

Cordialement
Patrice
Ajouter un commentaire

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !