Signaler

SOMMEPROD +2 conditions [Résolu]

Posez votre question felixloca 5Messages postés mardi 20 septembre 2016Date d'inscription 21 septembre 2016 Dernière intervention - Dernière réponse le 21 sept. 2016 à 14:22
Bonjour,
Pour des statistiques, je dois mettre au point une formule qui calcule le CA des clients par mois et dont la fiche client a été créée avant/après une certaine date. Pouvez-vous m'aider sur ce problème?
Merci d'avance!
Afficher la suite 
Utile
+1
moins plus
Bonjour
essayez avec
=SOMMEPROD((MOIS(D2:D100)=1)*(B2:B100<=DATEVAL("20/8/2016")*(C2:C100))


ajustez les adresses à vos besoins (les N° de lignes sont obligatoires avec ce code

crdlmnt
felixloca 5Messages postés mardi 20 septembre 2016Date d'inscription 21 septembre 2016 Dernière intervention - 21 sept. 2016 à 08:54
Bonjour,

http://www.cjoint.com/c/FIvg0zKzQFy

J'ai appliqué la formule au premier mois =1 (janvier) et il me propose "90" comme réponse. C'est impossible car aucun des achats n'a eu lieu en janvier, ils ont tous lieu ne aout. Comment expliquez-vous ceci?
Merci
Répondre
Vaucluse 17964Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 30 septembre 2016 Dernière intervention - 21 sept. 2016 à 09:50
sans votre modèle, je ne peux pas l'expliquer... l'image ne suffit pas pour déterminer par exemple si vos date sont au bon format!
déposez un modèle Excel sur:
http://www.cjoint.com
et revenez ici coller le lien donné par le site.
A vous lire
crdlmnt
Répondre
felixloca 5Messages postés mardi 20 septembre 2016Date d'inscription 21 septembre 2016 Dernière intervention - 21 sept. 2016 à 10:07
Bonjour Vaucluse,

Le lien est au dessus de mon message de 8h54: http://www.cjoint.com/c/FIvg0zKzQFy

Merci!
Répondre
Vaucluse 17964Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 30 septembre 2016 Dernière intervention - 21 sept. 2016 à 10:23
effectivement excuses, je n'avais pas vu
  • ceci dit, un petit os dans la formule, il faut numériser le résultat de DATEVAL pour qu'il soit numérique (je pensais qu'Excel le faisait automatiquement, mais non!)

soit donc en G2:
=SOMMEPROD((MOIS(D2:D100)=8)*(B2:B100<=DATEVAL("20/8/2016")*1)*(C2:C100))

crdlmnt
Répondre
felixloca 5Messages postés mardi 20 septembre 2016Date d'inscription 21 septembre 2016 Dernière intervention - 21 sept. 2016 à 14:22
Génial, vous êtes trop fort. Merci beaucoup :)
Répondre
Ajouter un commentaire

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !