Signaler

Trouver le nombre de fois un mot donné entre deux dates. [Résolu]

Posez votre question dany7496 54Messages postés lundi 21 juillet 2014Date d'inscription 22 septembre 2016 Dernière intervention - Dernière réponse le 20 sept. 2016 à 13:39
Bonjour,
je suis devant un casse-tête pour moi.
Je cherche à calculer le nombre de fois que l'on peut trouver un mot dans une colonne, (celle-ci composée de dates) et ceci entre deux dates (entre le 1° et le dernier jour du mois de l'année 2016)
J'essaye avec Somme.si.ens... marche pas.
NB. SI. ENS pourrait marcher, sauf que j'ai l'impression de ne pas lui donner les bons renseignements.
voici ma formule :
=nB. SI. ENS(colonne! F3: F411;"le mot"; colonne! C3: C411;"mois de l'année 2016")
Sachant que le mois à 31 jours, j'ai l'impression qu'excel ne se base que sur le 1° jour du mois quand je tape (exemple) 01/16.
car en 13.01.16 il y a deux fois le mot recherché, et il ne les mentionne pas.
Pourriez-vous m'aider s'il vous plaît ?
Je ne pourrais pas vous mettre de pièce jointe, j'en suis dsl.
Merci par avance pour votre aide,
Cordialement,
Dany
Afficher la suite 
Utile
+0
moins plus
Bonjour
NB.SI.ENS ne fonctionnera pas avec l'extraction du mois dans le champ date.
soit:
NB.SI.ENS(champdate;">="&celldatedébut;Date;"<="&celldatefin;champtexte;"mot")


soit pour traiter le mois et la date:

=SOMMEPROD((ANNEE(champdate)=année cherchée)*(MOIS(champdate)=moischerché)*(champ mot=mot cherché))

dans ce code les adresses de champs doivent obligatoirement comporter des N° de ligne et colonne (pas de A:A ou B:BH)

crdlmnt
dany7496 54Messages postés lundi 21 juillet 2014Date d'inscription 22 septembre 2016 Dernière intervention - 20 sept. 2016 à 11:48
Bonjour Vaucluse et merci pour la rapidité de votre réponse.

Sur un tableau de 700 lignes(voir plus) je ne peux pas donner le n° de ligne et colonne !

Au sujet de votre première proposition :
NB.SI.ENS(champdate;">="&celldatedébut;Date;"<="&celldatefin;champtexte;"mot")

pourriez-vous me dire à quoi correspond le "&cell" s'il vous plait ?

merci par avance ;)
Répondre
Vaucluse 17935Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 22 septembre 2016 Dernière intervention - 20 sept. 2016 à 12:19
pourquoi? vous ne pouvez pas écrire par exemple A1:A700 au lieu de A:A????

celldatedébut et celldatefin sont des adresses de cellules hors champ dans laquelle vous placez la date début et la adte de fin cherchée

exemple pour NB.SI.ENS
une liste de date de A1 à A700
une liste de mots de B1 à B700
en C1: la date début cherchée
en C2: la date fin cherchée
en C3: le mot cherché
=NB.SI.ENS(A:A;">="&C1;A:A;"<="&C2;B:B;C3)

exemple pour SOMMEPROD avec le même champ A1:B700 et toujours le mot cherché en C3
pour mois de mai 2015

=SOMMEPROD((MOIS(A1:A700)=5)*(ANNEE(A1:A700)=2015)*(B1:B700=C3))

vous pouvez bien sur placer dans ce cas le N° du mois en C1 et l'année en C2 et remplacer dans la formule =5 et = 2015 par les adresses de cellules

crdlmnt
Répondre
dany7496 54Messages postés lundi 21 juillet 2014Date d'inscription 22 septembre 2016 Dernière intervention - 20 sept. 2016 à 13:33
Oups, je pense avoir mal compris votre première explication alors :$

J'essaye de suite votre proposition et vous dis si ça marche.
Merci beaucoup Vaucluse.
Répondre
dany7496 54Messages postés lundi 21 juillet 2014Date d'inscription 22 septembre 2016 Dernière intervention - 20 sept. 2016 à 13:39
ça marche du tonnerre !!!!!!!!!
Merci infiniment !!!!!!!!!
Très belle après-midi à vous !
Répondre
Ajouter un commentaire

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !