Signaler

Interdire d'insérer des doublons dans une plage excel [Résolu]

Posez votre question sebyyy - Dernière réponse le 15 sept. 2016 à 21:37
Bonjour,
Je cherche à faire une plage de données mais j'aimerais que par exemple, dans la plage de A1 à A90 je ne puisse pas insérer 2 fois le même nombre. J'aimerais qu'Excel m'interdise de pouvoir insérer 2 fois le même numéro.
Est-ce possible ?
Merci d'avance de vos réponses
Afficher la suite 
Utile
+0
moins plus
Bonjour

sélectionnez A1:A90
onglet données / validation des données
dans la liste "personnalisé"
entrez la formule:

=NB.SI($A$1:$A$90;$A1)<2

attention aux signes

en cliquant dans la fenêtre de validation, sur "alerte d'erreur", vous pouvez afficher un message explicatif visible lorsque les données non valides sont tapées
(par ex: "donnée existante".
crdlmnt
Ajouter un commentaire
Utile
+0
moins plus
Bonsoir,

commence par sélectionner ta plage A1:A90
puis Onglet Données/module Outils de données/Validation de données/onglet Options/sélectionne Personnalisé et colle cette formule
=NB.SI($A$1:$A$90;$A1)<=1
ou
=NB.SI($A$1:$A$90;$A1)<2
dans l'assistant onglet, Alerte d'erreur tu peux mettre un titre et un texte d'erreur
A+
Mike-31

Pas savoir n'est pas un échec, l'échec est le refus d'apprendre.
Ajouter un commentaire
Utile
+0
moins plus
Bonsoir

Ou alors en vba: => Alt + F11 et coller ce code sur la feuille
Public Flag As Boolean

Private Sub Worksheet_Change(ByVal Target As Range)
If Flag Then Exit Sub
If Not Application.Intersect(Target, Columns("a")) Is Nothing Then
If Target.Count > 1 Then Exit Sub
If Application.CountIf(Range("a1:a90"), Target) > 1 Then
Flag = True
MsgBox ("Ce numéro existe déjà !")
Target.ClearContents
Flag = False
End If
End If
End Sub

Slts
Ajouter un commentaire
Utile
+0
moins plus
Super ça fonctionne!

Merci pour vos réponses ;-)
Ajouter un commentaire

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !