Signaler

Extraire plusieurs chaîne de carractères excel [Résolu]

Posez votre question Marc - Dernière réponse le 16 sept. 2016 à 15:55
Bonjour,
Je cherche à extraire plusieurs chaînes de caractère dans une colonne et je bloque.Puis je avfoir une formule excel recherche v ou trouve ou un code vBA?
Merci
ci dessous l'exemple:
colonne A Colone B COLONNE C
TEXTE valeur cherché valeur à afficher
MANGE ang ANG
PAPA pa PA
DANSE dan DAN
RECEPTION recept RECEPT
VOISIN ISIN ISIN
Afficher la suite 
Utile
+0
moins plus
Bonjour
=SI(NB.SI(A1;"*"&B1&"*");MAJUSCULE(B1);"")
attention aux signes
crdlmnt
Ajouter un commentaire
Utile
+0
moins plus
Bonjour,


excuse moi j'ai pas été précis
si la colonne A contient "ange" afficher en colonne B "ange"
si...
j'ai 100000 ligne

colonne A TEXTE Colonne B valeur à afficher

MANGE " ange"
Papas "pas"
DANSE "dan"
Recel "recel"
VOISIN "Si"
Vaucluse 17969Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 1 octobre 2016 Dernière intervention - 15 sept. 2016 à 14:31
Dites nous quel est le rapport entre la valeur en A et la valeur à trouver? là, c'est incompréhensible! c'est un nombre de caractères, une liste de référence, ou quoi?
Répondre
Ajouter un commentaire
Utile
+0
moins plus
Bonjour
pas bien compris le but
une proposition quand même
Ajouter un commentaire
Utile
+0
moins plus
Merci pour ton retour
je cherche une certain nombre de chaine dans des celules.

si la formule retrouve une de ces chaines qu'il l'affiche dans la colonne B

LISTE DES CHAINES A RETROUVER DANS LA CELULE(HEURES CHIFFRE;COUT.VENTE..)

COLONE A COLONE B

L10-HEURES HEURES
L674-HEURES-4 HEURES
L7892425-CHIFFRE CHIFFRE
L7892425-COUT COUT
L25-VENTE-PA VENTE
Ajouter un commentaire
Utile
+0
moins plus
Re
Une autre proposition
Ici
Marc- 15 sept. 2016 à 13:36
impossible de voir le lien
Répondre
Ajouter un commentaire
Utile
+0
moins plus
Re copie écran
yclik 710Messages postés vendredi 25 juillet 2014Date d'inscription 17 septembre 2016 Dernière intervention - 15 sept. 2016 à 14:22
en C3
=SI(ESTERREUR(TROUVE(MAJUSCULE($C$2);A3));"";TROUVE(MAJUSCULE($C$2);A3))

en G3
=SI(C3="";"";STXT($A3;C3;NBCAR(G$2)))
Répondre
Ajouter un commentaire
Utile
+0
moins plus
Bonjour
voyez si ce modèle correspond à ce que vous cherchez, et revenez si besoin de complément d'infos

http://www.cjoint.com/c/FIqn2JldUOc

crdlmnt
Ajouter un commentaire

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !