Signaler

Formule index(;equiv;) avec une plage de recherche variable [Résolu]

Posez votre question ddpoel 11Messages postés lundi 11 avril 2016Date d'inscription 15 septembre 2016 Dernière intervention - Dernière réponse le 14 sept. 2016 à 16:16
Bonjour, et merci d'avance pour votre aide.
J'ai un petit problème que je n'arrive pas résoudre (Excel 2013), pourtant je crois que ce n'est pas si compliqué... Bref je n'en sors pas !
Cela se passe dans le fichier cjoint http://www.cjoint.com/c/FIoip6vypJ8
Dans l'onglet Classement, sur la cellule B52 :
=SIERREUR(INDEX('T2'!$A$2:$N$2000;EQUIV($A52;'T2'!$N$2:$N$2000;0);1);"")
En réalité, si en A51 j'ai la première occurrence de 47, alors je rapatrie de la feuille T2 les données concernant la première occurrence de 47 en 'T2'!N2:N2000, soit dans ce cas-ci rapatrier les données 'T2'!A121. C'est bon.
Mais en A52 j'ai la seconde occurrence de 47 (47 est déjà présent plus haut dans la colonne A, en A51 précisément). Dans ce cas je dois rapatrier en B52 le contenu 'T2'!A123
Il doit y avoir de l'INDIRECT() et de l'NB.SI() là-dedans, mais je n'y arrive pas...
Avez-vous une solution?
Un tout grand merci d'avance.
Damien
Afficher la suite 
Utile
+0
moins plus
Bonjour,

Tu transformes ta feuille t2 en tableau, tu retires les doublons, et tu tries avec la derniere colonne (du +petit au +grand)
Et tu "rapropries" ...

Crdmt

http://www.cjoint.com/c/FIonULoTlSD
Ajouter un commentaire
Utile
+0
moins plus
Bonjour
une solution ici avec une colonne de codage qui peut être masquée ou sur une autre feuille
revenez besoin de complément d'info

http://www.cjoint.com/c/FIonWk55CmC

crdlmnt


ddpoel 11Messages postés lundi 11 avril 2016Date d'inscription 15 septembre 2016 Dernière intervention - 14 sept. 2016 à 16:16
C'est exactement cela, merci bcp Vaucluse.
Répondre
Ajouter un commentaire

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !