Signaler

[Linux Fedora] Absence de boot dans le BIOS [Fermé]

Posez votre question Lamyo80 12Messages postés lundi 12 septembre 2016Date d'inscription 18 septembre 2016 Dernière intervention - Dernière réponse le 18 sept. 2016 à 16:39 par Lamyo80
Bonjour,
j'ai fait un peu n'importe quoi en voulant installer Unix-Fedora sur mon pc portable (Asus) en dual-boot avec windows 8. L'installation a bien fonctionné mais lorsque le PC a redémarrer pour terminer l'installation, le BIOS s'est ouvert directement. Dans les boots options, il n'y a plus aucune option de boot telle que Windows boot manager, USB, etc... et il n'y a plus non plus l'option ajouter des boots.

Je vous remercie par avance pour votre aide et pour vos réponses que j'espère rapides car j'ai besoin de mon pc en état de fonctionnement pour mes cours.

PS : Impossible de lancer fedora en live depuis une clé, alors que c'est ce que j'avais fait avant de procéder à l'installation.
Utile
+1
plus moins
Bonjour,

1) Est-ce que ce que tu appelles le BIOS ne serait pas plutôt grub ?

2) Qu'est ce qui est affiché à l'écran à ce moment-là (au besoin, prends une photo et joins-la à ton prochain message à l'aide du 5e bouton situé au dessus de la boîte dans laquelle tu tapes ton message) ?

3) Est-ce que par hasard tu n'aurais pas juste écrasé ton windows en installant fedora par dessus au lieu de faire un dual boot ?

4) Est-ce que fedora démarre correctement ?

Bonne chance
Cette réponse vous a-t-elle aidé ?  
Lamyo80 12Messages postés lundi 12 septembre 2016Date d'inscription 18 septembre 2016 Dernière intervention - 13 sept. 2016 à 21:14
Bonjour, merci pour ta réponse :)
Alors,
1) Oui c'est bien du BIOS dont je parle

2) J'ai pris une photo mais je n'arrive pas à l'intégrer au message donc voilà ce qui apparaît dans l'onglet BOOT du BIOS :
Boot Configuration (écriture noire)
Lauch CSM [Enabled]
Launch PXE OpROM policy [DISABLED]

Boot option Priorities (écriture noire)
Boot option #1 [P2: HL-DT-ST DVDRAM GUAON] (cette boot option vient d'apparaître alors qu'elle n'y était pas hier)

CD/DVD ROM DRIVE BBS Priorities

--> Delete Boot Option


3 & 4) Je ne sais pas si mon Windows a été écrasé ou non car je ne peux même pas accéder à Fedora (donc il ne marche pas). Dès que j'allume mon ordinateur, il lance le BIOS tout seul.
mamiemando 27973Messages postés jeudi 12 mai 2005Date d'inscription ModérateurStatut 10 octobre 2017 Dernière intervention - 13 sept. 2016 à 23:35
Pour intégrer la photo au message ne rédige pas un commentaire, mais clique sur le bouton "'répondre au sujet". C'est le bouton que tu es toujours sensé utilisé, les commentaires étant plus là pour apporter une précision à un message.

Et sinon pour ton problème : je pense que tu n'as pas installé correctement ta fedora. Si en plus l'installation n'est pas compatible EFI, il y a fort a parier pour que non seulement tu aies écrasé ton windows, mais en plus que ta fedora ne soit pas bootable.

Ce que je te propose c'est de réinstaller ton linux en partant sur une ubuntu récente qui sera compatlble uefi et pour laquelle tu trouveras beaucoup de tutoriels d'installation détaillés.
https://www.ubuntu-fr.org/telechargement

Au moment de partitionner, fais un partitionnement manuel pour voir quelles partitions sont encore présentes et s'il y a quelque chose à sauver...
https://openclassrooms.com/courses/reprenez-le-controle-a-l-aide-de-linux/tester-et-installer-ubuntu

Bonne chance
Ankara- 14 sept. 2016 à 10:23
Salut,

Commence par passer Lauch CSM [Enabled] en Lauch CSM [Disabled] et sauvegarde par F10. Puis, réessaie un démarrage sur disque dur, puis sur live-cd.
Utile
+0
plus moins
Bonjour,
merci infiniment pour votre aide !!

J'ai réussi à accéder à mon PC avec une version live de Ubuntu, Windows et Fedora sont respectivement sur leurs partitions, alors je ne comprends pas pourquoi les boots options ne sont pas dans le BIOS...

Avez-vous une idée ? Le problème est donc toujours le même...
Ankara- 14 sept. 2016 à 19:07
Depuis ton live-cd ubuntu, fais un rapport boot-info (et pas la réparation proposée) :

https://doc.ubuntu-fr.org/tutoriel/boot-info
Utile
+0
plus moins
J'ai fait un rapport boot-info comme tu me l'a demandé, voici l'URL :

http://paste2.org/1KMGD1E3
Ankara- 14 sept. 2016 à 20:30
Salut,

Le premier problème apparaît dès les premières lignes :
=> Grub2 (v2.00) is installed in the MBR of /dev/sda and looks at sector 

Or,ton PC est prévu pour fonctionner en uefi.

sda1:
Boot sector type: Windows 8/2012: FAT32
Boot sector info: No errors found in the Boot Parameter Block.
Operating System:
Boot files: /EFI/Boot/bootx64.efi /EFI/Microsoft/Boot/bootmgfw.efi
/EFI/Microsoft/Boot/bootmgr.efi


Donc, ton / tes Linux sont mal installés. Ils sont installés en Legacy, Pour preuve, une partition bios-boot a été créée :
sda6: 
File system: BIOS Boot partition

Je pense même que tu as tenté d'installer une version 32 bits.
sda1 : nogrub, no-docgrub, no-update-grub, 32.... /mnt/boot-sav/sda1.

Pas de Grub.

Ajoutons quelques blagues sympas :

Fedora (lui, en 64 bits) est installé en version LVM (disques virtuels) :
9 964GB 979GB 15.2GB lvm,

Donc, on ne peut pas gérer simplement les partitions. Et pour couronner le tout :
=================== efibootmgr -v
BootCurrent: 0001
BootOrder: 0001
Boot0001* UEFI: USB DISK Pro PMAP PciRoot(0x0)/Pci(0x14,0x0)/USB(2,0)/HD(1,MBR,0x4294967222,0x1f80,0xe6c080)..BO

Tu as flingué le démarrage de Windows. Eh bien là, je dis "belle performance". Une situation parmi les plus pourries que j'aie rencontrées (je vais garder une copie du boot-info en souvenir). Je suis curieux de voir les spécialistes ccm gérer ça.

La seule chose positive est ici :

BIOS is EFI-compatible, and is setup in EFI-mode for this live-session.

Tu as su faire booter Ubuntu 64 bits en UEFI. Tu devrais donc en être aussi capable avec un outil Windows. Car tu n'y échapperas pas pour réparer tout ça.
Utile
+0
plus moins
Bonjour,
Merci de t'être donné la peine de rédiger une telle réponse.
Concrètement, si on oublie Fedora, quelle est la solution ? Réinstaller Windows en UEFI ? Si l'installation fonctionne le "windows boot manager" apparaîtra à nouveau dans le BIOS ? Il me "suffira" à priori ensuite de virer Fedora de la partition sur laquelle je l'ai installé ?

Merci encore pour le mal que vous-vous donnez pour m'aider.
Ankara- 14 sept. 2016 à 22:41
Il n'y a pas de raison de réinstaller. Ton Windows est toujours là et il occupe 103 Gb. Ça fait pas mal de "copie de récupération" à faire, de toute manière.

Il y a plusieurs options. La plus "simple".

1. Récupérer le contenu de sda2, notamment le fichier winre.wiim.
2. Formater les partition sda1 et sda2 pour les recréer correctement.
3. Supprimer toutes les partitions Linux car ils sont mal installés.
4. Réparer le démarrage de Windows.
5. Réparer le démarrage avancé de Windows.
6. Réinstaller un Linux en uefi de manière correcte.

Sinon,

On peut tenter directement le point 4 si la console Windows identifie la partition efi comme partition système. Le point 3 peut venir ensuite. La première chose à faire, c'est de créer une clé d'installation ou de réparation de Windows en fat32 et de faire en sorte de booter dessus en uefi.
Utile
+0
plus moins
Je confirme ce que dit Ankara, suis un tutoriel pour réparer un windows 8 ou 10 installé en UEFI pour déjà pouvoir booter dessus.
https://blog.d0zingcat.xyz/2015/09/28/Windows/How%20to%20repair%20the%20EFI%20Bootloader%20in%20Windows%2010/

Ceci fait, réinstalle linux en prenant soin de prendre une version récente (par exemple la dernière ubuntu) en veillant :
1) à ne pas supprimer/formater tes partitions windows
2) à ne pas supprimer/formater ta partition EFI
https://www.ubuntu-fr.org/telechargement

Le plus sûr est au cours de l'installation de faire un partitionnement manuel afin d'être sûr d'éviter les points (1) et (2). N'utilise pas LVM si c'est sur le même disque dur que windows, fais simplement des partitions "bien dimensionnées" dès le début (par exemple 4Go de swap, 20 Go pour / en ext4, le reste en ext4 pour /home).
https://openclassrooms.com/courses/reprenez-le-controle-a-l-aide-de-linux/partitionner-son-disque

Bonne chance
Utile
+0
plus moins
impressionnent !
tu as pris ton temps pour expliquer tout ça!!!
Utile
+0
plus moins
Bonjour, merci pour votre aide précieuse, mais j'ai une mauvaise nouvelle : j'ai fait tout ce que vous m'avez conseillé et pourtant, les boots options ne sont pas réapparues. Dans la console de Windows, à la fin de la réparation, la console m'a dit que tout avait bien fonctionné, comme l'indique le tuto de mamiemando.
J'ai bien formater sda1 et sda2, mais qu'entendez-vous exactement par "recréer correctement" ?
Ankara- 15 sept. 2016 à 19:36
Dans la console de Windows, à la fin de la réparation...

Tu m'impressionnes : je ne t'ai même pas dit quoi faire. Les tutos, c'est de la daube en boîte. Chaque cas est un cas particulier.

Fais un point sur la situation. Photos de
diskpart
list disk
sel disk 0
list vol
list part
exit

Puis
bcdedit /v
Utile
+0
plus moins
Voilà les photos, j'espère que ça t'aidera à y voir plus clair :



Ankara- 15 sept. 2016 à 21:01
J'ai été sévère avec le tuto... il semble avoir fait les choses dans les règles. On va toutefois refaire la manip, pour ne serait-ce que passer le démarrage en français (et l'attribut masqué sur le volume 5 pourrait bien expliquer la situation)
diskpart
sel disk 0
sel part 3
delete partition override
create partition efi offset=1
format fs=fat32 quick
exit

Puis, la commande minimaliste (L minuscule, et non 1):
bcdboot c:\windows /l fr-FR

Si tout se fait sans erreur, tu tentes un redémarrage. Si c'est toujours pareil, tu redémarres sur le live-usb ubuntu et tu fais une capture du résultat de:
sudo efibootmgr-v

Fais aussi une photo de l'onglet "boot" dans ton bios /uefi.

Edit. Attention, j'ai modifié pour supprimer et recréer la partition 3.
Utile
+0
plus moins
Il n'arrive pas à créer la partition, il dit : "Erreur du service de disque virtuel : L'espace utilisable pour cette opération est insuffisant"
Ankara- 16 sept. 2016 à 07:20
Refais-le sans l'option offset=1.
Utile
+0
plus moins
Ça n'a malheureusement pas marcher.
Voilà la photo de la commande que tu m'as dit de faire dans le terminal de ubuntu :



Par contre, je n'ai pas la photo du bios, mais c'est toujours pareil qu'avant.
Ankara- 16 sept. 2016 à 17:17
J'aimerais voir les options proposées par ce bios, et notamment l'éventualité d'une ligne permettant de dmarrer sur un fichier efi. Et il faut avoir désactivé cette option :
Lauch CSM [Enabled] 

Il faut la passer en disabled... L'as-tu fait ?

Refais un rapport boot-info, histoire de voir si j'ai raté quelque chose.

Sinon, je n'ai pas de solution. Ton cas est étonnant.
Utile
+0
plus moins
http://paste2.org/ptNVnbaV

Voilà le rapport boot-info, puis les photos du BIOS (et oui, je l'ai passé en disabled)









Ankara- 17 sept. 2016 à 13:24
Essaie de voir où mène l'option " launch efi shell from filesystem device". Idem l'entrée "add boot option" dans l'onglet boot. On pourra peut-être forcer le démarrage.

Entre temps, je regarde tout ça....
Ankara- 17 sept. 2016 à 19:54
Dans l'absolu, on a tous les éléments pour que ça démarre. Quelques points restent douteux, notamment :
/dev/sda2: unknown GPT attributes
8000000000000001
/dev/sda3: unknown GPT attributes
8000000000000000
Unknown BootLoader on sda6

Les attributs sont jugés inconnus. Or, il correspondent à ce que M$ préconise.
RAID detected. You may want to retry after installing the [mdadm] packages

Boot-info détecte du raid... Est-ce le cas ?
=================== df -Th:
Filesystem Type Size Used Avail Use% Mounted on
/dev/sda4 fuseblk 373G 8.2G 365G 3% /mnt/boot-sav/sda4

Je trouve que 8,2 Gb, c'est vraiment peu pour un Windows installé.
/dev/sda3     2664448    3131391     466944   228M EFI System
/dev/sda4 3131392 783718399 780587008 372.2G Microsoft basic data

La partition msr a été écrasée par ta première réparation.

Mais tout ça n'explique pas que le bios ne détecte pas les fichiers efi sur le disque dur puisqu'ils sont là, et que le démarrage est bon. Essaie les deux options du bios que j'ai indiquées dans le précédent message. Vois si elles conduisent à quelque chose: si on peut lancer le fichier /efi/Microsoft/boot/bootmgfw.efi manuellement, on pourra peut-être s'en sortir.

On peut aussi essayer une remise du bios à default (en prenant soin de désactiver le fast boot avant d'enregistrer). J'avoue que ton problème commence à devenir énigmatique.

On pourra encore essayer de supprimer toutes les partitions Linux et retenter la commande bcdboot, mais je ne pense pas que ça change quelque chose.

Edit. J'arrête d'écrire sur ce site de m.... qui me dit ceci (quelle blague quand on lit le jargon de certains):

Veuillez écrire correctement s'il vous plaît (pas de SMS, orthographe, grammaire)

Si tu veux reprendre, on continuera sur le forum cnet.
Utile
+0
plus moins
Les deux options n'on rien donner de concluant, et on ne peut choisir un chemin personnalisé pour ajouter un boot option.
J'ai déjà fait une remise du bios à default, rien non plus.

Je vais voir quelqu'un de compétent dans ce domaine lundi, j'espère qu'il pourra m'aider...
Si mon problème est résolu, j'expliquerai ce que l'expert à fait pour ceux qui - malheureusement - serait dans le même cas mais je promets rien.

Merci à tous pour votre aide ! Mille fois merci même. Bonne continuation !
Ankara- 17 sept. 2016 à 21:37
Je te donne la réponse... j'espère me tromper. Formatage complet et réinstallation de Windows. Tiens-nous au courant.
Utile
+0
plus moins
Qu'est-ce que tu entends par formatage complet ?

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !