Signaler

Impossible de définir imprimante par défaut [Résolu]

Posez votre question L'âne Trotro - Dernière réponse le 20 sept. 2016 à 17:44
Bonjour,
Aujourd'hui, alors que je veux lancer l'impression d'un fichier pdf, mon ordinateur me demande de sauvegarder mon fichier au format ".oxps". Je me pose des questions, d'autant plus qu'au final mon fichier ne s'impriment pas pour autant (rien ne se passe malgré plusieurs essais).
Je constate alors que mon imprimante a été remplacée par un certain "Microsoft XPS Documents Writer" sorti de je ne sais où ! Je désinstalle donc ce petit malotru.
Problème : maintenant je ne peux plus rien imprimer car je n'ai plus d'imprimante par défaut, or quand je fais clic droit sur mon imprimante dans le panneau de configuration, je n'ai plus l'option "définir par défaut" !
Preuve en image : http://hpics.li/a52f313
(Par contre, je peux utiliser le scanner sans problème en cliquant sur « démarrer la numérisation », bizarrement !)
Naturellement j'ai cherché une solution sur Internet et j'ai trouvé celle-ci :
http://h30478.www3.hp.com/t5/Imprimantes-et-imprimantes-tout-en-un-Mise-en-route/Impossible-de-d%C3%A9finir-l-imprimante-par-d%C3%A9faut/td-p/285922
J'ai tout fait comme demandé puis j’ai redémarré l'ordinateur. Mon imprimante est enfin bel et bien inscrite dans ce fameux "Windows" (ce n'était pas le cas avant), mais le problème reste malgré tout le même : impossible de définir ma Lexmark par défaut dans le panneau de configuration. J’ai réessayé une deuxième fois dans le doute, mais rien n’a changé.
Voici à quoi cela ressemble maintenant : http://hpics.li/4c57142
Précision : Je suis sous Windows 8.1 (64 bits), mon imprimante est une Lexmark P4350.
Existe-t-il une autre solution ? Merci d'avance pour vos réponses ! :) J’admets être très loin de m'y connaitre dans ce domaine…
Bonne journée / soirée à vous.
Afficher la suite 
Utile
+0
moins plus
Bonjour,

Retourne dans le régistre
Double-clique sur --> UserSelectedDefault
Dans données de la valeur, met 1
Ca devrait donner ceci --> 0x00000000 (1)



Ajouter un commentaire
Utile
+0
moins plus
Bonjour,
Merci beaucoup pour cette réponse !
Malheureusement, malgré cela, le problème persiste.
Je constate cependant qu'il est indiqué "pilote indisponible", donc je présume que le problème vient peut-être de là également... Or je crois que je ne suis pas au bout de mes surprises !
Déjà, Driver Booster 3.5 ne semble pas voir de problème de pilote chez mon imprimante.
Je vais donc directement sur le site de Lexmark (http://support.lexmark.com/index?page=driversdownloads&userlocale=FR_FR&locale=FR) et y cherche ce que je peux y trouver de plus récent pour mon imprimante, ce qui semble être "Complete drivers and software for setting up, configuring, and using your device with Windows 64-bit" (cjs4300FR.exe) sorti en 2010 pour Windows Vista 64 bits. Soit, je suis sous Windows 8.1 mais on va faire avec... Pas le choix, apparemment.
En le lançant, il m'indique que je dois d'abord désinstaller ce qui est déjà présent sur mon PC. Je clique sur "Uninstall" dans cette fenêtre, et... J'ai une magnifique petite fenêtre blanche sans rien écrit dessus. Et bien sûr, ça ne désinstalle rien.
Je vais donc dans "Ajouter ou supprimer des programmes" pour désinstaller d'ici... Petite fenêtre blanche !
Je vais alors dans "Revo Uninstaller"... Lexmark ne fait même pas parti des programmes présent dans sa liste.
Après quelques recherches sur Internet, je décide d'aller dans le registre pour copier les "données de valeur" de son fichier "UninstallString" pour ensuite le lancer manuellement dans le programme "Exécuter". Sauf que quand j'essaye, une fenêtre s'affiche m'indiquant de me connecter en tant qu'administrateur. Je vais donc chercher le fichier manuellement, l'exécute en tant qu’administrateur... Et là, devinez quoi : retour de la petite fenêtre blanche ! La preuve en image si besoin : http://hpics.li/13186b3
Je ne sais plus quoi faire...
Je constate au passage quelque chose qui me parait un peu bizarre à la fin de ces fameuses "données de valeur" :
"C:\windows\system32\spool\DRIVERS\x64\3\lxceUNST.EXE -NOLICENSE"
Mais pourquoi donc "No license" ? Est-ce normal ? J'ai acheté mon imprimante il y a environ 9 ans et l'ait installée avec son disque d'origine sur mon nouveau PC l'an dernier, donc je ne vois pas en quoi elle n'aurait pas de licence. Ceci-dit j'avais galéré pour l'installer, donc peut-être qu'elle ne s'est pas installée comme elle aurait dû... Je ne sais pas. Je suis un peu (beaucoup) perdu !
Je vous remercie d'avance pour votre aide et je m'excuse pour ce pavé !
Ajouter un commentaire
Utile
+0
moins plus
Est-ce que l'imprimante fonctionne normalement ?
Quand tu fais une impression, elle bien présente dans le nom de l'imprimante ?
Ajouter un commentaire
Utile
+0
moins plus
Bonjour et de nouveau merci d'avoir répondu !

L'imprimante en elle-même fonctionne très bien (je lui ai fait imprimer des pages test), mais je ne peux rien lui demander depuis l'ordinateur puisqu'il n'y a pas d'imprimante définie par défaut sur ce dernier.
Par exemple, Microsoft Word me dit "Impossible d'imprimer : problème de configuration d'imprimante" et l'aide m'indique que ça peut notamment venir du fait qu'il n'y a pas d'imprimante désignée par défaut. Je précise que je sélectionne bien ma Lexmark lors de la demande d'impression. Preuve en image :
Demande d'impression : http://hpics.li/f62c78e
Fenêtre de refus : http://hpics.li/d4ff017

La Visionneuse de photos Windows ne veut pas imprimer de photos car "aucune imprimante n'est installée ou un service requis par Windows n'est pas activé", or j'ai bien vérifié et le Spouleur d'impression et Lxce_Device (les deux services dont j'ai besoin) sont bien activés tous les deux, pas de problème.

Photofiltre refuse d'imprimer également car "Aucune imprimante par défaut sélectionnée". Bref, vous voyez le tableau.

Mais l'imprimante est bel et bien repérée par l'ordinateur, elle s'affiche bien dans "Périphériques et imprimantes" comme étant branchée, est également présente dans "Paramètres du PC / PC et Périphériques / Périphériques", je peux la sélectionner dans Word, etc. Preuve en est que, curieusement, je n'ai aucun mal à demander à scanner un fichier depuis l'ordinateur. Elle reçoit bien l'information, scanne, et je peux enregistrer le fichier scanné sans problème.

Chose intéressante : en allumant mon ordinateur ce soir et en jetant un œil à Regedit, je constate que ma Lexmark a de nouveau disparue ! Il ne restait plus que ça (comme la première fois que je l'avais ouvert, donc) : http://hpics.li/49c9ccc Donc j’ai recommencé l’opération comme avant : j’ai retiré « UserSelectedDefault » , redémarré, constaté que ma Lexmark été bien revenue, mis un « 1 » en valeur… Mais le problème persiste, je ne peux toujours pas la mettre par défaut et je ne peux donc rien imprimer.
Ajouter un commentaire
Utile
+0
moins plus
Va dans le panneau de configuration
Périphériques et Imprimantes
As-tu essayé --> ajouter une imprimante ?
Ajouter un commentaire
Utile
+0
moins plus
J'ai essayé et ça y est, elle est enfin définie comme "par défaut" ! Merci de m'avoir conseillé de le faire.
Par contre maintenant, un nouveau problème se pose : quand je veux imprimer, une fenêtre m'indique que "le port détecté est incorrect".
Image : http://hpics.li/12357b8
(J'ai cliqué sur le lien du bas dans la fenêtre mais il ne mène à rien)
Je précise que le câble USB est bien connectée à l'ordinateur et à l'imprimante, je l'ai même débranché / rebranché pour être sûr.
Que devrais-je faire ?
Ajouter un commentaire
Utile
+0
moins plus
As-tu essayé un autre port usb ?
L'âne Trotro- 31 août 2016 à 12:52
Oui, sur quatre ports. Pourtant ils fonctionnent bien, aucun problème avec les clés usb ou la webcam par exemple.
Répondre
Ajouter un commentaire
Utile
+0
moins plus
Gestionnaire des périphériques
Déroule le menu --> contrôleurs de bus usb
Désinstalle le concentrateurs usb racine qui correspond à l'imprimante
Redémarre le pc.

L'âne Trotro- 3 sept. 2016 à 11:55
(Désolé pour le retard de ma réponse)
Comment savoir de quel concentrateur usb il s'agit ?
J'en ai 3, deux nommés "Concentrateur USB racine" et l'autre "Concentrateur USB racine (xHCI)". Dans leurs propriétés, je ne vois nul part inscrit imprimante ou Lexmark par exemple, donc je ne sais pas duquel il s'agit.
Répondre
Ajouter un commentaire
Utile
+0
moins plus
salut

si tu mets l'imprimante sous tension ,tu devrais le voir



@+
L'âne Trotro- 3 sept. 2016 à 19:37
Merci pour l'explication.
Le nom de mon imprimante ne s'affiche pas, donc j'ai débranché / rebranché l'imprimante pour voir quels lignes disparaissent quand l'imprimante est débranchée. Il y en a trois, soulignés en rouge sur cette image : http://hpics.li/f01df85
Lesquel(s) dois-je désinstaller ?
Encore merci pour votre aide.
Répondre
Ajouter un commentaire
Utile
+0
moins plus
re

je vais faire la même manipulation sur mon pc et je reviens^^

@+
Ajouter un commentaire
Utile
+0
moins plus
re

voici les 2 captures d'écran:

imprimante hors tension



imprimante en tension



regarde sur ton pc, ce qui "s'ajoute" quand l'imprimante est en "tension" et supprime

@+

Ajouter un commentaire
Utile
+0
moins plus
Tu as quoi dans Ports (COM et LPT) ?
Ajouter un commentaire
Utile
+0
moins plus
Je viens de me rendre compte que ma Lexmark s'affiche dans "Autres périphériques".
Image : http://hpics.li/b5e401d
Il précise que "Ce périphérique fonctionne correctement".


kaneagle : Où se trouve "Ports (COM et LPT)" ? Je ne le trouve pas dans la liste (voir image ci-dessus).


billmaxime : Je les ai désinstallés mais malheureusement, ça n’a rien changé :(
Ajouter un commentaire
Utile
+0
moins plus
Donne le no. d'identification de matériel de l'imprimante
Fais clic droit sur le périphérique
Propriétés
Onglet détails
Sélectionne le no. d'identifiant de matériel.
C'est un no. qui doit ressembler à ceci comme exemple:
--> PCI\VEN_1969&DEV_1026&SUBSYS.......
USB\.....
Au besoin, regarde --> ici

L'âne Trotro- 7 sept. 2016 à 13:29
Voici ce qui s'affiche :
USBPRINT\Lexmark_4300_Series8A00
Lexmark_4300_Series8A00
Répondre
Ajouter un commentaire
Utile
+0
moins plus
Fais clic droit sur le pilote --> cjs4300FR.exe
Choisis --> extraire tout

Va dans le gestionnaire de périphériques
Fais clic droit sur le périphérique
Mettre à jour le pilote
Rechercher un pilote sur mon ordinateur
Parcourir
Va dans le dossier du pilote dézippé --> cjs4300FR
Sélectionne le dossier --> drivers
OK, suivant
Redémarre

L'âne Trotro- 7 sept. 2016 à 14:08
Je ne trouve pas de fichier nommé cjs4300FR.exe sur le disque dur.
Répondre
Ajouter un commentaire
Utile
+0
moins plus
Complete drivers and software for setting up, configuring, and using your device with Windows 64-bit" (cjs4300FR.exe) sorti en 2010 pour Windows Vista 64 bits.
En le lançant, il m'indique que je dois d'abord désinstaller ce qui est déjà présent sur mon PC

Tu l'as déjà essayé:
Le voici --> cjs4300FR.exe
Installe-le manuellement comme proposé.
L'âne Trotro- 7 sept. 2016 à 16:13
Merci pour l'explication ! C'est fait.
Je ne peux toujours rien imprimer, mais au moins je n'ai plus de fenêtre "port incorrect" qui s'affiche. Par contre, maintenant je constate encore quelque chose de nouveau : dans "Périphériques et imprimantes", j'ai maintenant deux imprimantes qui s'affichent... Ma Lexmark que j'ai définie par défaut précédemment, et "F:\". Quand je débranche ma Lexmark, l’icône de la "F" s'éteint mais pas celle de la Lexmark. Je n'ai pourtant bien que ma Lexmark comme imprimante et n'en n'ai pas branché d'autre entre temps.
Répondre
Ajouter un commentaire
Utile
+0
moins plus
Fais Windows + R
Tape --> services.msc et OK

Vérifie si le service spouleur d'impression est bien démarré et est en automatique dans type de démarrage.
L'âne Trotro- 9 sept. 2016 à 13:47
C'est bien le cas, ainsi que pour lxce_device.
Je me demandais si je n'avais pas tout simplement mal réinstallé l'imprimante.
Du coup je l'ai désinstallée dans "Périphériques et imprimantes", puis pour la réinstaller cette fois-ci j'ai cliqué sur "USB001" dans l'installation (ce que je n'avais pas fait avant), sauf que j'attends et l'imprimante ne semble pas s'installer. La barre verte bouge mais ça fait un quart d'heure que j'attends que quelque chose se passe... Je désespère.
Répondre
L'âne Trotro- 9 sept. 2016 à 13:51
Est-ce bien sur USB001 que je dois cliquer si mon imprimante est branchée par un câble usb classique ?
Répondre
kaneagle 70601Messages postés mercredi 27 mai 2009Date d'inscription ModérateurStatut 26 septembre 2016 Dernière intervention - 9 sept. 2016 à 16:01
Oui.
Répondre
Ajouter un commentaire
Utile
+0
moins plus
Fais clic droit sur les 2 concentrateurs USB racine
Désinstalle-les
Redémarre le pc.



Si le problème persiste, peut-être Daemon tolls la cause ?


kaneagle- 9 sept. 2016 à 20:48
C'est fait et ça a marché, elle s'est installée toute seule quand je l'ai rebranchée au démarrage. Sauf que je ne pouvais plus la définir par défaut donc j'ai refait tous le processus, et maintenant je me retrouve avec "deux" Lexmark pour je ne sais quelle raison, celle définie par défaut est grisée car soi-disant non connectée, et l'autre en couleur ne fait rien. Je désespère à comprendre à jour pourquoi mon pc et mon imprimante se font la tête à ce point...

Je ne pense pas que Dameon Tools me pose problème sachant qu’il est là depuis bien avant ce souci d’imprimante.
Répondre
Ajouter un commentaire
Utile
+0
moins plus
Dans le panneau de configuration
Programmes et fonctionnalités
Tu as quoi comme imprimante d'installé ?

PS: Utilise un autre pseudo que le mien, s'il te plaît.
L'âne Trotro- 9 sept. 2016 à 21:38
Ah oui désolé j'ai voulu copié-collé mon pseudo et je me suis trompé de case !
Ma Lexmark 4300 series, je n'ai qu'elle comme imprimante de toute façon. Mais j'ignore pourquoi dans "Périphériques et imprimante" elle s'est dédoublée...
Répondre
Ajouter un commentaire
Utile
+0
moins plus
Désinstalle tout ce qui concerne les imprimnates avec --> Revo Uninstaller
Suis bien le tuto.

Redémarre le pc
Va dans le panneau de configuration
Périphériques et imprimantes
Vérifie ce qui est présent comme imprimante.

L'âne Trotro- 10 sept. 2016 à 14:13
Je n'ai rien concernant mon imprimante dans Revo (je n'ai jamais pu installer son logiciel CD qui n'est pas compatible Windows 8). De toute façon je n'ai jamais branché une autre imprimante que ma Lexmark.
Répondre
Ajouter un commentaire

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !