Signaler

Sommeprod [Résolu]

Posez votre question Marie Chant 53Messages postés lundi 24 mars 2014Date d'inscription 24 octobre 2016 Dernière intervention - Dernière réponse le 12 oct. 2016 à 12:40
Bonjour,
Je vous remercie d'avance de votre aide,
Je n'arrive pas a résoudre mon problème.
J'ai un classeur avec deux feuilles, une est nommé data et l'autre conclusion.
Dans mon data j'ai
Dans ma colonne C des noms d'outil ex: BRAS
Dans ma colonne O j'ai les localisations ex: Ameublement
dans ma colonne H j'ai les division ex: 2000014
dans la colonne L j'ai les prix ex:2.00$
Sur ma feuille de conclusion
En
C1 c'est inscrit OUTIL
A2 Localisations
A3 Localisations
J'ai inscrit ceci dans ma formule mais cela ne fonctionne pas. Je ne trouve pas mon erreur. Pourriez-vous m'aider s.v.p.
=SOMMEPROD( (data!$C$2:$C$45406=C$1) * (data!$O$2:$O$45406=$A8) * (data!$L$2:$L$45406))
Je voudrais que cela me donne la somme: Il me manque la condition H
Additionne (data!$C$2:$C$45406=C$1)(soit Outil) et additionne (data!$O$2:$O$45406=$A2) MAIS seulement s'il y a dans (data!$H$2:$H$45406 le nombre 200014, 200016,200020,201201 et fait la somme de (data!$L$2:$L$45406))
je n'arrive pas a savoir quoi écrire pour mon critère de seulement en O si c'est inscrit inscrit 200014, 200016,200020,201201 et seulement ceux là
J'avais essayé mais cela ne fonctionne pas
  • (data!$H$2:$H$45406="200014"200016""200020"201201") mais cela ne fonctionne pas

Dans la l ligne suivante sur ma feuille conclusion donne moi la différence de O (Ameublement) moins le montant qui sera inscrit en C2 sur ma feuille conclusion
Merci beaucoup de votre aide c'est apprécié
Afficher la suite 
Utile
+0
moins plus
Bonjour,

Voici ta formule :
=SOMMEPROD( (data!$C$2:$C$45406=C$1) * (data!$O$2:$O$45406=$A2) *((data!$H$2:$H$45406=200014)+(data!$H$2:$H$45406=200016)+(data!$H$2:$H$45406=200020)+(data!$H$2:$H$45406=201201))*data!$L$2:$L$45406)

En fait, tu souhaites cumuler si en colonne H tu as 200014 ou 200016 ou 200020 ou 201201 et dans SOMMEPROD le "ou" se traduit par + et tu mets tes "+" entre parenthèses pour avoir vrai si une des conditions est remplie.
Tu n'as pas besoin par contre de parenthèses pour la colonne que tu cumules.
Marie Chant 53Messages postés lundi 24 mars 2014Date d'inscription 24 octobre 2016 Dernière intervention - 7 juin 2016 à 16:00
Merci beaucoup Gbinforme,

Cela fonctionne très bien,

Pour la ligne suivante , je veux la différence qui reste de la colonne H
Est-ce que je pourrais faire
=SOMMEPROD( (data!$C$2:$C$45406=C$1) * (data!$O$2:$O$45406=$A8) * (data!$L$2:$L$45406)-C7 car la réponse précedente est en C7 ? Non cela ne fonctionne pas

Est-ce que je pourrais faire

=SOMMEPROD( (data!$C$2:$C$45406=C$1) * (data!$O$2:$O$45406=$A2) *((-data!$H$2:$H$45406=200014)-(data!$H$2:$H$45406=200016)-(data!$H$2:$H$45406=200020)-(data!$H$2:$H$45406=201201))*data!$L$2:$L$45406)

merci beaucoup et bonne journée!
Répondre
gbinforme 12838Messages postés lundi 18 octobre 2004Date d'inscription ContributeurStatut 23 novembre 2016 Dernière intervention - 7 juin 2016 à 18:28
Bonjour,

Non cela ne fonctionne pas
Pourtant cela fonctionne si tu l'écris correctement :
=SOMMEPROD((data!$C$2:$C$45406=C$1)*(data!$O$2:$O$45406=$A8)*data!$L$2:$L$45406)-C7

Tu avais une parenthèse de trop !
Répondre
Marie Chant 53Messages postés lundi 24 mars 2014Date d'inscription 24 octobre 2016 Dernière intervention - 7 juin 2016 à 22:14
Bonjour Gbinforme,

Je voudrais que les trois conditions soit remplie et cela ne fonctionne pas. Je ne sais plus quoi faire. Je dois avoir le cumul de mon data qui rempli les trois conditions soit C$1 et $A2 seulement si dans H c'est soit200014,200016,200020,201201.

Je veux que cela respecte es trois conditions. car en D$1 j'ai une autre cie mais avec les mêmes data

Pourrais-tu m'aider s.v.p merci beaucoup
Répondre
gbinforme 12838Messages postés lundi 18 octobre 2004Date d'inscription ContributeurStatut 23 novembre 2016 Dernière intervention - 8 juin 2016 à 08:22
Bonjour,

C'est exactement ce que fait la première formule : j'ai l'impression que tu n'es pas très méthodique et les formules doivent être précises pour donner le bon résultat.
Répondre
Ajouter un commentaire
Utile
+0
moins plus
Bonjour(et salut mon ami gb)
peut être un peu plus simple ici pour la réponse à la première question, mais j'avoue ne pas avoir compris ce que vous voulez dans le dernier message

http://www.cjoint.com/c/FFhoCtAINt8

ce serait sans doute p)plus clair si vous pouviez déposer un fichier sur
http://www.cjoint.com
en revenant coller ici le lien créé sur le site

crdlmnt
gbinforme 12838Messages postés lundi 18 octobre 2004Date d'inscription ContributeurStatut 23 novembre 2016 Dernière intervention - 7 juin 2016 à 18:30
Salut Vaucluse,

Ce serait bien de nous fournir un peu plus de soleil ! ;-)
Répondre
Marie Chant 53Messages postés lundi 24 mars 2014Date d'inscription 24 octobre 2016 Dernière intervention - 12 oct. 2016 à 12:40
Merci beaucoup
Répondre
Ajouter un commentaire

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !