[leap 42.1 sur 3 écrans] iceWM ok mais pas kde5, écrans noirs [Fermé]

Demi Cerveau 3 Messages postés mercredi 17 octobre 2012Date d'inscription 21 mars 2016 Dernière intervention - 20 mars 2016 à 23:37 - Dernière réponse : mamiemando 28092 Messages postés jeudi 12 mai 2005Date d'inscriptionModérateurStatut 13 décembre 2017 Dernière intervention
- 23 mars 2016 à 23:57
Bonjour à tous

J'ai installé leap 42.1, à partir du netInstall en USB
tout à bien fonctionné, puis, comme j'ai une quadro NVS 440 reliée à 3 écrans, j'ai installé, à partir des dépots NIVIDA.COM les drivers suivants:
- libdrm_nouveau2 (fournisseur openSUSE)
- nvidia-computeG02 (fournisseur : obs://build.suse.de/home:sndirsch:drivers au lieu de ceux de NVidia....)
- nvidia-gfxG02-kmp-default (le fournisseur est toujours le obs au lieu de nvidia)
- x11-video-nvidiag02 (meme fournisseur que ci dessus)
- xf86-video-nouveau (fournisseur opensuse)
- xf86-video-nv (toujours de chez opensuse)

Mes questions sont :
1/ Je ne sais pas comment installer les drivers fournis par NVidia au lieu de ceux marqués comme provenant de chez openSuse
2/ dans la version OpenSUSE 13.1, xinerama fonctionnait bien avec les drivers NVidia, kde4 s'affichait bien, ici, kde5 m'offre un écran tout noir, avec tout de meme le pointeur de la souris :D alors que iceWM s'affiche correctement, qui peut m'expliquer?

Je vous remercie d'avance pour votre aide
Afficher la suite 

4 réponses

mamiemando 28092 Messages postés jeudi 12 mai 2005Date d'inscriptionModérateurStatut 13 décembre 2017 Dernière intervention - 21 mars 2016 à 10:33
0
Utile
1
Bonjour,

Les noms des paquets sont un peu surprenants (par exemple xf86 au lieu de xorg) ou même simplement le fait que tu aies dû installer des paquets qui ne sont en vrai que des dépendances de nvidia. C'est assez bizarre.

Je ne connais pas leap, mais je suppose que tu as un gestionnaire de paquets genre apt ? Peux-tu nous en dire un peu plus ?

Je t'invite à lire et suivre le tutoriel donné ici (lire l'intro) :
http://www.commentcamarche.net/faq/3456-installer-drivers-nvidia-sous-debian

A priori tu devrais utiliser la méthode (E) et au pire la méthode (A).

1) Voir méthode (A)
2) Je pense que ce sont les effets 3D qui plantent car le pilote est mal installé. Normalement tu as un fichier dans ton home qui devrait t'aider à comprendre la cause exacte de l'erreur (.xsession-errors)


Bonne chance
Demi Cerveau 3 Messages postés mercredi 17 octobre 2012Date d'inscription 21 mars 2016 Dernière intervention - 21 mars 2016 à 19:50
Bonsoir et merci de votre réponse.

J'ai regardé votre lien, j'ai fouillé les différents drivers, mais je me dis que les drivers fonctionnent bien. La preuve en est qu'avec IceWM, les 3 écrans fonctionnent correctement en xinérama, et KDE s'affiche quand je désactive xinérama.
Seul KDE ne fonctionne pas en mode xinérama (je n'ai pas encore testé Gnome)

J'ai abandonné pour l'instant la recherche sur les drivers, je les changerai si aucune autre solution n'est présentée

J'ai donc regardé le fameux fichier .xsession-errors. Pour en obtenir un correct, j'ai redemarré en mode console (ctrl-alt-F1), j'ai supprimé le fichier, reboot, démarrage de KDE Plasma 5 jusqu'à obtenir la souris, mais les écrans restent noirs (bon sang de bon sang!), redémarrage en mode console, toujours avec ctrl-alt-F1, et renommage de .xsession-errors en xsession-errors-avecerreurs-kde.

Il me dit qu'il y a plusieurs erreurs
Qt: Session management error: networkIdsList argument is NULL
kscreen: Failed to request backend: unknown error <= et je pense que c'est cette erreur qui fait que je n'ai pas de "backend", pas de bureau où cliquer...
Error found while setting up ShellCorona's KScreen: "Failed to prepare backend" (ben oui, si pas de backend, pas de request...)
QXcbConnection: XCB error: 3 (BadWindow), sequence: 687, resource id: 6291475, major code: 18 (ChangeProperty), minor code: 0

Par contre IceWM carbure sur un i3, hate de voir ce que donne KDE
Demi Cerveau 3 Messages postés mercredi 17 octobre 2012Date d'inscription 21 mars 2016 Dernière intervention - 21 mars 2016 à 19:51
0
Utile
Voici l'integralité de .xsession-errors :

Loading stage "initial" 131
startkde: Starting up...
kdeinit5: preparing to launch 'libkdeinit5_klauncher'
kdeinit5: Launched KLauncher, pid = 1684, result = 0
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
kdeinit5: opened connection to :0
kdeinit5: preparing to launch 'libkdeinit5_kded5'
kdeinit5: Launched KDED, pid = 1686 result = 0
kdeinit5: preparing to launch 'libkdeinit5_kcminit_startup'
kdeinit5: Launched 'kcminit_startup', pid = 1687 result = 0
kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/ktimezoned.so"
kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/soliduiserver.so"
kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/freespacenotifier.so"
kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/kscreen.so"
kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/remotedirnotify.so"
kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/networkwatcher.so"
kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/ksysguard.so"
kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/appmenu.so"
kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/recentdocumentsnotifier.so"
kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/networkmanagement.so"
kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/networkstatus.so"
kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/desktopnotifier.so"
kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/proxyscout.so"
kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/solidautoeject.so"
kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/powerdevil.so"
kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/device_automounter.so"
kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/statusnotifierwatcher.so"
kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/khotkeys.so"
kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/keyboard.so"
kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/baloosearchmodule.so"
kdeinit5: Got SETENV 'KDE_MULTIHEAD=false' from launcher.
Initializing "kcm_style" : "kcminit_style"
kdeinit5: Got SETENV 'GTK_RC_FILES=/etc/gtk/gtkrc:/home/michel/.gtkrc:/home/michel/.config/gtkrc' from launcher.
kdeinit5: Got SETENV 'GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/michel/.gtkrc-2.0:/home/michel/.config/gtkrc-2.0' from launcher.
Initializing "kcm_access" : "kcminit_access"
kdeinit5: Got EXEC_NEW '/usr/bin/kaccess' from launcher.
kdeinit5: preparing to launch '/usr/bin/kaccess'
kf5.kded: found kded module "accounts" by prepending 'kded_' to the library path, please fix your metadata.
Initializing "kcm_input" : "kcminit_mouse"
kdeinit5: Got SETENV 'XCURSOR_THEME=breeze_cursors' from launcher.
Initializing "kded_touchpad" : "kcminit_touchpad"
Initializing "kcm_kgamma" : "kcminit_kgamma"
kf5.kded: found kded module "printmanager" by prepending 'kded_' to the library path, please fix your metadata.
kdeinit5: Got EXEC_NEW '/usr/lib64/libexec/kf5/kconf_update' from launcher.
kdeinit5: preparing to launch '/usr/lib64/libexec/kf5/kconf_update'
kdeinit5: PID 1697 terminated.
kdeinit5: PID 1687 terminated.
kdeinit5: Got KWRAPPER '/usr/bin/ksmserver' from wrapper.
kdeinit5: preparing to launch '/usr/bin/ksmserver'
QCoreApplication::arguments: Please instantiate the QApplication object first
powerdevil: Backend loaded, loading core
powerdevil: Core loaded, initializing backend
powerdevil: XRandR extension not available
powerdevil: Falling back to helper to get brightness
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
kdeinit5: PID 1695 terminated.
pm.kded: unable to register service to dbus
Qt: Session management error: networkIdsList argument is NULL
Configuring Lock Action
XSync seems available and ready
XSync Inited
Supported, init completed
Created alarm 39845889
ksmserver: "/run/user/1000/KSMserver"
kdeinit5: Got SETENV 'SESSION_MANAGER=local/linux-opu8:@/tmp/.ICE-unix/1699,unix/linux-opu8:/tmp/.ICE-unix/1699' from launcher.
ksmserver: KSMServer: SetAProc_loc: conn 0 , prot= local , file= @/tmp/.ICE-unix/1699
ksmserver: KSMServer: SetAProc_loc: conn 1 , prot= unix , file= /tmp/.ICE-unix/1699
ksmserver: KSMServer::restoreSession "saved at previous logout"
kdeinit5: Got EXEC_NEW '/usr/bin/baloo_file' from launcher.
kdeinit5: preparing to launch '/usr/bin/baloo_file'
QDBusConnection: name 'org.kde.kglobalaccel' had owner '' but we thought it was ':1.11'
QDBusConnection: name 'org.kde.kglobalaccel' had owner '' but we thought it was ':1.11'
detected kglobalaccel restarting, re-registering all shortcut keys
Session path: "/org/freedesktop/login1/session/_32"
kscreen: Failed to request backend: unknown error
detected kglobalaccel restarting, re-registering all shortcut keys
kdeinit5: Got EXEC_NEW '/usr/bin/krunner' from launcher.
kdeinit5: preparing to launch '/usr/bin/krunner'
Setting the name of 0x1bd18a0 to "org.kde.ActivityManager.Resources.Scoring"
Creating directory: "/home/michel/.local/share/kactivitymanagerd/resources/"
KActivities: Database connection: "kactivities_db_resources_140433858238336_readwrite"
query_only: QVariant(qlonglong, 0)
journal_mode: QVariant(QString, "wal")
wal_autocheckpoint: QVariant(qlonglong, 100)
synchronous: QVariant(qlonglong, 1)
Setting the name of 0x1c24910 to "org.kde.ActivityManager.RunApplication"
Setting the name of 0x1c2b5d0 to "org.kde.ActivityManager.ActivityTemplates"
Service started, version: 6.2.0
powerdevil: org.kde.powerdevil.backlighthelper.brightnessmax failed
powerdevil: current screen brightness value: 0
powerdevil: Backend is ready, KDE Power Management system initialized
XSync seems available and ready
XSync Inited
Supported, init completed
powerdevil: Session path: "/org/freedesktop/login1/session/_32"
powerdevil: ACTIVE SESSION PATH: "/org/freedesktop/login1/session/_32"
powerdevil: Current session is now active
powerdevil: fd passing available: true
powerdevil: systemd powersave events handling inhibited, descriptor: 25
powerdevil: systemd support initialized
powerdevil: Got a valid offer for "DPMSControl"
org.kde.baloo: "/home/michel"
powerdevil: Core is ready, registering various services on the bus...
powerdevil: Can't contact ck
powerdevil: We are now into activity "28c5a0d0-29fc-4c20-ba82-e2969914d601"
powerdevil: () ()
powerdevil: () ()
powerdevil: No batteries found, loading AC
powerdevil: Activity is not forcing a profile
powerdevil: Handle button events action could not check for screen configuration
powerdevil:
powerdevil: Loading timeouts with 300000
Created alarm 25165825
Created alarm 25165828
Created alarm 25165829
Created alarm 25165830
Created alarm 25165831
kscreen: Failed to request backend: unknown error
powerdevil: Handle button events action could not check for screen configuration
QObject::connect: invalid null parameter
kscreen: Failed to request backend: unknown error
kdeinit5: Got EXEC_NEW '/usr/bin/plasmashell' from launcher.
kdeinit5: preparing to launch '/usr/bin/plasmashell'
completeShutdownOrCheckpoint called
completeShutdownOrCheckpoint called
kdeinit5: Got EXEC_NEW '/usr/lib64/libexec/polkit-kde-authentication-agent-1' from launcher.
kdeinit5: preparing to launch '/usr/lib64/libexec/polkit-kde-authentication-agent-1'
kwin_core: Compositing is not possible
New PolkitAgentListener 0x9e8120
Adding new listener PolkitQt1::Agent::Listener(0xa04060) for 0x9e8120
Listener online
Authentication agent result: true
Invalid service name "/org/kde/polkit-kde-authentication-agent-1" using: "/org/kde/polkitkdeauthenticationagent1"
kdeinit5: Got EXEC_NEW '/usr/bin/xembedsniproxy' from launcher.
kdeinit5: preparing to launch '/usr/bin/xembedsniproxy'
ksmserver: Autostart 0 done
kcminit not running? If we are running with mobile profile or in another platform other than X11 this is normal.
ksmserver: Kcminit phase 1 done
kdeinit5: Got EXEC_NEW '/usr/bin/start-pulseaudio-x11' from launcher.
kdeinit5: preparing to launch '/usr/bin/start-pulseaudio-x11'
completeShutdownOrCheckpoint called
ksmserver: Autostart 1 done
Installing the delayed initialization callback.
Trying to convert empty KLocalizedString to QString.
Trying to convert empty KLocalizedString to QString.
Trying to convert empty KLocalizedString to QString.
kf5.kded: found kded module "touchpad" by prepending 'kded_' to the library path, please fix your metadata.
kf5.kded: found kded module "kmixd" by prepending 'kded_' to the library path, please fix your metadata.
kmix: kmixd: Triggering delayed initialization
ksmserver: Starting notification thread
Delayed initialization.
ksmserver: Kcminit phase 2 done
ksmserver: Autostart 2 done
kde.xembedsniproxy: starting
Reloading the khotkeys configuration
Version 2 File!
SHO QKeySequence("")
SHO QObject(0x0)
kde.xembedsniproxy: Manager selection claimed
SHO QKeySequence("Ctrl+Alt+I")
SHO QObject(0x0)
SHO QKeySequence("Ctrl+Alt+H")
SHO QObject(0x0)
SHO QKeySequence("Ctrl+Alt+T")
SHO QObject(0x0)
SHO QKeySequence("Ctrl+W")
SHO QObject(0x0)
SHO QKeySequence("Ctrl+Alt+W")
SHO QObject(0x0)
SHO QKeySequence("Ctrl+Alt+B")
SHO QObject(0x0)
SHO QKeySequence("Meta+E")
SHO QObject(0x0)
SHO QKeySequence("Print")
SHO QObject(0x0)
SHO QKeySequence("Shift+Print")
SHO QObject(0x0)
SHO QKeySequence("Meta+Print")
SHO QObject(0x0)
true
Imported file "/usr/share/khotkeys/defaults.khotkeys"
Imported file "/usr/share/khotkeys/konqueror_gestures_kde321.khotkeys"
Imported file "/usr/share/khotkeys/kde32b1.khotkeys"
Imported file "/usr/share/khotkeys/spectacle.khotkeys"
Trying to use rootObject before initialization is completed, whilst using setInitializationDelayed. Forcing completion
kdeinit5: PID 1746 terminated.
kscreen: Failed to request backend: unknown error
Error found while setting up ShellCorona's KScreen: "Failed to prepare backend"
kmix: kmixd: Delayed initialization running now
kmix: kmixd: Delayed initialization done
QXcbConnection: XCB error: 3 (BadWindow), sequence: 687, resource id: 6291475, major code: 18 (ChangeProperty), minor code: 0
powerdevil: ACTIVE SESSION PATH CHANGED: "/"
powerdevil: Switched to inactive session - leaving unchanged
powerdevil: ACTIVE SESSION PATH CHANGED: "/org/freedesktop/login1/session/_33"
powerdevil: Current session is now inactive
mamiemando 28092 Messages postés jeudi 12 mai 2005Date d'inscriptionModérateurStatut 13 décembre 2017 Dernière intervention - 23 mars 2016 à 23:57
0
Utile
Bonjour,

Oui c'est la "bonne ligne" d'erreur. Une piste :
https://forums.opensuse.org/showthread.php/511887-I-ve-Borked-Plasma-5-5

Bonne chance