Test de connectivité REDHAT [Fermé]

nickodemco87 - 7 mars 2016 à 12:19 - Dernière réponse : mamiemando 28092 Messages postés jeudi 12 mai 2005Date d'inscriptionModérateurStatut 13 décembre 2017 Dernière intervention
- 9 mars 2016 à 00:30
Bonjour, je travaille sur Redhat 6.5
je veux faire communiquer mes deux machines virtuelles( adresse source= 192.168.1.7 ; adresse destinataire=192.168.1.6 ) mais voici ce qui s'affiche:
#ping 192.68.1.7
PING 192.168.1.7 (192.168.1.7) 56 (84) bytes of data .
From 192.168.1.6 icmp_seq=2 Destination Host Unreachable
Afficher la suite 

5 réponses

mamiemando 28092 Messages postés jeudi 12 mai 2005Date d'inscriptionModérateurStatut 13 décembre 2017 Dernière intervention - 7 mars 2016 à 19:53
0
Utile
4
Bonjour,

Si tu utilises virtualbox ou vmware, est-ce que ces deux machines virtuelles sont configurées en accès par pont ?

Peux-tu nous copier coller ce que retournent les commandes suivantes sur tes 2 VMs ?

/sbin/route -n
/sbin/ifconfig -a


Bonne chance
voici le resultat:

# /sbin/route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
192.254.0.0 0.0.0.0 255. 255.0.0 U 0 0 0 eth0

# /sbin/ifconfig -a
eth0 Link encap :Ethernet HWaddr 00:OC:29:97:AE:7A
inet addr:192.168.1.7 Bcast: 192.168.1.255 Mask: 255.255.255.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
Collisions:0 txqueuelen:1000
RX bytes:0 ( 0.0 b ) TX bytes:0 ( 0.0 b )
lo Link encap :Local loopback
inet addr:127.0.0.1 Mask: 255.0.0.0
inet addr: : : 1/128 Scope: Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:212 errors:0 dropped:0 overruns:0 frame:0
TX packets:212 errors:0 dropped:0 overruns:0 carrier:0
Collisions:0 txqueuelen:0
RX bytes:17570 ( 17.1 KiB ) TX bytes:17570 ( 17.1 KiB)
pan0 Link encap :Ethernet HWaddr 36:EE:F6:26:B8:1B
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
Collisions:0 txqueuelen:0
RX bytes:0 ( 0.0 b ) TX bytes:0 ( 0.0 b )
mamiemando 28092 Messages postés jeudi 12 mai 2005Date d'inscriptionModérateurStatut 13 décembre 2017 Dernière intervention - 8 mars 2016 à 09:29
Et pour l'autre VM ? Quelqu'un a basculé ton sujet en résolu, tu as trouvé une solution à ton problème ?

Mais d'ores et déjà en admettant que tu utilises vmware ou virtualbox (merci de préciser) les routes de cette VM ne sont pas normales.
http://www.commentcamarche.net/faq/3759-vmware-et-virtualbox-les-differents-types-de-reseau

Si tu étais en accès par pont (ce qui y ressemble vu les IPs), tu devrais récupérer par pont automatiquement une configuration IP "comme si" ta VM était un PC de ton réseau. Supposons par exemple que tu utilises une box pour te connecter à internet qui alloue des IPs en 192.168.0.*, tu auras alors une IP dans cette plage et des routes ainsi configurées (dans cette exemple, 192.168.0.254 est l'IP de ma box) :

(mando@velvet) (~) $ /sbin/route -n
Table de routage IP du noyau
Destination Passerelle Genmask Indic Metric Ref Use Iface
0.0.0.0 192.168.0.254 0.0.0.0 UG 600 0 0 wlan0
192.168.0.0 0.0.0.0 255.255.255.0 U 600 0 0 wlan0


La configuration IP se fait simplement à l'aide d'une requête DHCP (typiquement en root :
dhclient eth0
)
bonjour mon problème n'est pas encore résolu c'est le même résultat pour les autres machines virtuelles. je suis connecté en mode pont justement .
mamiemando 28092 Messages postés jeudi 12 mai 2005Date d'inscriptionModérateurStatut 13 décembre 2017 Dernière intervention - 9 mars 2016 à 00:30
1) As-tu essayé "réseau interne" (en imaginant que les VMs n'aient pas besoin d'accéder à internet ?

2) Si elles ont besoin d'accéder à internet, parviennent-elles à pinguer la gateway (192.168.0.254 dans mon exemple) ?

3) Est ce que ton système hôte parvient à pinguer les VM.(voir commande ifconfig pour voir l'IP de chaque eth0) ?

Bonne chance