Packet Filter [Fermé]

Littleassao 6 Messages postés jeudi 4 février 2016Date d'inscription 10 mars 2016 Dernière intervention - 4 févr. 2016 à 19:30 - Dernière réponse : mamiemando 28084 Messages postés jeudi 12 mai 2005Date d'inscriptionModérateurStatut 9 décembre 2017 Dernière intervention
- 5 févr. 2016 à 20:13
Bonjour,



Ayant eu une soudaine envie de passer mon serveur dédié sous freeBSD (Je suis sous linux depuis plusieurs années), je rencontre néanmoins un problème avec packet filter, lorsque je lance le service j'ai ce message: Enabling pfNo ALTQ support in kernel ALTQ related functions disabled.

N'ayant pas encore trop potassé la syntaxe de Pf j'ai utilisé un tuto trouvé sur un blog pour le pf.conf http://www.planet-libre.org/index.php?post_id=11336.

Si quelqu'un pouvait m'expliquer ce message que me retourne la console ça serait super sympa. Merci d'avance
Afficher la suite 
6Messages postés jeudi 4 février 2016Date d'inscription 10 mars 2016 Dernière intervention

5 réponses

mamiemando 28084 Messages postés jeudi 12 mai 2005Date d'inscriptionModérateurStatut 9 décembre 2017 Dernière intervention - 4 févr. 2016 à 20:50
0
Utile
2
Bonjour,

En gros il te dit que la fonctionnalité altq (alternate queuing) n'est pas supporté par le noyau sur lequel tu as démarrer. Certaines fonctionnalités de packet filter qui reposent dessus ne sont donc pas utilisable. Ce n'est pas forcément grave...
http://unix.stackexchange.com/questions/66035/should-i-fix-no-altq-support-in-kernel-to-run-the-firewall

... mais si tu y tiens, tu peux recompiler un noyau pour les supporter.
http://www.cyberciti.biz/faq/freebsd-enable-pf-altq-firewall-support/

Bonne chance
Littleassao 6 Messages postés jeudi 4 février 2016Date d'inscription 10 mars 2016 Dernière intervention - 4 févr. 2016 à 23:14
D'abbord un grand merci pour tes explications. Je vais vérifier ci les règles établies dans pf marchent,sinon j'utiliserai un autre firewall. Est ce du au fait que l'hébergeur utilise un noyau modifié? Je sais que lors des instalations debian le noyau installé est modifié par l'hebergeur.
mamiemando 28084 Messages postés jeudi 12 mai 2005Date d'inscriptionModérateurStatut 9 décembre 2017 Dernière intervention - 5 févr. 2016 à 08:33
Je n'en sais rien, mais vu le grand nombre de messages relatifs à cette question sur internet c'est peut-être un noyau standard. Tu peux vérifier avec ton gestionnaire de paquets. De toute façon, peu importe la réponse si le but est d'exploiter ces fonctionnalités :-)
Littleassao 6 Messages postés jeudi 4 février 2016Date d'inscription 10 mars 2016 Dernière intervention - 5 févr. 2016 à 16:11
0
Utile
Je ne comprend plus rien, pour tester la chose j'ai fait un scan sur le serveur=>il me met seulement que les ports 25 et 445 sont filtrés alors que quand je fais un scan sur le port autorisé pour le ssh il met qu'il est ouvert.

Pour tester sans Packet filter j'ai effacé le fichier pf.conf, et relancé le service.

Mêmes résultats alors que le firewall devrait être désactivé. De plus rien de marqué dans les logs.

Si quelqu'un à une explication je suis preneur car j'ai vraiment envie de m'essayer à freebsd mais là malheureusement le handbook ne m'aide pas.

Merci d'avance
mamiemando 28084 Messages postés jeudi 12 mai 2005Date d'inscriptionModérateurStatut 9 décembre 2017 Dernière intervention - 5 févr. 2016 à 20:13
0
Utile
Je suppose que tu scannes tes ports avec
nmap
? Dans ce cas ça dépend peut-être de la manière dont tu fais le scan.

Rien ne dit en outre qu'un scan complet adopte la même stratégie de scan qu'un scan sur un port donné.

Rien ne dit non plus que le pare-feu réagit de la même manière. Il peut s'apercevoir dans un cas qu'il est en train de se faire scanner, dans l'autre non.

Bonne chance