Menu

Comment faire des arrondis à l'intérieur d'une somme sans macro [Résolu/Fermé]

Hittite31 3 Messages postés jeudi 3 décembre 2015Date d'inscription 3 décembre 2015 Dernière intervention - 3 déc. 2015 à 06:49 - Dernière réponse : Hittite31 3 Messages postés jeudi 3 décembre 2015Date d'inscription 3 décembre 2015 Dernière intervention
- 3 déc. 2015 à 16:06
Bonjour,

Je ne maitrise pas bien les macro et je voudrais faire la somme d'une série de cellules en incluant un calcul et un arrondi. J'ai essayé la formule suivante mais EXCEL 2013 n'accepte apparemment pas de faire des calculs à l'intérieur de la fonction SOMME:
=SOMME(ARRONDI(S2333/1,2;2):ARRONDI(S2348/1,2;2))

Mon problème est de faire la somme hors taxe de cellules en TTC. Si j'arrondi la somme, le résultat est imprécis car des fractions de centimes sont cumulées. Il faut donc faire le calcul hors taxe et l'arrondi, puis faire la somme.

Je peux bien sur faire une colonne cachée, mais j'ai une multitude de colonne et ce n'est pas très "élégant".

Merci de vos conseils.
Afficher la suite 

5 réponses

Vaucluse 21853 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 19 avril 2018 Dernière intervention - Modifié par Vaucluse le 3/12/2015 à 08:49
+2
Utile
2
Bonjour (et salut Michel)

peut être directement avec:

=SOMMEPROD((ARRONDI(S2333:S2348/1,2;2))*1)

qui calcule l'arrondi ligne par ligne

crdlmnt

Errare humanum est, perseverare diabolicum
Cette réponse vous a-t-elle aidé ?  
michel_m 15205 Messages postés lundi 12 septembre 2005Date d'inscriptionContributeurStatut 19 avril 2018 Dernière intervention - 3 déc. 2015 à 09:06
Salut Vaucluse
bien vu § :o)
et un ptit plus pour bien démarrer la journée
Hittite31 3 Messages postés jeudi 3 décembre 2015Date d'inscription 3 décembre 2015 Dernière intervention - 3 déc. 2015 à 16:02
Cela fonctionne super bien. Merci. Je ne connaissais pas le fonctionnement de SOMMEPROD.
michel_m 15205 Messages postés lundi 12 septembre 2005Date d'inscriptionContributeurStatut 19 avril 2018 Dernière intervention - 3 déc. 2015 à 08:00
0
Utile
1
Bonjour*c'est au niveau de chaque ligne qu'il faut faire l'arrondi
S2333=ARRONDI(cellule TTC/1,2;2)
jusqu'à 2348

=somme(C2333:C2348)
Hittite31 3 Messages postés jeudi 3 décembre 2015Date d'inscription 3 décembre 2015 Dernière intervention - 3 déc. 2015 à 16:06
Merci, mais si je ne l'ai pas fait c'est que les valeurs des cellules sont aussi utilisées pour d'autres calculs et quelles doivent rester TTC.
La réponse de Vaucluse corresponds beaucoup mieux à mon besoin.
Merci tout de même d'avoir répondu.