Signaler

Yast bloqué par processus dans "opensuse 13.2" [Résolu/Fermé]

Posez votre question CASTORAGILE 13Messages postés lundi 29 octobre 2007Date d'inscription 12 octobre 2015 Dernière intervention - Dernière réponse le 28 sept. 2015 à 14:22 par castorafile
Bonjour, dans opensuse yast est bloqué par un processus pid2014 .quel est donc le moyen pour débloquer ce processus ??? les mises à jour sont rendues impossibles et la konsole ne répond pas .Aie aie que de problèmes .Merci à celle ou celui qui voudra bien éclairer ma lanterne .Cordialement



Utile
+0
plus moins
Tu as probablement une autre instance de yast qui tourne en arrière plan.

Comme elle tourne probablement en root, il faut :
1) vérifier si tu as une session root ouverte qui lance yast, la récupérer, et quitter yast proprement
2) si tu n'y parviens pas, passe en root et tue le processus correspondant.

su -
ps aux | grep root
kill -9 pid_de_yast


(ici ce serait
kill -9 2014
), puis relance yast.

Bonne chance
castoragile- 26 sept. 2015 à 18:30
1/ merci pour ta précieuse réponse ,
2/tout est débloqué et yast répond bien ouf!! comme koi vaut mieux "un qui trouve que deux qui cherchent " c'est vrai qu'après Windows il faut se familiariser avec Linux Encore merci .cordialement
mamiemando 27973Messages postés jeudi 12 mai 2005Date d'inscription ModérateurStatut 10 octobre 2017 Dernière intervention - 27 sept. 2015 à 13:56
Oui juste pour la petite histoire : ce genre de problème est classique, il faut donc le garder en tête pour que tu adoptes la même démarche quand tu vois ce genre de message d'erreur.

Plus précisément, ici, yast a besoin de manipuler une "base" qui maintient le statut des paquets installés sur ta machine. Pour éviter des accès concurrents et contradictoires, seule une instance de gestionnaire de paquets doit la manipuler. En informatique, cela se réalise en verrouillant ladite ressource, et c'est ce qui t'est arrivé.
castorafile- 28 sept. 2015 à 14:22
Hello ! merci pour la précision apportée .Je débute avec Opensuse ,ce sont donc d'autres problèmes ,je crois savoir qu'il y a conflit avec Yast et Apper pour les mises à jour .J'avais bien desinstallé Apper et packagekit et surprise Yast me faisait encore des misères .Le problème semble ( grace à toi ) cette fois résolu . Merci en encore . Cordialement

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !