[OpenSuse 10.2] Problème avec phpmyadmin [Résolu/Fermé]

Xantra - 28 juin 2007 à 22:02 - Dernière réponse :  Xantra
- 28 juin 2007 à 22:58
Bonjour,
J'ai télécharger phpmyadmin et je l'ai mis a la racine de mon site web et j'ai fait les modif qu'il fallait dans le fichier de config. Mais quand je me connecte a l'adresse ou est phpmyadmin, que je mette n'importe quoi en login et pass j'ai l'erreur suivante :
#2002 - Le serveur ne répond pas. (ou l'interface de connexion ("socket") vers le serveur MySQL local n'est pas correctement configurée)

Voila mon fichier de config :
<?php
if (!isset($old_error_reporting)) {
   error_reporting(E_ALL);
   @ini_set('display_errors', '1');
}
$cfg['PmaAbsoluteUri'] = 'http://192.168.1.120/phpmyadmin/';
$cfg['PmaAbsoluteUri_DisableWarning'] = TRUE;
$cfg['PmaNoRelation_DisableWarning']  = FALSE;
$cfg['blowfish_secret'] = 'dvolv2';
$i = 0;
$i++;
$cfg['Servers'][$i]['host']          = 'localhost'; 
$cfg['Servers'][$i]['port']          = '3306';          
$cfg['Servers'][$i]['socket']        = '/var/lib/mysql/mysql.sock';          
$cfg['Servers'][$i]['connect_type']  = 'tcp';       
$cfg['Servers'][$i]['extension']     = 'mysql';     
$cfg['Servers'][$i]['compress']      = FALSE;
$cfg['Servers'][$i]['controluser']   = '';            
$cfg['Servers'][$i]['controlpass']   = '';          
$cfg['Servers'][$i]['auth_type']     = 'cookie';    
$cfg['Servers'][$i]['user']          = 'root';      
$cfg['Servers'][$i]['password']      = '';       
$cfg['Servers'][$i]['only_db']       = '';         
$cfg['Servers'][$i]['verbose']       = '';          
$cfg['Servers'][$i]['pmadb']         = '';  
$cfg['Servers'][$i]['bookmarktable'] = '';         
$cfg['Servers'][$i]['relation']      = '';     
$cfg['Servers'][$i]['table_info']    = '';          
$cfg['Servers'][$i]['table_coords']  = '';         
$cfg['Servers'][$i]['pdf_pages']     = '';        
$cfg['Servers'][$i]['column_info']   = '';       
$cfg['Servers'][$i]['history']       = '';          
$cfg['Servers'][$i]['verbose_check'] = TRUE;        
$cfg['Servers'][$i]['AllowRoot']     = TRUE;        
$cfg['Servers'][$i]['AllowDeny']['order'] = '';
$cfg['Servers'][$i]['AllowDeny']['rules'] = array(); 
$cfg['ServerDefault'] = 1;              
$cfg['Server']        = '';
unset($cfg['Servers'][0]);
?>

Je ne vois pas d'ou pourrai venir le problème. Help me
Merci d'avance
Afficher la suite 

8 réponses

lami20j 21513 Messages postés jeudi 4 novembre 2004Date d'inscriptionContributeur sécuritéStatut 8 octobre 2012 Dernière intervention - 28 juin 2007 à 22:48
+1
Utile
je crois que le problème est ici
dans ton php.ini tu as
mysql.default_socket = "/var/lib/mysql/mysql.socket"
et dans /etc/my.cnf je vois
/var/lib/mysql/mysql.sock

il faut modifier dans php.ini
avant de faire des modifications sauvegarde les fichiers originaux
Cette réponse vous a-t-elle aidé ?  
lami20j 21513 Messages postés jeudi 4 novembre 2004Date d'inscriptionContributeur sécuritéStatut 8 octobre 2012 Dernière intervention - 28 juin 2007 à 22:17
0
Utile
Salut,

affiche le fichier de configuration de mysql
je ne sais pas sur SUSE mais regarde si tu as le fichier /etc/my.cnf
0
Utile
Oui j'ai se fichier, je savais même pas qu'il existait celui la lol. Il contiens ceci :
# Example MySQL config file for medium systems.
#
# This is for a system with little memory (32M - 64M) where MySQL plays
# an important part, or systems up to 128M where MySQL is used together with
# other programs (such as a web server)
#
# You can copy this file to
# /etc/my.cnf to set global options,
# mysql-data-dir/my.cnf to set server-specific options (in this
# installation this directory is /var/lib/mysql) or
# ~/.my.cnf to set user-specific options.
#
# In this file, you can use all long options that a program supports.
# If you want to know which options a program supports, run the program
# with the "--help" option.

# The following options will be passed to all MySQL clients
[client]
#password       = your_password
port            = 3306
socket          = /var/lib/mysql/mysql.sock

# Here follows entries for some specific programs
lami20j 21513 Messages postés jeudi 4 novembre 2004Date d'inscriptionContributeur sécuritéStatut 8 octobre 2012 Dernière intervention - 28 juin 2007 à 22:26
0
Utile
il faut afficher tout
0
Utile
Dsl j'ai pas vu que le fichier était plus grand. Le voila:
# Example MySQL config file for medium systems.
#
# This is for a system with little memory (32M - 64M) where MySQL plays
# an important part, or systems up to 128M where MySQL is used together with
# other programs (such as a web server)
#
# You can copy this file to
# /etc/my.cnf to set global options,
# mysql-data-dir/my.cnf to set server-specific options (in this
# installation this directory is /var/lib/mysql) or
# ~/.my.cnf to set user-specific options.
#
# In this file, you can use all long options that a program supports.
# If you want to know which options a program supports, run the program
# with the "--help" option.

# The following options will be passed to all MySQL clients
[client]
#password	= your_password
port		= 3306
socket		= /var/lib/mysql/mysql.sock

# Here follows entries for some specific programs

# The MySQL server
[mysqld]
port		= 3306
socket		= /var/lib/mysql/mysql.sock
skip-locking
key_buffer = 16M
max_allowed_packet = 1M
table_cache = 64
sort_buffer_size = 512K
net_buffer_length = 8K
read_buffer_size = 256K
read_rnd_buffer_size = 512K
myisam_sort_buffer_size = 8M

# Don't listen on a TCP/IP port at all. This can be a security enhancement,
# if all processes that need to connect to mysqld run on the same host.
# All interaction with mysqld must be made via Unix sockets or named pipes.
# Note that using this option without enabling named pipes on Windows
# (via the "enable-named-pipe" option) will render mysqld useless!
# 
#skip-networking

# Replication Master Server (default)
# binary logging is required for replication
# log-bin=mysql-bin

# required unique id between 1 and 2^32 - 1
# defaults to 1 if master-host is not set
# but will not function as a master if omitted
server-id	= 1

# Replication Slave (comment out master section to use this)
#
# To configure this host as a replication slave, you can choose between
# two methods :
#
# 1) Use the CHANGE MASTER TO command (fully described in our manual) -
#    the syntax is:
#
#    CHANGE MASTER TO MASTER_HOST=<host>, MASTER_PORT=<port>,
#    MASTER_USER=<user>, MASTER_PASSWORD=<password> ;
#
#    where you replace <host>, <user>, <password> by quoted strings and
#    <port> by the master's port number (3306 by default).
#
#    Example:
#
#    CHANGE MASTER TO MASTER_HOST='125.564.12.1', MASTER_PORT=3306,
#    MASTER_USER='joe', MASTER_PASSWORD='secret';
#
# OR
#
# 2) Set the variables below. However, in case you choose this method, then
#    start replication for the first time (even unsuccessfully, for example
#    if you mistyped the password in master-password and the slave fails to
#    connect), the slave will create a master.info file, and any later
#    change in this file to the variables' values below will be ignored and
#    overridden by the content of the master.info file, unless you shutdown
#    the slave server, delete master.info and restart the slaver server.
#    For that reason, you may want to leave the lines below untouched
#    (commented) and instead use CHANGE MASTER TO (see above)
#
# required unique id between 2 and 2^32 - 1
# (and different from the master)
# defaults to 2 if master-host is set
# but will not function as a slave if omitted
#server-id       = 2
#
# The replication master for this slave - required
#master-host     =   <hostname>
#
# The username the slave will use for authentication when connecting
# to the master - required
#master-user     =   <username>
#
# The password the slave will authenticate with when connecting to
# the master - required
#master-password =   <password>
#
# The port the master is listening on.
# optional - defaults to 3306
#master-port     =  <port>
#
# binary logging - not required for slaves, but recommended
#log-bin=mysql-bin

# Point the following paths to different dedicated disks
#tmpdir		= /tmp/		
#log-update 	= /path-to-dedicated-directory/hostname

# Uncomment the following if you are using BDB tables
#bdb_cache_size = 4M
#bdb_max_lock = 10000

# Uncomment the following if you are using InnoDB tables
#innodb_data_home_dir = /var/lib/mysql/
#innodb_data_file_path = ibdata1:10M:autoextend
#innodb_log_group_home_dir = /var/lib/mysql/
#innodb_log_arch_dir = /var/lib/mysql/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
#innodb_buffer_pool_size = 16M
#innodb_additional_mem_pool_size = 2M
# Set .._log_file_size to 25 % of buffer pool size
#innodb_log_file_size = 5M
#innodb_log_buffer_size = 8M
#innodb_flush_log_at_trx_commit = 1
#innodb_lock_wait_timeout = 50

# The safe_mysqld script
[safe_mysqld]
err-log=/var/lib/mysql/mysqld.log

[mysqldump]
quick
max_allowed_packet = 16M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[myisamchk]
key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[mysqlhotcopy]
interactive-timeout
lami20j 21513 Messages postés jeudi 4 novembre 2004Date d'inscriptionContributeur sécuritéStatut 8 octobre 2012 Dernière intervention - 28 juin 2007 à 22:34
0
Utile
affiche le résutat de
find /etc/ -name 'php.ini' -exec grep sock {} \;

0
Utile
; Default timeout for socket based streams (seconds)
default_socket_timeout = 60
; Default socket name for local MySQL connects.  If empty, uses the built-in
mysql.default_socket =
; Default socket name for local MySQL connects.  If empty, uses the built-in
mysqli.default_socket =
; Default timeout for socket based streams (seconds)
default_socket_timeout = 60
; Default socket name for local MySQL connects.  If empty, uses the built-in
mysql.default_socket = "/var/lib/mysql/mysql.socket"
; Default socket name for local MySQL connects.  If empty, uses the built-in
mysqli.default_socket =
0
Utile
Merci cher ami de ta patience. Maintenant tout marche. @+ la communauté ccm, vous êtes génial.