Posez votre question Signaler

Plug-in Java

denzel - Dernière réponse le 24 juin 2009 à 12:01
salut à vous,

j'ai un problème sous linux (Red Hat 8.0), je n'arrive pas à voir les applets java dans mon navigateur (mozilla). Il me dit qu'il n'a pas le plug-in qu'il faut.

ok. Sauf que j'ai le plug-in en question (j2re1.4.1_02) !! J'ai bien exécuté mon fichier bin mais ça ne marche toujours pas. Et là je sais plus trop quoi faire, n'étant pas expert en linux : ) j'ai bien trouvé un fichier install.sh que j'ai exécuté mais ça n'a pas eu grand effet...

si certains peuvent m'aider, sans m'intéresse. ça m'éviterait de basculer sous windows à chaque fois pour tester les applets créées !!

merci,
Lire la suite 
Réponse
+1
moins plus
slt,
taka utiliser l'appletviewer de sun qui est livré avec le jsdk.
2ème option : tu réinstalle le jre en suivant bien les instructions sur le site de sun

<------Galfus------>
In penguin we trust
Ajouter un commentaire
Réponse
+0
moins plus
tu telecharge un plug in linux de chez
java.sun.com
Ajouter un commentaire
Réponse
+0
moins plus
il est possible que ce soit du a un probleme de comptatibilite.
les derniers mozilla sont compiles avec gcc-3.2 ou plus.
et pas le plugin de sun.
dans ce cas la il faut parait il utiiser blackdown.

il y a eu un autre probleme a un moment, avec une bibliotheque C++ de version differente, au pire des cas, ca se regle a coup de ln -s.

je te conseille de faire une petite recherche sur google avec mozilla 1.ta_version redhat 8.0.

heu, un leger doute: evidemment tu as fais le lien symbolique de /usr/local/java/j2sdk1.4.0/jre/plugin/i386/ns610/libjavaplugin_oji140.so vers /usr/lib/mozilla/plugins (à adapter suivant sa distribution et sa version de java etc...)?

--
pouet
Ajouter un commentaire
Réponse
+0
moins plus
salut,

ils ne parlent pas de l'installation du plug-in sur le site de sun..

pour ce qui est du fichier libjavaplugin_oji140.so, je l'ai effectivement copié dans le répertoire plugins de Mozilla mais du coup y'a un bug. Quand je lance une page qui fait appel au plugin, le navigateur se ferme tout seul....

Petit parenthèse: une petite pensée pour tous les profs grévistes grâce auxquels je ne peux pas passer mes exams. Vous êtes en train de vous mettre les étudiants à dos...
Ajouter un commentaire
Réponse
+0
moins plus
ce n'est pas vraiment un plugin
c la machine virtuelle java ou jre(java runtime environnement). C pour ça que sur le site de sun tu n'as pas vu plugin.
il te suffit de télécharger le jre sur le site de sun et de l'installer.
T'as essayé l'appletviewer ?

<------Galfus------>
In penguin we trust
Ajouter un commentaire
Réponse
+0
moins plus
oui désolé, c'était un abus de langage de ma part, je parlais non pas du plugin mais du JRE. Et donc, tu as les liens pour le télécharger mais ils ne t'expliquent pas comment l'installer.

Donc j'ai simplement exécuté mon fichier bin et mis les fichiers .so dans /usr/bin/mozilla-1.0.1/plugins. Et là ça plante. Si je ne met pas les fichiers .so, il ne se passe rien.

l'appletviewer marche bien oui mais ce n'est pas toujours forcément pratique.
pouet- 6 juin 2003 à 17:31
c est faux. le jre contient effectivement des plugins pour differentes versions de netscape.
tu _dois_ faire un lien symbolique comme je te l ai indique. la copie ne marche pas - ou plutot ne marchait pas la derniere fois que j ai essaye.
sinon il plante au lancement ou lors de la consultation de l applet?

--
pouet
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
salut pouet,

il plante au lancement de la page qui contient l'applet (au tout début, il n'affiche rien).

pour le lien symbolique, comment fait-on déjà ? si c'est mes souvenirs sont bons c'est pas un truc du genre : %lnk fichier_source nouveau_fichiers j'ai bon ?

denzel
pouet- 7 juin 2003 à 18:29
$ln -s /usr/local/jdk/pouet /usr/lib/mozilla/toto
tu verifie si le plugin est pris en compte:
Help/about_plugins
ensuite tu verifies qu il ne plante pas juste sur cette applet, et pas sur toutes.
grace a nos amis de chez redmond, il existe des applets non compatible.
si le plugin est detecte et que ca plante sur toutes les applets, je donne mon joker.

--
pouet
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
bonjour.

impossile de télécharger plug-in de java pour pouvoir tchater sur wanadoo par adsl 512k. que faire, merci?

mon système est windows xp family.
Ajouter un commentaire
Réponse
+0
moins plus
j'essaie de telecharger une machine virtuelle pour jouer et il y a une ligne java en bas de mon ecran qui cache le dialogue quand je telecharge java , y a t il un moyen d'enlever cette barre java au bas d emon ecran
Ajouter un commentaire
Réponse
+0
moins plus
Bonjour et merci d'utiliser mon adresse email personnelle (et non pas celle de mon employeur).
Voici mon problème:
J'ai essayé de faire ma declaration de revenu par internet. Après la première page de données, mon PC m'a demandé de vérifier si j'avais les données java dans mon système afin de pouvoir continuer.
Question : De quelle données java s'agit-il exactement et comment dois-je procéder ?
Merci par avance
Senta
PS :
J'ai un XP familial
Ajouter un commentaire
Réponse
+0
moins plus
Ajouter un commentaire
Ce document intitulé «  Plug-in Java  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.