Boot de FreeBSD sur Raspberry Pi [Fermé]

atlantis - 4 sept. 2014 à 19:58 - Dernière réponse : strght2hll 1 Messages postés samedi 13 septembre 2014Date d'inscription 13 septembre 2014 Dernière intervention
- 13 sept. 2014 à 18:01
Bonjour,

Apparemment plusieurs gens avant moi ont connus ce problème :

http://unix.derkeiler.com/Mailing-Lists/FreeBSD/current/2013-08/msg00626.html

Ce que je ne comprends pas c'est qu'il me fait cette erreur 2 redémarrages sur 3 et je ne serais pas le seul a qui c'est arrivé. Le problème c'est que je trouve peu de documentation et les correctifs ne sont pas très clair. Je ne suis pas très brillant en informatique, mais serait-ce une erreur de synchronisation ? (le temps que FreeBSD a pour reconnaître la carte SD.)

PS : J'ai une carte SD classe 10 8GB de la marque Kingston sur un Raspberry pi Model B
512MB

Merci d'avance
Afficher la suite 

2 réponses

mamiemando 28092 Messages postés jeudi 12 mai 2005Date d'inscriptionModérateurStatut 13 décembre 2017 Dernière intervention - Modifié par mamiemando le 5/09/2014 à 12:29
0
Utile
Si le mount échoue cela peut-être du au raisons suivantes :

1) Le device correspondant n'existe pas

Cela arrive si le noyau (ou les modules chargés) ne prennent pas en charge ce type de matériel. Voici par exemple les modules chargés chez moi pour que mon lecteur de carte sd fonctionne :

(mando@velvet) (~) $ lsmod | grep mmc_core
mmc_core 94043 4 mmc_block,sdhci,sdhci_acpi,rtsx_pci_sdmmc

S'ils ne sont pas chargés, tu peux essayer de voir si les charger avec la commande modprobe règle ton problème.

sudo modprobe mmc_core mmc_block sdhci sdhci_acpi rtsx_pci_sdmmc

Si tout va bien la commande suivante, tapée juste après avoir insérée la carte SD :

dmesg | tail

... devrait écrire qu'elle détecte ta carte :

[ 1422.186862] mmc0: new high speed SD card at address 3b1a
[ 1422.188542] mmcblk0: mmc0:3b1a SD512 488 MiB
[ 1422.189529] mmcblk0: p1
[ 1422.326120] FAT-fs (mmcblk0p1): utf8 is not a recommended IO charset for FAT filesystems, filesystem will be case sensitive!

Ici, le device /dev/mm0 est créé.

2) Le point de montage n'existe pas

Il s'agit du répertoire dans lequel le contenu du périphérique doit apparaître (par exemple /media/usb).

Ceci peut être un simple oubli (dans ce cas tu peux créer ledit répertoire avec la commande
mkdir -p
), ou bien signifier que les "mount ne sont pas faits dans le bon ordre. Par exemple, un système linux doit monter d'abord / (dont le système de fichier contient un répertoire /home vide) pour permettre ensuite à la partition /home de se monter.

3) Le système de fichiers utilisé n'est pas supporté

Comme les systèmes de fichiers (genre ntfs, vfat, ext4, ...) sont gérés grâce à des modules (en gros les "pilotes"), ceux-ci doivent être au préalable chargé. Par exemple impossible de monter un système de fichiers fat32 avant d'avoir chargé le module vfat.

Pour résoudre ton problème

/ance un shell et lance manuellement la commande
mount
. Les paramètres à lui passer sont directement indiqués dans
/etc/fstab
, dont tu peux afficher le contenu avec la commande :

cat /etc/fstab

Dans le cas général le format est :

mount -t filesystem -o options device point_de_montage

Exemple :

mkdir -p /media/mmc
mount -t vfat -o user,uid=mando /dev/mm0 /media/mmc
ls /media/mmc

Ainsi tu verras rapidement lequel des trois points ne va pas.

Bonne chance
strght2hll 1 Messages postés samedi 13 septembre 2014Date d'inscription 13 septembre 2014 Dernière intervention - 13 sept. 2014 à 18:01
0
Utile
par d'autres forums bsd j'ai trouvé ceci:
dans le fichier "loader.conf" (ds /boot/defaults/loader.conf)
ajoute la ligne suivante:

hw.bcm2835.sdhci.hs=0

cela permet de contourner ce bug qui est semble-t-il lié a un probleme de timeout du SoC bcm.
bien sur pour cela il faut que tu puisse au moin booter une fois pour effectuer le changement. J'avais le meme prob et depuis tout est ok!
bonne chance.