Signaler

.htaccess syntaxe [Résolu/Fermé]

Posez votre question pierrot77450 96Messages postés samedi 5 octobre 2013Date d'inscription 11 juin 2017 Dernière intervention - Dernière réponse le 26 mars 2014 à 17:58 par pierrot77450
Bonjour,

J'ai écrit un mini-site dans les nuages (1&1), nuage sous apache muni de .htaccess

J'ai essayé plusieurs choses et ou bien il n'y a aucune demande de mot de passe ou bien le nuage me renvoie une erreur 500 (j'ai oublié le libellé exact mais je crois erreur système)

Comme je ne connais pas .htaccess (je me suis servi d'un tuto sur comment ça marche) je voudrais faire vérifier la syntaxe avant de contacter le "maître des nuages"

Dans les nuages j'ai une racine (virtuelle?) un directory Lab, et à l'intérieur de Lab un directory site
J'ai mis .htpasswd (non crypté) dans Lab et .htaccess dans site

.htaccess
AuthUserFile /Lab/
AuthGroupFile /dev/null
AuthName "Accès réservé aux associés"
Authtype Basic

<Limit GET > Require valid-user
</Limit>

.htpasswd
pierreyves : toto

Merci d'avance

Afficher la suite 
Utile
+1
plus moins
Salut,

.htpasswd
pierreyves : toto

Il ne faut pas d'espaces autour du caractère deux points ( : ) ;-(

pierreyves:toto
Cette réponse vous a-t-elle aidé ?  
zipe31 34824Messages postés dimanche 7 novembre 2010Date d'inscription ContributeurStatut 10 août 2017 Dernière intervention - 26 mars 2014 à 16:48
Et il faut le chemin absolu complet vers le fichier .htpasswd :

.htaccess
AuthUserFile /Lab/.htpasswd
Utile
+0
plus moins
Merci; je vais essayer
J'ai aussi trouvé une majuscule manquante dans AuthType
Utile
+0
plus moins
Même message d'erreur
Le message exact est:
Error 500 - internal server error

un problème inattendu est survenu
veuillez réessayer ultérieurement
zipe31 34824Messages postés dimanche 7 novembre 2010Date d'inscription ContributeurStatut 10 août 2017 Dernière intervention - 26 mars 2014 à 16:58
A voir : http://www.wistee.fr/erreur-http/500-internal-server-error.html
zipe31 34824Messages postés dimanche 7 novembre 2010Date d'inscription ContributeurStatut 10 août 2017 Dernière intervention - 26 mars 2014 à 16:59
A voir aussi : https://www.google.com/search?q=Error+500+-+internal+server+error#q=error+500+internal+server+error+1and1
Utile
+0
plus moins
J'ai corrigé le chemin

AuthUserFile /Lab/.htpasswd
AuthGroupFile /dev/null
AuthName "Accès réservé aux associés"
AuthType Basic

<Limit GET > Require valid-user
</Limit>

et j'ai supprimé les espaces autour des deux points.

J'ai toujours le même message.

Est-ce que j'ai le droit de mettre la table des mots de passe à un niveau supérieur au site?
zipe31 34824Messages postés dimanche 7 novembre 2010Date d'inscription ContributeurStatut 10 août 2017 Dernière intervention - 26 mars 2014 à 17:41
Je n'en sais trop rien, je ne suis pas spécialiste en matière de serveur Apache et de ses méandres ;-(

Regarde les liens que je t'ai filés. As-tu contacté le SAV de 1&1 ?
zipe31 34824Messages postés dimanche 7 novembre 2010Date d'inscription ContributeurStatut 10 août 2017 Dernière intervention - 26 mars 2014 à 17:43
Tiens j'ai trouvé ça chez 1&1 : Explanation of 500 Errors
Utile
+0
plus moins
Moi non plus. je suis un pauvre utilisateur lambda.

Je n'ai pas encore contacté le SAV pour ne pas passer pour une bille. Je vais donc le faire maintenant (ou demain)
Pour le lien sur l'erreur 500 je te remercie. Il n'y a presque aucun trafic sur mes pages. En revanche je ne sais pas combien de mémoire j'utilise. Il faut que je vérifie que je n'ai pas laissé de trop gros fichiers mais je ne pense pas.
Pour ce qui est de mettre des # je n'ai mis qu'un seul .htaccess

Merci de ton aide

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !