Signaler

[Conversion]Disque dur externe FAT32>NTFS [Résolu/Fermé]

Posez votre question Kelthalas - Dernière réponse le 8 mai 2017 à 17:14 par 120496
Bonjour,
Voila mon problème: Je souhaiterai convertir mon DD externe de FAT32 vers NTFS (fichier de plus de 4Go) J'utilise donc la commande native a Windows > convert h: fs:ntfs
Mais la problème: le volume est utilisé par un autre processus. Il me propose de faire la conversion au prochain demarrage mais comme c'est un disque dur externe au prochain demarrage il ne sera pas demarré.
Merci d'avance!
Utile
+51
plus moins
Salut Lagon_Bleu !

Il te faut taper cette ligne de commande dans " l'Invite de commande "
Que tu trouvera dans Démarrer => Programmes => Accessoires => Invite de commande

Donc c'est une fenêtre noire où tu dois taper ces lignes :

CHKDSK /F "nom_du_lecteur":

Qui vérifiera ton disque (le préparera)



Puis cette ligne :

convert "nom_du_lecteur": /fs:ntfs /x

Qui convertira donc ton disque..



N'hésite pas a nous tenir au courant !


AB
Cette réponse vous a-t-elle aidé ?  
ToNy MoNtOnO- 1 janv. 2014 à 13:56
Au top j'ai mis un peu de temps à comprendre mais çà marche du feu de dieu! Merci
Chantal- 8 sept. 2014 à 04:33
On me demande le nom du volume. Qu'est-ce que je dois écrire? Merci de votre aide!
daily lama- 6 oct. 2014 à 20:14
hello je tape les lignes de commandes ca marche , enfin ca me donne ule liste de tache a effectuer sur le disque mais ca ne bouge plus par la suite la conversion se fait sur une longue durée ou c rapide ?
merci d'avance
eliot08 8Messages postés lundi 14 février 2011Date d'inscription 17 février 2017 Dernière intervention - 17 févr. 2017 à 11:34
bonjour
j'ai essayé de suivre ta configuration avec mon DD amovible qui est en FAT32 mais j'ai le message suivant :
CHKDSK ne peut pas s’exécuter parce que le volume est utilisé
par un autre processus. Voulez-vous que ce volume soit
vérifié au prochain redémarrage du système ? (O/N) O
Répondre
120496 2Messages postés samedi 16 février 2013Date d'inscription 8 mai 2017 Dernière intervention - 8 mai 2017 à 17:14
Merci bcp pour cet aide ! en plus avec un DD plein (1 To) je n'ai rien perdue c'est génial !!
Répondre
Utile
+8
plus moins
Je viens de suivre votre conseil pour passer mon disque dur externe en NTFS et pouvoir enregistrer des gros fichiers dessus, et tout s'est passé impeccablement, alors je vous en remercie sincèrement.

Astuce pour passer en mode administrateur, si vous obtenez "Accès refusé, vous n'avez pas de privilèges suffisants. Vous devez invoquer cet utilitaire dans un mode d'execution élevé" :
DEMARRER/PROGRAMMES/ACCESSOIRES, puis clic droit sur INVITE DES COMMANDES et EXECUTER EN TANT QU'ADMINISTRATEUR

La suite est décrite plus haut.

Aucune perte de données, tout est NICKEEEEEEEL!!!
MILLE MERCIS
Utile
+4
plus moins
Oki ca marche merci les gars
Utile
+3
plus moins
Bonjour,

moi aussi j'ai essaié de convertir mon DDext Fat 32 en NTFS
G bien été dans l'invite de commande mais lorsque je tape la première ligne
il me met " impossible d'ouvrir le volume en accès direct "
que dois-je faire ?

je suis sous windows 7
c un DDext de 1To WD

Merci de votre aide
Utile
+2
plus moins
Hello,

Un grand merci pour cette méthode. ça a marché nickel et du premier coup. Aucune perte de données sur le DD.

Je peux enfin transférer plus gros que 4 Giga. Du bonheur grace à vous.

Merci
Utile
+2
plus moins
vous étes trop fort, merci.
Utile
+2
plus moins
stg13rebel, Prends le temps de lire son message et tu verra qu'il a appliqué la bonne procédure.

Si intégralité de ce lecteur est incertaine c'est que le disque dur comporte des erreurs, exécute un chkdsk depuis Démarrer/Exécuter, tapes chkdsk i: /r

P.S. : tu es sur que la lettre i est bien celle qui est attribuée à ton lecteur ?

Utile
+2
plus moins
Salut
Il te faut taper cette ligne de commande dans " l'Invite de commande "
Que tu trouvera dans Démarrer => Programmes => Accessoires => Invite de commande

Donc c'est une fenêtre noire où tu dois taper ces lignes :

CHKDSK /F "nom_du_lecteur":

Qui vérifiera ton disque (le préparera)



Puis cette ligne :

convert "nom_du_lecteur": /fs:ntfs /x

Qui convertira donc ton disque..

j'avais le même problème et j'ai suivi ce qui est cité ci dessus et ça marche
Utile
+2
plus moins
moi tout fonctionne jusqu'a la fonction convert où j'ai come réponse apres avoir tout mis : "spécification de lecteur non valide"
Mayot35 514Messages postés mardi 11 mai 2010Date d'inscription 9 mai 2017 Dernière intervention - 20 mars 2011 à 22:32
J'ai eu ca aussi, alors que le check disk m'as dit "windows a vérifié sans trouver de problème".
J'ai formater (attention vérifie bien que tu n'as pas de données importante a sauvegarder avant car tout sera effacer !)

la commande : format X: (x étant la lettre attribué au lecteur a formater)

et ensuite j'ai converti !
Si la conversion marche pas essaye la même commande mais tu enlèves le '/x' à la fin ;)
Utile
+2
plus moins
Je suis désolé, ça fait plus de 2h que je répète de manière inlassable tout ce qui a été inscrit dans ce forum... je crois que je v renvoyer le disque dur externe que je viens de m'acheter.. parce que là ça m'énerve pas mal, car rien ne fonctionne comme je le souhaiterai.. je trouve scandaleux ce système de FAT:32 alors que la plupart des gens ont à mettre dessus des fichiers *.iso ou d'autres gros fichiers pour ne pas avoir à les stocker dans le disque dur de l'appareil.... purement scandaleux...
Donc c'est l'invite de commandes j'ai taper ces lignes :

CHKDSK /F "nom_du_lecteur": ( le disque dur externe est représenté par la lettre "i")

Ça a vérifié le disque externe(ça l'a préparé)

Puis cette ligne :

convert "i": /fs:ntfs /x

Qui devrait convertir donc mon disque..

Et bien sûr rien ne marche...
Il me sort (comme si je ne le savais déjà pas) que le type de fichiers su système est FAT32
et ensuite d'entrer le nom du volume en cours pour le lecteur "i" , et c là que ça blesse !! que dois-je écrire? le disque externe est un toshiba avec un logo E-store devant le I c marqué Toshiba USB-HDD, que dois je marquer? j'ai tout essayé.. et là franchement ça me les brise gigantesquement !! alors j'ai remplacé le x à la fin de la seconde commande par "i" le nom de mon lecteur, rien y fait...
J'imagine bien qu'il y a quelqu'un a qui il ai arrivé exactement la même aventure merdique...
Je demande un peu d'aide, parce que ça m'a bien pourri mon après-midi !
baroner- 9 juil. 2010 à 21:29
bon ça a marché, par je ne sais quel miracle.. d fois je me demande si il ni a pas quelqu'un dans l'ordi..parce chez windows les choses qui marchent du 1er coup.. m'enfin ..
laety- 10 mars 2015 à 12:13
tro fort !
leon91490 183Messages postés mardi 19 mai 2009Date d'inscription 9 septembre 2017 Dernière intervention - 25 mars 2012 à 00:26
heu tu as rentréé

convert i: /fs:ntfs /x

ou alors convert "i"; ... parce que là c'est sur qu'il risque de pas marcher aussi bien.
Aleks- 18 mars 2014 à 19:47
Salut Baroner, j' ai le même problème t' as fait comment toi ? Tu as rentré quoi ?
Utile
+1
plus moins
Bonjour à tous,

J'ai commencé a convertir mon dd externe fat32 en ntfs avec la manip habituelle. Mais...erreur de manip ou autre, mon pc a rebooté sans que je fasse quoi que ce soit. (je soupçonne fortement mon fils ainé d'avoir fait une connerie alors que la conversion était en cours. Du coup, mon disque est illisible. Comment puis-je faire pour au moins récupérer mes données à présent innaccessibles. OUIN!!!!!!
MrTomate GiLe46 - 11 mai 2009 à 21:58
En effet et un grand merci GiLe46, ta commande fonctionne parfaitement, y compris sous vista...
JP GiLe46 - 15 déc. 2009 à 20:19
Bonjour,

Testé et approuvé :

CHKDSK /F "nom_du_lecteur":
convert "nom_du_lecteur": /fs:ntfs /x

J'ai fais tout ceci, mais il me demande:

Entrez le nom de volume en cours pour le lecteur F:

Et j'ai beau essayer f, F, f:, F:, F:/, f:/, et pareil avec les G, il me dit toujours:

Un nom de volume incorrect a été entré pour ce lecteur.

Merci d'avance de m'aider.
JP- 16 déc. 2009 à 21:43
Résolu. Il suffit de mettre le même nom que le disque dur a dans le poste de travail.
Tibo- 29 avril 2010 à 08:03
Par "nom", JP veut dire le véritable nom donné au disque dur (pas sa lettre)
oto86- 21 juil. 2016 à 14:06
Bonjour,
Pour les personne qui ont le message '' Entrez le nom de volume en cours pour le lecteur xx: ''
Il faut taper le nom du volume '' xxxxx'' (sans '' ) qui figure dans le ligne :
volume ''xxxxxx'' à crée le jj/mm/aaaa hh:mm
vous trouverai cette ligne après la 1er étape du 'CHKDSK /F ''X'': ...''
Utile
+1
plus moins
Bonjour à tous,
ça fait un petit moment que je cherche une solution mais en vain.
Cela fait peut être 10 fois que j'essaye les lignes de commandes dictées un peu plus haut, mais ça ne veut toujours pas se convertir.
Je fais CHKDSF /F I: là tout se passe très bien donc je passe à la suite,
je tape convert I: /fs:ntfs /x il me demande le nom de volume en cours pour le lecteur I: (qui est packardbell)
Ca travaille un peu et je me retrouve devant : l'intégralité de ce lecteur est incertaine et il ne peut pas être converti. Vous devez remettre le bit d'intégrité de ce lecteur à zéro en exécutant CHKDSK /F ou en autorisant l'exécution de AUTOCHK au prochain redémarrage. La conversion a échoué. I: n'a pas été converti en nfts"
Que faire ?
Merci d'avance
sgt13rebel- 31 janv. 2010 à 18:45
Bonsoir,
il suffit d'écrire la lattre qui correspond au DD externe sans les guillemets, ensuite il demande le nom du volume en cours (c'est le nom du DD).
moi ça a marché
@+
seytec- 22 juin 2010 à 13:04
bonjour j'ai un disque externe plein de données qui passe en mode raw une aide svp j'ai fais chkdsk ca ne donne pas grand chose il me dit ce type de fichier est raw
bidouille- 22 janv. 2012 à 15:29
Merci sgt13rebel
grâce toi j'ai pu résoudre mon problème à savoir lettre du DD sans les guillemets et ensuite le nom du volume
Utile
+1
plus moins
Super ce post !

j'ai transformé mon fat 32 en ntfs en deux coups de cuiller à pot.

Merci à tous !
Utile
+1
plus moins
Bonjoiur le probleme n'est toujours pas résolu pour moi

J'ai taper dans l'anvit de commande (en tant qu'administrateur) les lignes suivantes

CHKDSK /F F:
La tout fonctionne!

Ensuite
CONVERT F: /fs:ntfs/x
Et la il me dit que le type du systeme est en FAT 32 (logique)
puis il vérifie les fichiers et les dossiers et ne trouve pas de probleme
MAIS ensuite, il me dit:

L'intégrité de ce lecteur est incertaine et il ne peut pas etre converti.
Vous devez remettre le bit d'intégrité de ce lecteur à zéro en exécutant
CHKDSK /F ou en autorisant l'exécution deAUTOCHK au prochain redémarrage.
La conversion a échouée
F: n'a pas éte converti en ntfs.


Voila, je bloque..

D'avance merci
Anonymous- 10 déc. 2010 à 22:20
Salut Jberger !
Comme le message l'indique, je te propose de redemarer ta machine et de laisser l'exécution de AUTOCHK se derouler.
Puis de refaire un essais après avoir laissé ta machine démarer normalement ;)
Bon courage !
leon91490 183Messages postés mardi 19 mai 2009Date d'inscription 9 septembre 2017 Dernière intervention - 1 avril 2012 à 15:08
et vous savez !!!! les checkdisk c'est du 0 ! sur les disques durs on a dejà de "checkdisk" en place. chaque secteur a une trame de début et de fin. on a une trame pour maintenir la vitesse du disque, ensuite le numero de secteur et de piste, et ensuite des codes de contrôle.

et le checkdisk est fait en permanence sur le disque. lorsque on lit un secteur lorsque on passe sur une erreur on fait de suite la correction. si erreur le disque a des pistes de secours (souvent plus lentes à lire) et les checkdisk ne font que causer des problemes en plus parce qu'ils font des séries d'ecriture et de lecture systématique des secteurs du disque. qui saturent les pistes de reserve du disque dur à cause des pannes ponctuelles.

les controles de disque ca fait les problemes qu'ils sont sensé détecter. sous linux les controles de disque y en a pas et c'est tant mieux.
Utile
+0
plus moins
salut,

essaye depuis le boot sur le cd d'xp puis choix console "R" ensuite une fois logé sur l'invité tappe la commande convert.
Ceyar69700- 8 nov. 2009 à 18:35
Ca veut dire quoi ça "le boot sur le cd d'xp puis choix console "R" ensuite une fois logé sur l'invité tappe la commande convert. " J'ai mis le CD d'XP et je ne vois rien de semblable.


J'ai essayé vos manips "convert j: /fs:ntfs" mais voila le message que j'ai => L'intégralité de ce lecteur est incertaine et il ne peut être converti. Vous devez nettoyer le lecteur en exécutant CHKDSK /F ou en autorisant l'exécution de AUTOCHK au prochain réamosçage.
J: n'a pas été converti en NTFS
Utile
+0
plus moins
j'aurais pas dit mieux
Utile
+0
plus moins
Salut
D'abord essayer ça:
convert h: fs:ntfs /x
Lacommande "convert" n'existe pas sur la console de récupération.
Essayer de l'utiliser en mode sans échec ou bien d'arrêter le proocessus qui utilise ce disque.
Si c'est explorer terminer-le dans le gestionnaire des tâches.
ctrl-alt-supr pour le lancer.
fichier-nouvelle tâche- cmd

Bonnechance.
Elfstat 3Messages postés jeudi 5 novembre 2009Date d'inscription 17 novembre 2009 Dernière intervention - 17 nov. 2009 à 13:35
Bonjour tt le monde,

Med, à quoi sert le /x à la fin de la commande?

Je vais essayer ce soir.

Merci d'avance;

Elfstat
Utile
+0
plus moins
convert h: /fs:ntfs /x
Utile
+0
plus moins
Merci a tous. Enfait j'ai juste accepter le "forcer le demontage du volume" (je crois que cest ça qu'il était marqué)

Désolé pour la faute de frappe j'ai oublié le /

Merci encore
leon91490 183Messages postés mardi 19 mai 2009Date d'inscription 9 septembre 2017 Dernière intervention - 25 mars 2012 à 01:00
ha d'accord

si vous voulez rentrer dans une maison d'un monsieur et que quelqu'un est dedans, vous allez peut etre pas y arriver aussi bien que vous voudriez.

le montage c'est necessaire en multi utilisateurs... ca fait une vitrine identique pour des utilisateurs différents. par exemple léon travaillé dans son coin sur le disque c: et julie travaille sur le disque e: mais là julie peut tres bien aller sur le disque c: elle aussi et mettre le souk dessus.

alors on mets un dossier commun aux deux... mes documents... mais via le montage julie et léon voient la meme chose mais julie son mes documents est e; et pour léon mes documents c'est c:

donc ils écrivent pas au meme endroit. et si patron veut changer le format du disque e; et bien on lui oppose que le disque est en usage par quelqu'un.


contre ca, on a la solution de couper les ponts entre julie et le convert du disque e; mais alors julie a des mauvaise surprises en sauvegardant son travail sur les ponts sont coupés.

donc c'est pas une bonne idée que de forcer la déconnexion du disque. le mieux c'est peut etre de mettre un cd de réparation et mettre le disque au format ntfs sans risque de processus qui vienne se mettre en conflit.

sous windows c'est mode sans echec. et donc lancer via f8 au démarrage.
Utile
+0
plus moins
Salut,

si tu disque dur est passé en raw c'est qu'il a un problème, il faut utiliser Testdisk pour essayer de le restaurer.

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !