Créer une alerte "anniversaire" sur fichier client pour mailing [Résolu/Fermé]

sebelo31 3 Messages postés lundi 16 décembre 2013Date d'inscription 20 décembre 2013 Dernière intervention - 17 déc. 2013 à 15:30 - Dernière réponse :  acolyte
- 19 mai 2017 à 20:42
Bonjour,
Toujours sur mon fichier clients ... et toujours mes limites.
Je souhaite maintenant créer les alertes "Bientôt anniversaire" (20 jours avant le jour J) et "jour d'anniversaire" (le jour J évidemment) pour penser à leur envoyer une offre par mail.
Sous quel format doit être entré la date? (actuellement jj/mm)
Encore merci d'avance...


Afficher la suite 

4 réponses

melanie1324 1508 Messages postés vendredi 25 mai 2007Date d'inscription 5 octobre 2016 Dernière intervention - 17 déc. 2013 à 16:19
+5
Utile
1
Bonjour,

Voici la formule :

J'ai supposé que ta date était en C3 et qu'elle avait le format jj/mm :

=SI(AUJOURDHUI()=TEXTE(JOUR(C3)&"/"&MOIS(C3)&"/"&ANNEE(AUJOURDHUI());"jj/mm/aaaa")+0;"Anniversaire";SI(ET(AUJOURDHUI()>=TEXTE(JOUR(C3)&"/"&MOIS(C3)&"/"&ANNEE(AUJOURDHUI());"jj/mm/aaaa")-20;AUJOURDHUI()<0+TEXTE(JOUR(C3)&"/"&MOIS(C3)&"/"&ANNEE(AUJOURDHUI());"jj/mm/aaaa"));"Bientôt Anniversaire";""))


==> TEXTE(JOUR(C3)&"/"&MOIS(C3)&"/"&ANNEE(AUJOURDHUI());"jj/mm/aaaa")+0
permet de convertir ta date jj/mm en jj/mm/année du jour pour pouvoir être comparé à aujourdhui()

et voici ce que fait la formule en français
==> si(aujourdhui()=date anni ;"anni"; si(et(aujourdhui >= date-20jours;aujourdhui() < date anni);"Bientôt anni";""))
Cette réponse vous a-t-elle aidé ?  
Bonjour,
Est-il possible d'ajouter une condition afin qu'apparaisse une alerte supplémentaire : 20 jours AVANT l'anniversaire ?
Merci par avance
sebelo31 3 Messages postés lundi 16 décembre 2013Date d'inscription 20 décembre 2013 Dernière intervention - 20 déc. 2013 à 11:53
0
Utile
1
Un immense merci !
Je suis revenue sur ce dossier aujourd'hui ... et ça marche !
Je suis ravie.
Votre aide est précieuse, je n'aurai jamais trouvé une formule pareille toute seule. J'ai juste ajouté (c3"";"" pour que n'aparaisse pas "valeurs!" dans la case anniversaire, s'il n'y a pas de date entrée.
Voilà une belle épine dans le pied retirée.
Mon tableau est fin prêt et mon client va être ravi.
Je vous souhaite de passer d'excellentes fêtes de noël et une très bonne année 2014.
melanie1324 1508 Messages postés vendredi 25 mai 2007Date d'inscription 5 octobre 2016 Dernière intervention - 20 déc. 2013 à 11:55
Merci Bonnes fêtes également