Signaler

[Ubuntu] Quelques questions générales..... [Résolu/Fermé]

Posez votre question Aska 164Messages postés samedi 9 décembre 2006Date d'inscription 19 avril 2016 Dernière intervention - Dernière réponse le 24 avril 2007 à 00:49 par mamiemando
Bonjour à tous,
Je viens de passer sous Linux et j'aurais deux trois questions :

1° J'ai donc une partition principale avec windows XP
et une partition étendue avec : la partition avec ubuntu (60G)
+ partition swap (1G)
+ partition en fat32 (1G)
Or sur mon bureau actuel il y a ma partition windows qui apparait ("hda1") pas les autres partitions .... c'est normal ?
(je n'ai pas crée de partition /home car j'ai un DD externe, peut-être aurais-je quand même dû ?)

2° Lors de l'installation de Flash Player on me dit : "In terminal, navigate to the desktop and type # rpm -Uvh <rpm_package_file>. Cick Enter."
c'est le "navigate to the desktop" que je pige pas....

3° Amarok ne veut pas lire mes mp3 :(
j'ai beau appuyer sur "install mp3 support" une fois installé ça ne change rien....

4° Firefox : tous les onglets et explications sont en français sauf marque-pages et aide où les listes sont moitié anglais moitié français... c'est normal ? ("marquer cette page..." mais "bookmark toolbar folder")

5° question à deux balles : comment on ajoute des émoticones sur gaim ? :)

Merci.
Afficher la suite 
Utile
+0
plus moins
1)

- Pour le disque qui apparaît sur le bureau c'est un réglage "ubuntu" qui se corrige soit dans ~/.gnome soit ~/.kde selon ce que tu utilises. Fouille un peu google et tu vas trouver.
- Pour le partitionnement, non il est très bien, séparer /home n'a d'intérêt que si plusieurs linux partagent un /home commun, ce qui n'est pas ton cas. Et comme un linux est (presque) toujours sauvable avec un liveCD contrairement à windows, il n'est pas forcément nécessaire de séparer / et /home. Personnellement je ne le fais jamais.

2)

rpm n'a rien à voir avec ta distribution (les rpm c'est pour les mandrivas notamment), toi il te faut des paquets debian. Pour installer flash, il suffit de passer par ton gestionnaire de paquet (par exemple aptitude, adept, synaptics etc...).

3)

Il faut installer les plugins (par exemple gstreamer, musepack, w32codecs etc...) pour lire les mp3. Il faudra rajouter peut-être rajouter des depôts universe et multiverse
http://doc.ubuntu-fr.org/depots/edgy

4)5) Je passe
Utile
+0
plus moins
Le problème ce que je ne comprend absolument rien à l'utilisation du terminal....

"Ouvrez votre fichier /etc/apt/sources.list avec les droits d'administration avec l'une des commandes suivantes :
* Sous Ubuntu ou Edubuntu :
~$ gksudo gedit /etc/apt/sources.list" (http://doc.ubuntu-fr.org/depots/edgy)

désolé mais pour moi c'est du chinois ça
me suis farci le tuto linux (communauté ubuntu-fr) mais ça n'explique pas comment ça marche (de plus la majorité de leurs exemples ne fonctionnent plus...)


"Pour installer flash, il suffit de passer par ton gestionnaire de paquet (par exemple aptitude, adept, synaptics etc...). "
c'est-à-dire synaptic ?
Benj- 17 avril 2007 à 13:14
gedit /etc/apt/sources.list

gedit c'est la commande qui lance l'editeur de texte
/etc/apt/sources.list c'est le chemin + le fichier (sources.list) que tu va editer.

Les gestionnaires de paquets, sont des des commandes qui vont télécharger et installer, les logiciels sur ton pc.

Je t'aide pas plus, parceque mes connaissances sont aussi très faibles ;)
Utile
+0
plus moins
Il suffit de recopier bêtement ce qui est sur la page dans un terminal. La le but c'est juste de modifier un fichier de configuration (ici /etc/apt/sources.list qui liste les serveurs sur lesquels chercher des mises à jours et quels mises à jours télécharger) appartenant à root (d'où le gksudo) avec un éditeur texte (ici gedit).
Utile
+0
plus moins
il me mets ça : bash: /etc/apt/sources.list: Permission non accordée

???

il m'arrive tout le temps ce genre de trucs quand je tente des manips avec le terminal
Utile
+0
plus moins
D'où l'intérêt du gksudo :
gksudo gedit /etc/apt/sources.list
Aska 164Messages postés samedi 9 décembre 2006Date d'inscription 19 avril 2016 Dernière intervention - 18 avril 2007 à 01:59
effectivement ça prend tout son sens ainsi :)
Merci!

C'est tout de même frustrant de bloquer face à des choses si simples.... pourquoi je ne trouve pas de tuto qui explique clairement la logique d'ubuntu dans toutes les manips....
(les tutos proposent souvent l'explication style "je réussi mes install sans comprendre ce que je fais" c'est dommage ....)
Utile
+0
plus moins
Par contre (je voudrais pas abuser.... mais gasp je m'en sors pas trop) pourrais-tu expliquer plus clairement les manips proposées dans post #1 ?

1. j'ai gnome, je fais comment donc pour faire apparaitre mon dd linux sur le bureau plutot que celui de winxp ?

2. quelles lignes dois-je rajouter exactement ?

3. euh je télécharge lequel alors ?

Merci!
Utile
+0
plus moins
C'est tout de même frustrant de bloquer face à des choses si simples.... pourquoi je ne trouve pas de tuto qui explique clairement la logique d'ubuntu dans toutes les manips

Il suffit de lire la doc :-) Dis toi qu'ubuntu c'est l'une des distributions les mieux documentées avec gentoo.
http://doc.ubuntu-fr.org/sudo

1. j'ai gnome, je fais comment donc pour faire apparaitre mon dd linux sur le bureau plutot que celui de winxp ?
2. quelles lignes dois-je rajouter exactement ?


Je ne connais pas assez gnome pour te dire. A priori j'imagine que tu as une sorte d'explorateur (l'equivalent du konqueror sous gnome), il suffit de glisser déposer l'icone de ton menu gnome sur ton bureau. Sous KDE il suffit de créer une icône qui lance :
kfmclient openProfile filemanagement

Et ça ouvre konqueror dans ton home... Pour gnome aucune idée.

3. euh je télécharge lequel alors ?

Je suppose que tu parles des mises à jours. SI c'est le cas ubuntu va automatiquement interroger tous les miroirs. J'imagine que toi tu utilises synaptics ou adept mais ça revient en fait à faire un :
sudo aptitude update
sudo aptitude upgrade
Pour les questons que tu avais posée dans <1> :
2) Tu as un paquet flash tout prêt :
(mando@aldur) (~) $ apt-cache search flash | grep -i flash | grep -i mozilla
libflash-mozplugin - GPL Flash (SWF) Library - Mozilla-compatible plugin
swf-player - Mozilla plugin for SWF files (Macromedia Flash)

Donc hop c'est parti, on installe ces deux paquets par exemple avec aptitude
sudo aptitude install libflash-mozplugin swf-player

3) Je pense que tu peux utiliser juste les plugins xine (et donc pas besoin de gstreamer) :
sudo aptitude install amarok-xine

5) Alors il va falloir apprendre à chercher dans tes paquets :
(mando@aldur) (~) $ apt-cache search gaim | grep -i gaim
...
gaim-libnotify - display notification bubbles in gaim
gaim-librvp - MS Exchange RVP instant messaging plugin for GAIM
gaim-otr - Off-the-Record Messaging plugin for gaim
gaim-themes - Smiley themes collection for gaim
gaim-thinklight - Blinks your ThinkPad's ThinkLight upon new messgaes
gaim-xmms-remote - gaim-plugin that lets you control XMMS from gaim
...

Partant de là
sudo aptitude install gaim-themes

Bonne chance
Utile
+0
plus moins
sudo aptitude update

ça semble avoir marché puisqu'il m'a dit «liste des paquets faits» (à moins qu'il en s'agissait d'un message du père noël envoyé par erreur... ok je sors)

2. Flash

Donc hop c'est parti, on installe ces deux paquets par exemple avec aptitude
sudo aptitude install libflash-mozplugin swf-player


J'ai lancé ça dans mon terminal, ça semble avoir «fonctionné» enfin la machine semble avoir compris ce que je lui demandais (bien que <gras>moi pas ;)) : du texte a défilé... puis on m'a demandé mon avis, j'ai répondu «yes».... du texte a continué à défiler ensuite ça s'est arrêté d'un air satisfait.
mais par contre je n'ai aucune idée de ce que je vais faire ça maintenant :


(mando@aldur) (~) $ apt-cache search flash | grep -i flash | grep -i mozilla
libflash-mozplugin - GPL Flash (SWF) Library - Mozilla-compatible plugin
swf-player - Mozilla plugin for SWF files (Macromedia Flash)


dans le terminal ça ne donne rien en tout cas.
De plus ai encore des problème pour lire certaines vidéos.....

3, Amarok


sudo aptitude install amarok-xine

ok il me met ça :
Configuration de sun-java6-jre Operating System Distributor License for Java v1.1 (DLJ) ↑
│ ▮
│ Operating System Distributor License for Java version 1.1 (DLJ) ▒
│ SUN MICROSYSTEMS, INC. ("SUN") IS WILLING TO LICENSE THE JAVA PLATFORM
│ STANDARD EDITION DEVELOPER KIT ("JDK" - THE "SOFTWARE") TO YOU ONLY UPON
│ THE CONDITION THAT YOU ACCEPT ALL OF THE TERMS CONTAINED IN THIS LICENSE
│ AGREEMENT (THE "AGREEMENT"). PLEASE READ THE AGREEMENT CAREFULLY. BY
│ INSTALLING, USING, OR DISTRIBUTING THIS SOFTWARE, YOU ACCEPT ALL OF THE ▒
│ TERMS OF THE AGREEMENT. ▒
│ ▒
│ 1. DEFINITIONS. "Software" means the code identified above in binary ▒
│ form, any other machine readable materials including, but not ▒
│ limited to, libraries, source files, header files, and data files), ↓

│ <Ok>

mais quand j'appuye sur ok il se passe rien, alors j'ai juste fermé la fenêtre

5. Pour Gaim (pas très important c'est vrai) idem que plus haut :


Partant de là
sudo aptitude install gaim-themes


easy game c'est fait

Alors il va falloir apprendre à chercher dans tes paquets :
(mando@aldur) (~) $ apt-cache search gaim | grep -i gaim
...
gaim-libnotify - display notification bubbles in gaim
gaim-librvp - MS Exchange RVP instant messaging plugin for GAIM
gaim-otr - Off-the-Record Messaging plugin for gaim
gaim-themes - Smiley themes collection for gaim
gaim-thinklight - Blinks your ThinkPad's ThinkLight upon new messgaes
gaim-xmms-remote - gaim-plugin that lets you control XMMS from gaim
...


par contre ça je sais pas quoi en faire
Utile
+0
plus moins
Alors je pense qu'un peu de lecutre t'éclaircira l'esprit :-)
man aptitude
man apt-cache

A noter que tout ce que je te fais faire avec aptitude devrait être faisable avec synaptic (gestionnaire de paquet) mais je ne sais pas comment il marche.

Quand tu auras lu les man tu t'aperceevra que je t'ai juste fais faire des recherches et des installations de paquet. Le rôle du apt-cache search est de trouver le nom exact du paquet (qui peut différer sur ton ubuntu vu que j'utilise une debian), et le aptitude install à l'installer. Typiquement
apt-cache search flash | grep -i flash | grep -i mozilla 

sert à chercher les paquets en rapport avec flash, dont le nom ou la description contient flash et mozilla. Dans cet exemple chez moi ça donne :
libflash-mozplugin - GPL Flash (SWF) Library - Mozilla-compatible plugin
swf-player - Mozilla plugin for SWF files (Macromedia Flash)

Pour installer le lecteur de fichier swf il suffit de taper par exemple :
sudo aptitude install  swf-player

Bonne chance

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !