Problème de dependance sur le kernel [Résolu/Fermé]

khrogos 49 Messages postés dimanche 24 mars 2013Date d'inscription 10 juillet 2013 Dernière intervention - 3 juil. 2013 à 12:18 - Dernière réponse : khrogos 49 Messages postés dimanche 24 mars 2013Date d'inscription 10 juillet 2013 Dernière intervention
- 9 juil. 2013 à 09:46
Salut les gens du fofo !

Au boulot, on vient de me filer un nouveau pc (qui était utilisé par un autre auparavant), chouette me dis-je !
première chose : apt-get update et apt-get upgrade, et c'est ce dernier qui coince :

Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 linux-generic : Dépend: linux-image-generic (= 3.2.0.43.51) mais 3.2.0.48.58 est installé
                 Dépend: linux-headers-generic (= 3.2.0.43.51) mais 3.2.0.48.58 est installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.


je lance donc le apt-get -f install, il se finit comme ça :
dpkg : des problèmes de dépendances empêchent la configuration de linux-generic :
 linux-generic dépend de linux-image-generic (= 3.2.0.43.51) ; cependant :
  La version de linux-image-generic sur le système est 3.2.0.48.58.
 linux-generic dépend de linux-headers-generic (= 3.2.0.43.51) ; cependant :
  La version de linux-headers-generic sur le système est 3.2.0.48.58.
dpkg : erreur de traitement de linux-generic (--configure) :
 problèmes de dépendances - laissé non configuré
Aucun rapport « apport » n'a été créé car le message d'erreur indique une erreur consécutive à un échec précédent.
                                                                                                                  Des erreurs ont été rencontrées pendant l'exécution :
 linux-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)


bon soit ... essayons un dpkg --configure linux-generic :
dpkg : des problèmes de dépendances empêchent la configuration de linux-generic :
 linux-generic dépend de linux-image-generic (= 3.2.0.43.51) ; cependant :
  La version de linux-image-generic sur le système est 3.2.0.48.58.
 linux-generic dépend de linux-headers-generic (= 3.2.0.43.51) ; cependant :
  La version de linux-headers-generic sur le système est 3.2.0.48.58.
dpkg : erreur de traitement de linux-generic (--configure) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 linux-generic

bref, c'est un peu la merde. l'ancien propriétaire de la bête m'as dit que le pc avait subit une coupure de courant pendant une mise à jour et que c'est depuis ce moment qu'il ne peut pllus rien installer ... bref, si vous avez des solutions, je suis preneur ;-)

note : je suis sous Ubuntu 12.04.2 LTS


Afficher la suite 

6 réponses

khrogos 49 Messages postés dimanche 24 mars 2013Date d'inscription 10 juillet 2013 Dernière intervention - 9 juil. 2013 à 09:46
+1
Utile
bon, désinstaller et réinstaller le paquet avec un upgrade entre les 2 à corriger le soucis !
Cette réponse vous a-t-elle aidé ?  
0
Utile
4
essaie d installer le linux image generic depuis la logitheque pour voir si cela ne resoud pas le problème puis tu lance apt-get update apt-get upgrade
khrogos 49 Messages postés dimanche 24 mars 2013Date d'inscription 10 juillet 2013 Dernière intervention - 3 juil. 2013 à 13:17
j'ai essayer de lancer la logithèque, elle à repéré l'erreur, m'as proposer de la réparer, j'ai lancer le truc, et ça se finit en gros fail avec pour message :
installArchives() failed: dpkg: dependency problems prevent configuration of linux-generic:
 linux-generic depends on linux-image-generic (= 3.2.0.43.51); however:
  Version of linux-image-generic on system is 3.2.0.48.58.
 linux-generic depends on linux-headers-generic (= 3.2.0.43.51); however:
  Version of linux-headers-generic on system is 3.2.0.48.58.
dpkg: error processing linux-generic (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
Errors were encountered while processing:
 linux-generic
Error in function: 
SystemError: E:Sub-process /usr/bin/dpkg returned an error code (1)
dpkg: dependency problems prevent configuration of linux-generic:
 linux-generic depends on linux-image-generic (= 3.2.0.43.51); however:
  Version of linux-image-generic on system is 3.2.0.48.58.
 linux-generic depends on linux-headers-generic (= 3.2.0.43.51); however:
  Version of linux-headers-generic on system is 3.2.0.48.58.
dpkg: error processing linux-generic (--configure):
 dependency problems - leaving unconfigured
quand tu as une mise a jour interrompu il faut taper dans un terminal :

sudo dpkg --configure -a

pour remedier et relancer essaie pour voir et dis nous si ca marche.
khrogos 49 Messages postés dimanche 24 mars 2013Date d'inscription 10 juillet 2013 Dernière intervention - 3 juil. 2013 à 21:44
je test ça demain, je vous tiens au courant !
khrogos 49 Messages postés dimanche 24 mars 2013Date d'inscription 10 juillet 2013 Dernière intervention - 4 juil. 2013 à 09:32
la commande ne change rien :-/
julien@julien-Vostro-260s:~$ sudo dpkg --configure -a 
dpkg : des problèmes de dépendances empêchent la configuration de linux-generic :
 linux-generic dépend de linux-image-generic (= 3.2.0.43.51) ; cependant :
  La version de linux-image-generic sur le système est 3.2.0.48.58.
 linux-generic dépend de linux-headers-generic (= 3.2.0.43.51) ; cependant :
  La version de linux-headers-generic sur le système est 3.2.0.48.58.
dpkg : erreur de traitement de linux-generic (--configure) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 linux-generic