CommentCaMarche
Recherche
Posez votre question Signaler

Error http 500 [Résolu]

djamel - Dernière réponse le 20 mai 2010 à 04:12
Bonjour;

J'essaye de comprendre pourquoi j'ai une erreur interne du serveur ds mon application ?
Ci-joint les traces d'apache et tomcat.

Logs d'apache :

10.171.94.4 - [25/Apr/2003:11:20:18+0200] "GET /stlweb/journal.jsp?logiciel=STL&typMsg=ERROR HTTP/1.1" 200 2721
10.171.94.4 - - [25/Apr/2003:11:20:23 +0200] "GET /stlweb/journal.jsp?logiciel=UCA2-3&typMsg=ERROR HTTP/1.1" 200 2051
10.171.94.4 - - [25/Apr/2003:11:20:28 +0200] "GET /stlweb/journal.jsp?logiciel=UCA1&typMsg=INFO HTTP/1.1" 200 59800
10.171.94.4 - - [25/Apr/2003:11:20:52 +0200] "GET /stlweb/journal.jsp?logiciel=UCA2-3&typMsg=INFO HTTP/1.1" 200 8361
10.171.94.4 - - [25/Apr/2003:11:21:45 +0200] "GET /stlweb/index.jsp HTTP/1.1" 200 44834
10.171.83.4 - - [25/Apr/2003:13:48:52 +0200] "GET /stlweb/ident.jsp?essais=0 HTTP/1.1" 500 336
10.171.83.4 - - [25/Apr/2003:13:48:58 +0200] "GET /stlweb/ HTTP/1.1" 500 336
10.180.46.95 - - [25/Apr/2003:13:56:22 +0200] "GET /default.ida?XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX%u9090%u6858%ucbd3%u7801%u9090%u6858%ucbd3%u7801%u9090%u6858%ucbd3%u7801%u9090%u9090%u8190%u00c3%u0003%u8b00%u531b%u53ff%u0078%u0000%u00=a HTTP/1.0" 404 270
10.171.83.4 - - [25/Apr/2003:15:07:56 +0200] "GET /stlweb/ident.jsp?essais=0 HTTP/1.1" 500 336
10.171.83.4 - - [25/Apr/2003:15:08:05 +0200] "GET / HTTP/1.1" 403 275
10.171.83.4 - - [25/Apr/2003:15:14:30 +0200] "GET /stlweb/index.jsp HTTP/1.1" 500 336
10.171.83.4 - - [25/Apr/2003:15:17:55 +0200] "GET /stlweb/index.jsp HTTP/1.1" 500 336
10.171.83.4 - - [25/Apr/2003:15:18:20 +0200] "GET /stlweb/index.jsp HTTP/1.1" 500 336
10.171.83.4 - - [25/Apr/2003:16:42:18 +0200] "GET /stlweb/ident.jsp?essais=0 HTTP/1.1" 500 336
10.171.94.4 - - [28/Apr/2003:08:06:08 +0200] "GET /stlweb/index.jsp HTTP/1.1" 500 336
10.171.94.4 - - [28/Apr/2003:08:06:37 +0200] "GET /stlweb/index.jsp HTTP/1.1" 500 336
10.171.83.4 - - [28/Apr/2003:09:19:39 +0200] "GET /stlweb/ident.jsp?essais=0 HTTP/1.1" 500 336
web/journal.jsp?logiciel=UCA2-3&typMsg=INFO HTTP/1.1" 200 5235
10.171.83.4 - - [24/Apr/2003:15:47:15 +0200] "GET /stlweblogs/acces_log_old

Logs tomcat :

2003-04-25 11:19:25 [org.apache.catalina.connector.warp.WarpConnection] Exception on socket
java.io.IOException: Premature packet header end
at org.apache.catalina.connector.warp.WarpConnection.recv(Unknown Source)
at org.apache.catalina.connector.warp.WarpRequestHandler.handle(Unknown Source)
at org.apache.catalina.connector.warp.WarpConnection.run(Unknown Source)
at java.lang.Thread.run(Thread.java:479)

2003-04-25 11:19:39 [org.apache.catalina.connector.warp.WarpConnection] Exception on socket
java.io.IOException: Premature packet header end
at org.apache.catalina.connector.warp.WarpConnection.recv(Unknown Source)
at org.apache.catalina.connector.warp.WarpRequestHandler.handle(Unknown Source)
at org.apache.catalina.connector.warp.WarpConnection.run(Unknown Source)
at java.lang.Thread.run(Thread.java:479)

2003-04-25 11:20:07 [org.apache.catalina.connector.warp.WarpConnection] Exception on socket
java.io.IOException: Premature packet header end
at org.apache.catalina.connector.warp.WarpConnection.recv(Unknown Source)
at org.apache.catalina.connector.warp.WarpRequestHandler.handle(Unknown Source)
at org.apache.catalina.connector.warp.WarpConnection.run(Unknown Source)
at java.lang.Thread.run(Thread.java:479)

2003-04-25 11:24:37 [org.apache.catalina.connector.warp.WarpConnection] Exception on socket
java.net.SocketException: socket closed: Bad file number
at java.net.SocketInputStream.socketRead(Native Method)
at java.net.SocketInputStream.read(SocketInputStream.java:85)
at java.net.SocketInputStream.read(SocketInputStream.java:107)
at org.apache.catalina.connector.warp.WarpConnection.recv(Unknown Source)
at org.apache.catalina.connector.warp.WarpRequestHandler.handle(Unknown Source)
at org.apache.catalina.connector.warp.WarpConnection.run(Unknown Source)
at java.lang.Thread.run(Thread.java:479)

2003-04-25 11:24:37 [org.apache.catalina.connector.warp.WarpConnection] Exception on socket
java.net.SocketException: socket closed: Bad file number
at java.net.SocketInputStream.socketRead(Native Method)
at java.net.SocketInputStream.read(SocketInputStream.java:85)
at java.net.SocketInputStream.read(SocketInputStream.java:107)
at org.apache.catalina.connector.warp.WarpConnection.recv(Unknown Source)
at org.apache.catalina.connector.warp.WarpRequestHandler.handle(Unknown Source)
at org.apache.catalina.connector.warp.WarpConnection.run(Unknown Source)
at java.lang.Thread.run(Thread.java:479)

2003-04-25 11:24:37 [org.apache.catalina.connector.warp.WarpConnector] Error accepting requests
java.net.SocketException: Socket closed
at java.net.PlainSocketImpl.socketAccept(Native Method)
at java.net.PlainSocketImpl.accept(PlainSocketImpl.java:463)
at java.net.ServerSocket.implAccept(ServerSocket.java:238)
at java.net.ServerSocket.accept(ServerSocket.java:217)
at org.apache.catalina.connector.warp.WarpConnector.run(Unknown Source)
at java.lang.Thread.run(Thread.java:479)


A+;
Lire la suite 
Réponse
+6
moins plus
IMPORTANT : Code Red ne s'attaque qu'aux machines disposant d'un serveur IIS. Il utilise une faille de ce logiciel.

Mesures préventives à mettre en œuvre immédiatement et systématiquement

Appliquer le correctif de Microsoft

1) télécharger un des patchs suivants correspondant à l'OS de la machine
2) exécuter le fichier
3) redémarrer la machine

NB : Pour WINDOWS 2000, la version minimum pour que le correctif soit pris en compte est Win 2000 SP1.
La machine est alors protégée contre les attaques de CODE RED 1 et CODE RED 2

Détection et éradication de Code Red 2

Vérifier la présence d'une "backdoor" installée par Code Red 2.
Pour cela , vérifier s'il existe un fichier caché explorer.exe sous c: et d: en exécutant les commandes DOS suivantes :
DIR /AH c:\explorer.exe
DIR /AH d:\explorer.exe
Si l'un de ces fichiers existe c'est que la machine est infectée ===> voir procédure de traitement c-après.
Nota : la machine peut être infectée même si la backdoor est absente.
Nettoyage - nouveau éradicateur
1) débrancher la machine du réseau
2) télécharger sur une autre machine le correctif suivant (valable pour tout OS) : coderedcleanup.exe et l'enregistrer sur une disquette téléchargeable ici : http://www.edu.cn/20010904/3000220.shtml
3) exécuter le fichier à partir de la disquette
4) redémarrer la machine
Pour plus de détails voir chez Microsoft à l'URL :
http://www.microsoft.com/technet/treeview/default.asp?url=/technet/security/tools/tools/redfix.asp
La machine est alors nettoyée de Code Red 2.
Par ailleurs, envoyer un mail à info.cnssi@francetelecom.com avec comme sujet "Infection Code Red 2" en précisant l'adresse IP de la machine, le type d'OS (NT ou W2000).
Analyse des logs
Vérifier les logs du serveur IIS afin de déterminer les machines attaquantes
Si présence d'une requête GET /defaut.ida suivie de nombreux NNNNNNNNNNNNNNNNNNNNNNN
envoyer un mail à info.cnssi@francetelecom.com avec comme sujet "Info Code Red 1" en précisant l'adresse IP de la machine et le type d'OS (NT ou W2000) ainsi que les logs complets.
Si présence d'une requête GET /default.ida suivie de nombreux XXXXXXXXXXXXXXXXXXXXXXX
envoyer un mail à info.cnssi@francetelecom.com avec comme sujet "Info Code Red 2" en précisant l'adresse IP de la machine, le type d'OS (NT ou W2000) ainsi que les logs complets.

MS ne supporte pas IIS 4.0 sur NT4 TSE, il ne proposera donc pas de correctif pour cette configuration.
Voici les informations reçues de MS :
La version 4.0 de IIS n'est pas supportée sur Terminal Server 4.0 comme le confirme l'article suivant :
http://support.microsoft.com/support/kb/articles/q190/1/57.asp
La version 3.0 de IIS est disponible avec Terminal Server 4.0 mais ne peut-être mise à jour et de plus ne rencontre le trou de sécurité décrit dans l'article ci-dessous :
http://www.microsoft.com/technet/treeview/default.asp?url=/technet/security/bulletin/ms01-033.asp
Les solutions supportées sont :
- une installation du serveur IIS 4.0 sur une machine NT
ou
- un downgrade du serveur IIS 4.0 vers IIS 3.0 (si les applications Web supportent ce downgrade) en conservant NT4-TSE
Une migration vers Windows 2000 permettrait de garder l'ensemble sur le même serveur ( à étudier ).
Pour information, l'article suivant décrit les fichiers modifiés par ce correctif de sécurité :
http://support.microsoft.com/support/kb/articles/q300/9/72.asp


111 111 111 x 111 111 111 = 12345678987654321
Utilisateur anonyme - 17 mai 2008 à 12:30
SALUT
JE VIENS DE LIRE CE QUE AS DIT,MOI J'AI DEPUIS PEU le meme probleme mais sous windows vista.
des que je vais sur internet et que j'ouvre une page j'en ai d'autres qui s'uovre s'en que j'ai fais quoique soit (page de pub de jeu gratuit ainsi que cette page HTTP 404 NON TROUVE) et en plus mon ordi rame maintenant ce que je n'avais pas avant (ai l'ordi depuis un an donc l'informatique et moi c'est pas le perou) je sais pas quoi faire si tu pouvais m'aider se serrais dormidable et super sympa merci d'avance
Répondre
Ajouter un commentaire
Réponse
+2
moins plus
Ajouter un commentaire
Réponse
+2
moins plus
mmmmmmmmmmmmmmmmmmmmmmmmmmajjjjjjjjjjjjjjjjjjjjjjjjjjjj
Ajouter un commentaire
Réponse
+1
moins plus
"default.ida", c'est la fameuse requête qui permet de trouver une faille dans Microsoft IIS ce qui a été utilisé pour le Virus "Code Red".

+ d'info : http://www.thesitewizard.com/news/coderediiworm.shtml
Ajouter un commentaire
Réponse
+1
moins plus
Tu fais bien de préciser.
Ajouter un commentaire
Réponse
+1
moins plus
J'utilise Apache + Tomcat

Oui effectivement j'ai essayé de planter tomcat avec le GET /default.ida => Tomcat n'a pas planter.
Mais le problème c'est que je ne pouvais plus me me connecter à mon application.
Les messages suivant s'affichent lors de tentative de connexion. WebApp: Error 500 File: pr_warp.c Line: 239) Cannot open connection warpConnection

En vous remerciant.
Ajouter un commentaire
Réponse
+1
moins plus
Salut
J'ai une erreur HTTP500 sur mon ordinateur qui ne veux plus ouvrir ma boite pro...Je n'ai rien d'un developpeur, honnêtement, je ne comprends rien à vos messages qui doivent etre, j'en suis sur, d'un grand secours pour vous autres...Je ne suis qu'un simple utilisateur qui ne comprends pas ce qui lui arrive...Je peux ouvrir ma boite email sur un autre ordinateur mais pas sur ma machine pro...ça me rends dingue...Je suis tombé par hasard sur votre forum...Pourriez vous m'aider?
A+
cris
customer 14 52Messages postés samedi 13 septembre 2008Date d'inscription 29 octobre 2011Dernière intervention - 20 mai 2010 à 04:12
Salut mon Ami ! Je ne peux t'aider car, je suis exactement comme toi ! Cela n'offre aucun plaisir, quand, des béotiens, comme nous, se retrouvent devant 1 vocabulaire d'une langue qui nous est inconnue. Je m'énerve et continue à être... "dingue".
En plus dans le dernier cas, il s'agit d'1 mail de la "Mutuelle" (+Sécurité Sociale) >http 500
<Cause mère...etc,etc, + JBossWeb/ ...etc ! >"...Oui, bien sûr...!!" Courage à nous ! Je fatigue ! @ + .
Vi
Répondre
Ajouter un commentaire
Réponse
+1
moins plus
bon moi voila le message sachant que mon aplication tourne sur d'autre machine et sur la mienne non.
mesage :



HTTP Status 500 -

--------------------------------------------------------------------------------

type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.

exception

javax.servlet.ServletException: Filter execution threw an exception
org.pentaho.core.system.SystemStatusFilter.doFilter(SystemStatusFilter.java:53)
org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)


root cause

java.lang.NoClassDefFoundError
org.pentaho.repository.runtime.RuntimeRepository.setSession(RuntimeRepository.java:75)
org.pentaho.core.system.PentahoSystem.getRuntimeRepository(PentahoSystem.java:1095)
org.pentaho.core.solution.SolutionEngineBase.execute(SolutionEngineBase.java:198)
org.pentaho.core.solution.SolutionEngineBase.execute(SolutionEngineBase.java:164)
org.pentaho.core.solution.SolutionEngine.execute(SolutionEngine.java:58)
org.pentaho.core.system.PentahoSystem.sessionStartup(PentahoSystem.java:810)
com.pentaho.security.SecurityStartupFilter.doFilter(SecurityStartupFilter.java:65)
org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
org.acegisecurity.providers.anonymous.AnonymousProcessingFilter.doFilter(AnonymousProcessingFilter.java:125)
org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
org.acegisecurity.ui.rememberme.RememberMeProcessingFilter.doFilter(RememberMeProcessingFilter.java:142)
org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
com.pentaho.security.RequestParameterAuthenticationFilter.doFilter(RequestParameterAuthenticationFilter.java:160)
org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
org.acegisecurity.ui.basicauth.BasicProcessingFilter.doFilter(BasicProcessingFilter.java:178)
org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
org.acegisecurity.ui.AbstractProcessingFilter.doFilter(AbstractProcessingFilter.java:217)
org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
org.acegisecurity.ui.logout.LogoutFilter.doFilter(LogoutFilter.java:108)
org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
com.pentaho.security.HttpSessionReuseDetectionFilter.doFilter(HttpSessionReuseDetectionFilter.java:142)
org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
org.acegisecurity.context.HttpSessionContextIntegrationFilter.doFilter(HttpSessionContextIntegrationFilter.java:193)
org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
org.acegisecurity.wrapper.SecurityContextHolderAwareRequestFilter.doFilter(SecurityContextHolderAwareRequestFilter.java:81)
org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
org.acegisecurity.util.FilterChainProxy.doFilter(FilterChainProxy.java:148)
org.acegisecurity.util.FilterToBeanProxy.doFilter(FilterToBeanProxy.java:98)
org.pentaho.core.system.SystemStatusFilter.doFilter(SystemStatusFilter.java:53)
org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)


note The full stack trace of the root cause is available in the Apache Tomcat/5.5.17 logs.


Merci
anonymous- 7 avril 2008 à 11:03
Bonjour,

Je travaille actuellement sur une solution avec Pentaho, et je me retrouve avec le même message d'erreur, sachant que, pour le moment, j'essaie uniquement de tester les examples fournis avec la plateforme.

J'aimerais bien savoir si tu as trouvé la source de cette erreur!. Sinon, si quelqu'un peut m'aider...

Merci.
Répondre
milou- 27 mai 2008 à 14:37
Bonjour,
j'ai également la même erreur avec Pentaho.
Avez-vous résolu ce problème depuis ?
Répondre
pmarcovi anonymous - 15 juil. 2008 à 12:00
Bonjour,

J'ai lu votre demande du lundi 7 avril 2008 à 11:03:01 au sujet de l'erreur "Etat HTTP 500 -" avec Pentaho (examples fournis avec la plateforme.). Auriez vous eu une solution ?
Merci d'avance pour votre réponse,

Phil
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
heuuuuu....
--> default.ida?XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX%u9090%u6858%ucbd3%u7801%u9090%u6858%ucbd3%u7801%u9090%u6858%ucbd3%u7801%u9090%u9090%u8190%u00c3%u0003%u8b00%u531b%u53ff%u0078%u0000%u00=a

T'as pas l'impression que c un peu long comme query ca ???*r*
A mon avis, ca fait +de 255 caracteres, et tu fait planter tomcat.
De plus tu verras que apache te renvoie un 404 sur cette requette, donc pas trouvé....

Essaye de passer ces valeurs par une autre méthode que par l'ecriture d'url, genre des attributs de session, un formulaire POST...

Bon courage, yann.
Ajouter un commentaire
Ce document intitulé «  error http 500  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.