Posez votre question Signaler

Problème de configuration serveur smtp wamp

stanymassart 9Messages postés samedi 3 mars 2007Date d'inscription 19 octobre 2010Dernière intervention - Dernière réponse le 19 sept. 2014 à 23:26
Bonjour à tous,
Je suis hyper-débutant en php et j'aimerais envoyer un simple email à mon adresse à partir d'un serveur local apache. Je travaille avec wampserver (wamp5, version 1.7.0)
J'ai crée une page dont le code commence de cette manière :
-------------------------------------------------------------------------------
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<?php
// Le message
$message = "Line 1\nLine 2\nLine 3";
// Dans le cas où nos lignes comportent plus de 70 caractères, nous les coupons en utilisant wordwrap()
$message = wordwrap($message, 70);
// Envoi du mail
mail('monadresse@mamessagerie.com", 'Mon Sujet', $message);
?>
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
----------------------------------------------------------------------------
C'est un morceau de code que j'ai trouvé sur internet juste pour tester mon serveur avant de m'atteler programmer cela moi-même.
La page est donc censée m'envoyer un mail lorsque je l'ouvre (rien de bien complexe) mais à l'ouverture de la page sur mon localhost, j'obtiens le messages d'erreur suivant :
-----------------------------------------------------------------------------
Warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in G:\STANY\sites-internet\newlland_tours_stan\messageSent.php on line 10
-----------------------------------------------------------------------------
la ligne 10, c'est celle-là :
mail('monadresse@mamessagerie.com', 'Mon Sujet', $message);
Comme demandé dans le message d'erreur, j'ai été voir dans mon php .ini, mais je n'y ai pas trouvé grand chose. Tout ce qui concerne le mail, c'est ceci :
---------------------------------------------------------------------------
extrait de mon php.ini
---------------------------------------------------------------------------
[mail function]
; For Win32 only.
SMTP = localhost
; For Win32 only.
sendmail_from = monautreadresse@mamessagerie.com
; For Unix only. You may supply arguments as well (default: "sendmail -t -i").
;sendmail_path =
; Force the addition of the specified parameters to be passed as extra parameters
; to the sendmail binary. These parameters will always replace the value of
; the 5th parameter to mail(), even in safe mode.
;mail.force_extra_paramaters =
-----------------------------------------------------------------------------
Voila. J'espère que quelqu'un pourra m'aider à configurer cela correctement.
Merci de votre lecture et du temps consacré aux abrutis du php... ;) faut bien commencer un jour.
Stan
Lire la suite 
Réponse
+3
moins plus
Bonsoir,
j'ai le meme problème, j'arriverai pas à configurer php.ini, moi j'utilise un serveur local "wampserver" .
j'ai introduis ma fonction dans mon code php comme suit:

$sujet='Demande satisfaite';
$destinataire=$row_envoyer['Mailinfor'];
$message ='Votre nom d\'utilisation est :'. $row_envoyer['Login'].'\n Votre mot de passe est :'.$row_envoyer['Motdepasse'].'\n Vous etes un responsable est votre matricule est le suivant:'. $row_envoyer['Matricule'].'\n les armoires associées sont:'.$_POST['mess'].'\n';
$maila=$_POST['maila'];
$headers = "MIME-Version: 1.0\r\n";
$headers .= "Content-type: text/plain; charset=iso-8859-1\r\n";
$headers .= "From: <".$maila.">\r\nReply-to :" .$row_envoyer['Nom']." <amme.fafi@yahoo.fr>\n";


if (@mail($destinataire,$sujet,$message,$headers))
echo " message envoyé";
else "une erreur s'est produite";


////////////////////////////////////////////////
et malheureusement l'erreur de else s'affichera toujours
sachant que l'application permet d'envoyer à chaque informaticien demandeur (il demande d'inscription) un e_mail en lui donnant un login et un password.
Espérant que j'ai bien expliqué mon problème,
j'attendrai vos réponses avec plaisir et merci d'avance
amme
ilhembilto- 16 mai 2009 à 09:56
bonjour amme88^
pour configurer le php.ini moi j'ai modifié que:

/////////////
[mail function]
; For Win32 only.
SMTP = smtp.gmail.com
smtp_port = 587
/////////
j'ai utilisé ça juste pour tester l'envoi des email en local
alors à toi de jouer et tu m'envoit un mail pour me dire quels sont les résultats

bonne chance
Répondre
koudji- 18 janv. 2010 à 14:51
J'ai apporté les modifications au fichier php.ini que tu as sugérées mais cela ne résoud rien, il y a toujours exactement le même problème
Répondre
Ajouter un commentaire
Réponse
+1
moins plus
pardon, j'ai cru que wamp était un serveur smtp.
en fait, il te manque simplement un serveur smtp à installer
si qqn sait nous en indiquer SANS activer IIS, je l'en remercie vivement par avance

virg
touta_touta 312Messages postés mercredi 7 août 2013Date d'inscription 9 avril 2015Dernière intervention - 19 sept. 2014 à 23:26
c'est quoi un serveur smtp?
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
Bonjour,

j'ai le mm problème sauf que je n'ai pas encore installé de serveur de mail sur mon pc car je ne savais pas lequel choisir (je suis sous vista ...), as-tu vérifié que tu avais les ports nécessaires d'ouverts (vérifier règles de sécurités, firwall, configuration connexion livebox etc...)?

as-tu trouvé ta solution depuis?
que vaut ce serveur wamp?

merci de l'info au cas où
Ajouter un commentaire
Réponse
+0
moins plus
bjr
moi aussi j'ai le meme problème que stanymassart et j'aimerais bien avoir une solution si quelqu'un veux m'aider il me repond par mail (redrose22a@yahoo.fr)

merci d'avance
be happy- 20 mars 2008 à 20:37
hi
je suis debutant en php aussi mais j ai un peu bucher la dessus pour faire un mailing list.voila ce que je peux vous dire pour l instant.
si vous ne voulez pas installer ou utiliser iis et son serveur smtp la solution la plus simple consiste a specifier le serveur smtp de votre FAI dans php.ini a la place de localhost.
je suis avec club internet donc dans mon php.ini j aai configure ... SMTP=mail.club-internet.fr
et ca marche. (sauf que pour mon mailing list je ne peux pas envoyer plus de 30 emails a la fois ca craint ....si qqun a une idee)
si vous ne savez pas quel serveur smtp avec votre FAI ---->http://www.commentcamarche.net/faq/sujet 893 serveurs pop et smtp des principaux fai
Répondre
chiro- 29 sept. 2008 à 09:05
bonjour
voila jaiconfigure php.ini sous wamp comme suit:
SMTP = smtp1.sympatico.ca
smtp_port = 25
mais la reponse est toujours:
Warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\wamp\www\Nouveau dossier\email.php on line 9

je comprend pas d'ou vient le mot "localhost" et pourtant jai redemare le service.
avez vous une idee?
merci
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
Bonjour,
Je tenais à répondre à ce sujet car j'ai trouvé la réponse après un petit quart d'heure !

Alors une fois le php.ini configuré comme il le faut, le problème vient d'ailleur.

En effet les serveurs smtp requiert une autorisation: username + password.

Personnelement j'ai contourné le problème avec le Zend framework et la classe Zend_Mail.


set_include_path(get_include_path() . PATH_SEPARATOR . "C:/wamp/www/libs/");


require_once('Zend/Mail.php');
require_once('Zend/Mail/Transport/smtp.php');
$config = array('username' => $username,
'password' => $password);

$transport = new Zend_Mail_Transport_Smtp('smtp.orange.fr', $config);

$mail = new Zend_Mail();
$mail->setBodyText('Ceci est le texte de l\'email.');
$mail->setFrom('emetteur@test.com', 'Un émetteur');
$mail->addTo('destinataire@xxxxxxx.com', 'Un destinataire');
$mail->setSubject('Sujet de test');
$mail->send($transport);

J'espère que cela sera util à quelqu'un, n'hésitez pas à poser des questions, je m'abonne a cette discussion pour y répondre.

Cordialement
sweeties- 8 févr. 2009 à 01:06
bsr,
j'ai le meme probleme de l'envoi des mails avec php
mais le probleme,c'est que je travaille pas avec un Framework
donc je me demande si vous pouvez me dire, comment integrer votre solution dans mon code php
Merci d'avance
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
ne modifier pas le php ini mais utilisé les directives php dans la config de apache
see that : http://fr2.php.net/manual/fr/ini.list.php
Ajouter un commentaire
Ce document intitulé «  problème de configuration serveur smtp wamp  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.