Posez votre question Signaler

Flash player pour firefox [Résolu]

Tieno15 125Messages postés vendredi 23 février 2007Date d'inscription 8 octobre 2012Dernière intervention - Dernière réponse le 3 juil. 2009 à 15:38
Salut,
J'ai mandriva free 2007 et mozilla firefox
plein de sites internet me disent qu'il me manque un plug-in pour les afficher correctement.
Alors ils me proposent de le trouver et ne le trouvent pas tout seul. Donc je fais manuellement et ça m'envoie sur la page de adobe flash player. Là je veux l'installer et ça me dit que je l'ai déjà. Effectivement je le retrouve bien par le centre de configuration.
Alors c'est, j'imagine, que Firefox ne sait pas comment le trouver.
Que dois je faire ?
Y at-il d'autres logiciels que je mettre à la place pour la même utilisation ?
Encore une fois, sûrement un truc très simple mais trsè compliqué pour moi qui suit novice++
Merci beaucoup de votre compréhension.
(j'ai pris un bon ordinateur justement pour pouvoir regarder des films sur Zalea TV, que je recommande à tous, et je ne peux pas !)
Etienne
Lire la suite 
Réponse
+0
moins plus
salut,

pour compléter: logiciel libre installation firefox 2 0 java flash
Tieno15 125Messages postés vendredi 23 février 2007Date d'inscription 8 octobre 2012Dernière intervention - 24 févr. 2007 à 14:40
Merci, c'est toujours pas ça.
J'ai suivi très exactement les consignes du tuto sur lequel tu m'envoies, en créant un répertoire de téléchargement et tout.
Ca marche très bien jusqu'au moment de lancer l'application, où là ça me met :
[1] 14459
[barbara-etienne@lns-bzn-23-82-248-126-55 ~]$ /usr/local/firefox/firefox-bin: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory
Et là ça bloque et il ne se passe plus rien !
Répondre
aruju 2222Messages postés dimanche 29 octobre 2006Date d'inscription ContributeurStatut 15 novembre 2014Dernière intervention - 24 févr. 2007 à 14:59
salut,

il te faut télécharger la librerie libstdc++5

en root tape:
urpmi libstdc++5
Répondre
Tieno15 125Messages postés vendredi 23 février 2007Date d'inscription 8 octobre 2012Dernière intervention - 24 févr. 2007 à 15:23
super ça marche.
Dans ma console, je peux donc l'ouvrir en tapant simplement firefox, et je sais même comment me le mettre dans le menu, maintenant.
Mais pourquoi est ce que ça m'écrit ça dans la console (mais ça n'empêche pas firefox de se lancer) ?
(firefox-bin:16084): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « ia_ora »

Bon, et puis je fais un essai sur Zalea TV : d'abord, la page est affichée très mal. Ensuite, j'ai bien accès aux vidéo, mais sans son !
Quand je reviens à ma console, il y tout ça d'écrit dessus (peut-être à cause des différents essais) :
(firefox-bin:16243): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « ia_ora »
Flash Player: Warning: environment variable G_FILENAME_ENCODING is set and is not UTF-8
Flash Player: Warning: environment variable G_FILENAME_ENCODING is set and is not UTF-8
Flash Player: Warning: environment variable G_FILENAME_ENCODING is set and is not UTF-8
Flash Player: Warning: environment variable G_FILENAME_ENCODING is set and is not UTF-8
Flash Player: Warning: environment variable G_FILENAME_ENCODING is set and is not UTF-8
Flash Player: Warning: environment variable G_FILENAME_ENCODING is set and is not UTF-8
Flash Player: Warning: environment variable G_FILENAME_ENCODING is set and is not UTF-8
Flash Player: Warning: environment variable G_FILENAME_ENCODING is set and is not UTF-8

Ca avance doucement, mais ça avance.
Merci de ta patience
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
Salut,

Tu as mozilla-firefox donc tu le trouveras sous le nom de mozilla-firefox et non pas firefox !
Puisque tu possède la Mandriva 2007 tu as probablement une version très récente donc il faut suivre les instructions de aruju (voir lien ci-dessus !
Surtout n'oublie pas de créer le lien symbolique sinon ....ça marche pô ! :-))

La manip prend quelques minutes donc il faut suivre méthodiquement la procédure et ton problème sera résolu !
Regarde ou est ton dossier mozzila-firefox chez moi (j'ai mandriva one 2007):
[zozo@localhost ~]$
whereis mozilla

mozilla: /usr/lib/mozilla
[zozo@localhost ~]$
cd /usr/lib/moz

mozilla/ mozilla-firefox-1.5.0.7/
[zozo@localhost ~]$ cd /usr/lib/mozilla

donc attention c'est mozilla-firefox que tu dois choisir !

bob
Ajouter un commentaire
Réponse
+0
moins plus
Re salut,
de plus, j'ai essayé d'installer un plugin java. Je sais pas ce que c'est mais les tutos disent d'en mettre.
Donc j'ai été chercher à le faire à partir d'un tuto trouvé sur comment ça marche : Astuces [Logiciel libre] Installation firefox 2.0+java+flash (désolé je ne sais même pas comment mettre un lien).
Il proposait d'installer ça : jre-6-linux-i586.bin
Or sur le site sur lequel il renvoie il n'y avait que des fichiers commençant par jdk et non jde;
De plus, comme j'ai un processeur athlon amd 64, j'ai préféré télécharger ça : jdk-6-linux-amd64.bin
Puis j'ai suivi le tuto en changeant ce qu'il me devait devoir changer à chaque fois (les jre par des jdk et les i586 ou i386 par des amd64.
A aucun moment ma console ne m'a engueulé, elle avait l'air de tout faire comme il faut.
Mais quand je fais about:plugins pour voir les plugins de firefox, ça ne m'affiche pas de java, j'ai toujours les deux même qu'avant :
Nom de fichier : libflashplayer.so, avec deux trucs dans le tableau, autorisés :
application/x-shockwave-flash
application/futuresplash

Et au passage ça m'affiche aussi un default plugin :
Nom de fichier : libnullplugin.so
avec rien dans le tableau et pas autorisé

Bon, j'imagine que ça c'est pas bien grave tout ça, c'est juste pour satisfaire ma curiosité.
Ajouter un commentaire
Réponse
+0
moins plus
re,

regarde ici
Tieno15 125Messages postés vendredi 23 février 2007Date d'inscription 8 octobre 2012Dernière intervention - 24 févr. 2007 à 17:50
Bon ben ça y est j'ai plein de plugins java qui s'affichent.
Merci encore.
Mais toujours pas de son sur les vidéos (et c'est pas mes enceintes parceque ça marche pour écouter un cd).
En parcourant les forums, j'ai cru comprendre que je en suis pas le seul, mais j'ai pas trouvé de solution.
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
quelle version de flashplayer utilises-tu?
Tieno15 125Messages postés vendredi 23 février 2007Date d'inscription 8 octobre 2012Dernière intervention - 24 févr. 2007 à 18:14
J'en sais trop rien, tu sais, je suis très débutant.
Quand je fais about:plugins, ça me donne ça
Nom de fichier : libflashplayer.so
Shockwave Flash 9.0 r31

et quand je vais dans le centre de configuration, je trouve ça
flash-plugin-9.0.31.0-release

Bon, c'est samedi soir et il est temps d'aller me changer les idées. Ca fait trois jours que je ne dors pas à essayer de faire marcher cet ordinateur (parce que après cette histoire de son, faut encore régler la question de l'imprimante, puis des DVD qui ne sont pas tous lu par KMplayer etc...)
Donc ce soir c'est fête, je reprend tout ça demain. Je commence à désespérer un peu.
Encore merci pour tout,
bon WE
Répondre
Tieno15 125Messages postés vendredi 23 février 2007Date d'inscription 8 octobre 2012Dernière intervention - 26 févr. 2007 à 11:47
De plus, pas de son non plus pour écouter la radio, comme France-inter.
Là ça me dit qu'il me manque un plugin, et quand je veux l'installer, ça me dit plugin inconnu (application/x-mplayer2) et ça me propose de le rechercher manuellement. Mais là ça m'envoie sur un site microsoft avec évidemment rien pour linux !
De plus, quand je veux regarder des émissions pas en direct, il me faut pouvoir lire des fichiers en .php. C'est quel logiciel pour ça ? Est ce que je l'ai normalement avec mandriva 2007 ? Sinon, où aller le chercher ?
Répondre
Tieno15 125Messages postés vendredi 23 février 2007Date d'inscription 8 octobre 2012Dernière intervention - 28 févr. 2007 à 16:17
Bon ben j'ai installé la version 7, sans désinstaller avant la version 9 que j'avais.
9a m'a demandé s'il fallait écraser un truc, et j'ai mis oui.
Et maintenant ça marche !
Quand je fais about:plugins, j'ai la version 7 qui apparait.
Mais quand je vais dans le centre de configuration et que je regarde mes programmes installés, c'est toujours la version 9 que je trouve, et rien sur la 7.
Bon, je m'en fous, le principal c'est que ça marche !
C'est peut-être pas académique mais on fait comme on peut.
Merci pour les réponses.
Je posterai de nouvelles questions pour pouvoir écouter la radio et pour un tas d'autres choses.
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
j'ai un probleme quand je met une video pour regardé il me dise d'installé le plugin et quand je cherche dans google google me dit d'installer adobe flash player que doit je faire
Ajouter un commentaire
Réponse
-1
moins plus
re ^^

Dans la precedente discussion (linux installer avg), je t'avais donné ces deux liens:
linux debuter sous linux
linux installer les programmes gestion des paquets compil

Si le premier lien donne sur des infos générales, le second t'explique comment configurer ton gestionnaire de paquetages.

Sous windows pour installer un logiciel, on doit le telecharger ou l'acheter puis on clique sur l'installateur qui va donc instaler le logiciel en question.

Sous linux c'est différent.

Au début, les logiciels n'etaient dispo que sous formes de code source (normal vuq eu linux est opensource). Résultat pour installer un logiciel il fallait le compiler ce qui n'est pas à la portée des néophytes/debutants.

Et venu ensuite une méthode un peu similaire à celle de windows ou l'on fabrique le logiciel (en somme on le compile) en l'empaquetant dans une archive (une sorte de zip si tu veux): on obtient un paquetage *.rpm ou *.deb (ou autres). Ces paquetages simplifie grandement la tache car on n'a plus de compilation et ils s'installent facilement; le programme gérant les paquetages ayant la charge de "dézipper" le contenu au bon endroit.

Or un probleme subsiste encore les dépendances.
Qu'est ce que c'est?
En fait quand on compile un programme, on le fabrique et dans la plupart des cas on utilise des briques toutes faites. Et bien ces briques consitituent ces fameuses dépendances. En effet, si on installe un paquetage (rpm, deb, ..etc) et qu'il n'y a certaines briques installées pour que le programme en question fonctionne et bien le programme de gestion des paquetages va signaler le ou les manques et ne pourra donc pas installer le paquetage.

La solution?
Une solution est de se prendre la tete en récupérant les dependances requises. Mais c'est fastidieux d'uatant plus que certaines dépendances peuvent elles meme avoir des dépendances!!!! imagine la prise de tete!! ^^
Heureusement, il existe des gestionnaires de paquetages qui peuvent récupérer des paquetages dans des depots (ftp ou http) depuis le net et installer un paquetage sans qu'on ait à se soucier des dépendances du dit paquetage: c'est pratique rapide et plus besoin de fouiller sur le net pour recupérer son paquetage. On n'a plus qu' lancer son gestionnaire de paquetage (dans ton cas, sous mandriva c'est urpmi dont l'interface graphique se trouve dans le centre de controle de mandriave rubrique gestionaire de paquetages ou une truc dans le genre), puis sélectionner le logiciel qu'on veut installer et ensuite cliquer sur installer : c'est tout!

Alors pour configurer son gestionnaire de paquetage c'est à dire pour lui donner les leins des depots, et bien regarde dans le second lien , tout y est expliqué.

Une fois configurer fais une recherche "flash" et tu trouveras une ligne "flash-mozilla" ou "flash plugin" : tu l'installe et firefox aura son plugin.
Tieno15 125Messages postés vendredi 23 février 2007Date d'inscription 8 octobre 2012Dernière intervention - 24 févr. 2007 à 12:33
merci,
alors j'ai effectivement viré mes sources de départ (les cd d'insatllation) et mis des sources trouvées sur easy urpmi, je crois, enfin le site cité dans le tuto que tu me mets en lien. Et j'ai trouvé un autre tuto qui me disait comment installer firefox et ses plug-in. Là-dedans, plein de trucs se sont bien installés et d'autres non. Déjà, le tuto parlait de firefox 2.0.0 et moi je n'avais droit qu'à une version plus ancienne.
Ah oui, parce que j'avais viré firefox dans une mauvaise manip.
Bref, maintenant firefox apparait dans mon gestionnaire de logiciels, mais pas dans ma konsole, où je ne trouve rien en tapant firefox et seulement thunderbird quand je tape mozilla.

Comment, en règle générale, connaître la commande d'un logiciel ? Il n'est nulle part dans le menuK, pas plus que ne l'était AVG, que je n'aurais jamais pu ouvrir par moi même si on ne m'avait pas donné la commande à taper.

Merci encore
Répondre
ekra 1885Messages postés vendredi 15 avril 2005Date d'inscription 24 juillet 2014Dernière intervention - 24 févr. 2007 à 20:02
Bonjour,

Je ne suis pas un expert, et loin de là, mais souvent le nom de l'exécutable ressemble au nom du paquet installé.
Après tu tapes les premieres lettres dans un terminale et tu fais le reste avec l'auto-complétion (TAB ou double-TAB).
Sinon le gestionnaire des paquets peut te renseigner sur l'emplacement des fichiers installés. Tu regardes quel est le fichier installé dans /usr/bin (ou tout en bin/, plus généralement fait un "echo $PATH" dans un terminale pour voir les chemins des executables).
Sinon, je suis d'accord avec toi, au début j'étais un peu perdu, surtout si le paquet est mal fait.

S'il existe une autre solution, je suis preneur : parole aux experts !
Répondre
Ajouter un commentaire
Ce document intitulé «  flash player pour firefox  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.