[fedora] passage qwerty azerty [Résolu/Fermé]

fm5267 5 Messages postés samedi 27 janvier 2007Date d'inscription 4 avril 2007 Dernière intervention - 27 janv. 2007 à 14:16 - Dernière réponse : darkmoule 6 Messages postés lundi 30 décembre 2013Date d'inscription 12 avril 2014 Dernière intervention
- 30 déc. 2013 à 17:05
Bonjour

J'ai installé fedora core 5 sur mon Pc avec colinux
pour faire du Windows Xp en même temps

quand je lance fedora je suis en clavier qwerty au lieu d'être en
azerty
Quelle commande faut-il passer en ligne de commande pour resoudre ce pb

Merci d'avance
Afficher la suite 
5Messages postés samedi 27 janvier 2007Date d'inscription 4 avril 2007 Dernière intervention

15 réponses

+8
Utile
6
J'ai trouve il faut modifier /etc/sysconfig/keyboard
mettre

KEYTABLE ="fr-latin1"
KEYCHARSET="iso-8859-15"
KEYBOARD="pc"

Voila j'ai trouvé la solution sur le forum...

Il est super ce forum
Cette réponse vous a-t-elle aidé ?  
Merciiiii ......;
si ça ne marche pas, ce qui a été mon cas en fedora 16, la commande suivante signalée dans d'autres threads, a marché :

setxkbmap fr

Pour que ça fonctionne à chaque redémarrage, sur un nouvel utilisateur, autre donc que l'utilisateur initial par défaut "live system user" qui est réinitialisé apparemment complètement à chaque redémarrage, il suffit de créer (ou de mettre à jour s'il existe) le fichier caché .Xkbmap et de mettre "fr" dedans (attention au . devant le X).

En effet si ce fichier est trouvé au démarrage de la session, la commande setxkbmap est exécutée avec son contenu en paramètre.
Merci la commande setxkbmap fr m'a bien rendu service
darkmoule 6 Messages postés lundi 30 décembre 2013Date d'inscription 12 avril 2014 Dernière intervention - 30 déc. 2013 à 17:05
hello :) ok, et bien pour moi ça ne fonctionne pas, ces lignes de commande ne changent rien. Et quand je fais setxkbmap fr, centos répond "Cannot open display "default display"...
piaf666 12 Messages postés mardi 20 novembre 2007Date d'inscription 13 février 2015 Dernière intervention - 8 juin 2009 à 12:08
+2
Utile
2
Pour ma part la configuration graphique passait outre et les commandes ci-dessous n'y font rien (même après redémarrage).

Aussi j'ai modifié : /etc/X11/xorg.conf

Avec quelque chose comme :

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
EndSection

notez le fr.
Redémarrer l'interface graphique (control alt backspace) ou le système.
Ouiiii c'est fait ..........;; Merci :)
C'est une excellente réponse que je valide
jipicy 43485 Messages postés jeudi 28 août 2003Date d'inscriptionModérateurStatut 7 novembre 2010 Dernière intervention - 27 janv. 2007 à 14:30
+1
Utile
2
Salut,
loadkeys /usr/lib/kbd/keymaps/i386/azerty/fr-latin1.kmap.gz
"/usr/lib/kbd/keymaps/" c'est le répertoire par défaut, après ça peut varier en fonction des distribs...

;-))
fm5267 5 Messages postés samedi 27 janvier 2007Date d'inscription 4 avril 2007 Dernière intervention - 28 janv. 2007 à 12:48
merci pour ton renseignement mais ça n'a pas marché
Je pense que la version Fédora pour colinux est un peu allégée
je vais essayer d'autres variantes

Bonne journée
jipicy 43485 Messages postés jeudi 28 août 2003Date d'inscriptionModérateurStatut 7 novembre 2010 Dernière intervention > fm5267 5 Messages postés samedi 27 janvier 2007Date d'inscription 4 avril 2007 Dernière intervention - 28 janv. 2007 à 13:31
Qu'est-ce qui n'a pas marché ?
La commande "loadkeys" n'existe pas, ou c'est le répertoire qui n'existe pas ?

Jette un oeil là à tout hasard : http://www.opennet.ru/docs/HOWTO/Francophones-HOWTO-4.html

;-)
cede 1238 Messages postés lundi 12 septembre 2005Date d'inscriptionContributeurStatut 9 décembre 2008 Dernière intervention - 27 janv. 2007 à 15:01
+1
Utile
Bonjour,

Ou bien,
Système / Administration / Clavier

A+, cede.
fm5267 5 Messages postés samedi 27 janvier 2007Date d'inscription 4 avril 2007 Dernière intervention - 28 janv. 2007 à 12:51
0
Utile
merci de ton conseil mais
hélas sans résultat non plus

Bonne journée