Signaler

Supprimer les doublons (excel 2003) [Résolu/Fermé]

Posez votre question tanchal29 88Messages postés vendredi 16 janvier 2009Date d'inscription 11 février 2014 Dernière intervention - Dernière réponse le 16 sept. 2017 à 15:26 par Icaribou
Bonsoir à tous,

Je dois réaliser un publipostage. Mais je m'aperçois que j'ai énormément de doublons.
Aussi, suis-je contrainte de les supprimer ligne/ligne, ou existe-t-il une formule qui permet d'éliminer une ligne qui apparaît deux fois?

Merci pour votre aide.

Ci-joint le type de fichiers.

http://cjoint.com/?BJkvmX5s1nG

J'utiliserai Excel 2003 au travail.

Bonne soirée.
Chantal
Utile
+22
plus moins
Il y a plus simple!

Dans l'onglet "données" sélectionner filtrer puis filtre élaboré.
Dans la case "plage" indiquer la plage avec les doublons
Dans la case "copier dans" une destination pour la plage sans doublon
cocher "extraction sans doublon"
et cliquez sur OK.

Vous aurez alors une liste sans doublons en vous évitant la fastidieuse étape de suppression des cases colorées
Sophie- 1 oct. 2013 à 12:36
Super méthode!
merci beaucoup
JMichel- 20 févr. 2014 à 20:36
Méthode super simple. Ca marche. 1000 Mercis
Icaribou- 16 sept. 2017 à 15:26
merci pour le tuyau
Répondre
Utile
+2
plus moins
Salut,

Plusieurs possibilités, entièrement automatique avec un code VBA si tu as quelques notions
ou avec une mise en forme conditionnelle qui colorise les doublons et manuellement tu sélectionnes les lignes colorisées et tu les supprimes

pour Excel 2003

commence par sélectionner la plage colonne A contenant les valeurs à tester, puis Format/Mise en forme conditionnelle/ la formule à coller est

=NB.SI(DECALER($A$1;0;0;LIGNE()-1);DECALER($A$1;LIGNE()-1;0))>0

format et tu choisis une couleur de remplissage

avec cette formule seulement les cellule de la plage en doublon se coloriseront et tu les supprimes
Utile
+0
plus moins
Merci Mike.
J'essaierai demain.
Bonne soirée.
Chantal
Utile
+0
plus moins
Re,

pourquoi as tu mis le statut en résolu alors que tu n'as pas encore testé ma proposition,
tiens nous tout de même au courant ou libère le statut
Utile
+0
plus moins
Bonjour à tous,

Juste pour vous dire que la formule de Mike est géniale!!!!!!!

Mille mercis.
A bientôt.
Chantal

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !