Posez votre question Signaler

Démarrage + ecran noir [Résolu]

DextroyMax 821Messages postés mardi 31 août 2010Date d'inscription 21 septembre 2014 Dernière intervention - Dernière réponse le 1 oct. 2012 à 19:59
Mon soucis ne dois pas être très complexe, cependant, je daigne réussir après d'infructueuses recherches.
Lorsque je démarre mon ordi, la carte mère s'affiche, l'écran violet de linux, puis, un tout petit chargement de Ubuntu avec les petits points rouge dessous. Je me retrouve finalement sur un écran noir dans lequel je peux rentrer mon login et password.
Je suis bloqué, que faire ?
Cordialement. Maxime.
Lire la suite 
Réponse
+0
moins plus
C'est ton serveur graphique qui plante, sans doute parce que le pilote graphique auquel il fait appel n'est pas (correctement) installé. Normalement ça se répare assez facilement en mode texte (l'écran sur lequel tu arrive), mais il faudrait qu'on sache quel modèle de carte vidéo tu utilises.
http://www.mistra.fr/tutoriel-linux-mode-texte.html

Une fois identifié, indique nous le résultat des commandes suivantes (attention à respecter les minuscules et majuscules), qui nous permettront de mieux cerner le problème et de t'indiquer la marche à suivre :

lspci | grep -i vga 
grep -i driver /etc/X11/xorg.conf 
grep EE /var/log/Xorg.0.log 
ls /etc/init.d/*dm


Tu peux également en profiter pour faire une mise à jour :

sudo apt-get update 
sudo apt-get upgrade


Bonne chance
DextroyMax 821Messages postés mardi 31 août 2010Date d'inscription 21 septembre 2014 Dernière intervention - 29 sept. 2012 à 12:39
Update et upgrade fait et refait.

lspci | grep -i vga : VGA compatible controler: Advanced Micro Device ( AMD) nee ATI Juniper [Radeon HD 5700 Series]

grep -I driver etc/X11/xorg.conf : aucun fichier de ce type.

grep EE /var/log/Xorg.0.log : (WW) warning (EE) error, (NI) not implemented, (??) unknow.
[ 20.608] (II) Loading extension MIT-SCREEN-SAVER

ls /etc/init.d/d*m : impossible d'accéder à /etc/init.d/d*m: Aucune fichier ou dossier de ce type.

C'est une Radeon HD 5770 avec 1go de cache.

Que dois-je faire ensuite ?

Merci d'avance pour ton aide précieuse :).
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
1) Quelques corrections à apporter dans les commandes que tu as tapé.

a) grep -I driver etc/X11/xorg.conf : aucun fichier de ce type. : Attention grep -i (i minuscule, pas majuscule) et n'oublie pas le "/" devant etc. La commande doit être retapée de manière exacte !

grep -i driver /etc/X11/xorg.conf 


b) ls /etc/init.d/d*m : impossible d'accéder à /etc/init.d/d*m: Aucune fichier ou dossier de ce type. Idem, tu as mal tapé la commande. L'étoile est devant "dm".

ls /etc/init.d/*dm


2) En tout cas vu le modèle de ta carte et ce qui est dit ici, il semble faudra utiliser catalyst (mais il existe peut-être d'autres pilotes qui peuvent faire l'affaire, genre radeon) :
http://doc.ubuntu-fr.org/liste_carte_graphique

Le problème, c'est que sur cette page il est dit que tu peux avoir des soucis avec les noyaux trop récents (>=3.5).
http://doc.ubuntu-fr.org/catalyst

On va donc vérifier ce qu'il en est. Peux-tu me reporter le résultat de :

uname -r


3) On va aussi regarder si d'autres pilotes sont installés. Reporte-moi aussi le résultat de :

dpkg -l | grep xserver-xorg-video 


(là pour le coup, c'est un L minuscule :p).

Si c'est le cas et si le fichier /etc/X11/xorg.conf existe, une idée serait de le renommer pour que tu récupères au moins le mode graphique.

En effet, xorg (le serveur graphique) va alors charger un pilote par défaut (ici je soupçonne le fichier /etc/X11/xorg.conf d'exister et de forcer le chargement d'un pilote qui ne marche pas) et avec un peu de chance qui marchera mieux. Souvent xorg charge automatiquement un pilote libre qui contrairement au pilote propriétaire se charge la plupart du temps avec succès. Malheureusement il est souvent aussi un peu moins performant.

Pour tester :

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak


Puis redémarre (ctrl alt suppr).

Bonne chance
DextroyMax 821Messages postés mardi 31 août 2010Date d'inscription 21 septembre 2014 Dernière intervention - 30 sept. 2012 à 10:59
Merci encore, je t'écrit ça sous peu.
Répondre
DextroyMax 821Messages postés mardi 31 août 2010Date d'inscription 21 septembre 2014 Dernière intervention - 30 sept. 2012 à 11:12
grep -i driver /etc/X11/xorg.conf

Option : "VendorName" "Ati proprietary driver"
Driver : " fglrx"

/etc/init.d/gdm et /etc/init.d/lightdm

3.2.0-31-generic-pae

Ensuite j'ai une mega liste pour xserver-xorg-video


Pour le sudo mv, j'obtiens : impossible d'évaluer /etc/X11/xorg.conf aucun fichier ou dossier de ce type.
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
Le fait que tu aies une mega liste pour dpkg signifie que la totalité des pilotes doivent être installés. On peut donc raisonnablement supposer que les pilotes libres alternatifs au pilote propriétaire fglrx soient présent, et prennent le relai si on empêche xorg de charger fglrx.

Si le grep a marché, pour le mv tu as forcément fait une faute de frappe (ou alors tu l'as déjà renommé ?). Tu peux regarder comment s'appellent les fichiers de ce répertoire avec la commande :

ls /etc/X11


Vu ce qui est dans /etc/init.d, le service qui sert à relancer le mode graphique s'appelle gdm. Donc pour voir si le renommage marche, en supposant que tu ne l'aies pas déjà fait :

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
sudo service gdm restart


Bonne chance
DextroyMax 821Messages postés mardi 31 août 2010Date d'inscription 21 septembre 2014 Dernière intervention - 30 sept. 2012 à 11:26
ls /etc/X11 :
app-defaults defaults-display-manager
rgb.txt xinit xorg.conf.bak.
xorg.conf.flgrx-0 xorg.conf.original-0
Xreset.d. Xsession Xsession.options
cursors fonts X en bleu Clair, xkb xorg.conf.failsafe xorg.conf.flgrx-1 Xreset Xressources Xsession.d Wwrapper.config

Y'a du bleu foncé, du vert et le X en cyan.
Répondre
DextroyMax 821Messages postés mardi 31 août 2010Date d'inscription 21 septembre 2014 Dernière intervention - 30 sept. 2012 à 11:28
Pourtant je tape bien sudo mv ( espace ) /etc/X11/xorg.conf ( espace ) /etc/X11/xorg.conf.bak
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
Ok ben là on on voir qu'il y a un xorg.conf.bak et plus de xorg.conf donc tu es arrivé à le renommer. Je pense que ce qui t'a induit en erreur c'est que lorsque la commande mv réussit, elle n'écrit rien.

Bref, le renommage est fait. Que se passe-t'il quand tu relances gdm ? Toujours un écran noir ?

Si oui, que donne :

grep EE /var/log/Xorg.0.log


Bonne chance
DextroyMax 821Messages postés mardi 31 août 2010Date d'inscription 21 septembre 2014 Dernière intervention - 30 sept. 2012 à 11:37
Toujours un ecran noir après sudo service gdm restart

grep EE /var/log/Xorg.0.log

(WW) Warning, (EE) error, ( NI ) not implemented, (??) unknow.
[. 13.061] (II) Loading extension MÎT-SCREEN-SAVER
[. 13.150] (EE) open/dev/fb0: No such file or directory
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
Pfouah pourquoi il manque /dev/fb0 :-( Ça sent le driver mal installé ça encore une fois.

Bon en gros j'ai l'impression que tu as le choix entre deux pilotes : fglrx (catalyst) et radeon (le pilote libre) :
http://doc.ubuntu-fr.org/catalyst
http://doc.ubuntu-fr.org/radeon

On va essayer d'installer le pilote libre, vu le message sur la page de catalyst je doute qu'on arrive à le faire marcher si tu un noyau récent. Tiens d'ailleurs, peux-tu m'indiquer sa version ?

uname -r


On va dégager tout ce qui concerne fglrx pour être sur qu'il n'interfère pas avec le pilote radeon :

sudo -s
dpkg -l | grep flgrx | cut -d" " -f3 > ~/paquets_fglrx.txt
apt-get update
apt-get upgrade
apt-get install aptitude
aptitude purge $(cat ~/paquets_fglrx.txt)
aptitude reinstall xserver-xorg-video-radeon
sudo dpkg-reconfigure xserver-xorg
sudo reboot


Dis-moi si ça marche mieux. Si ce n'est pas le cas reporte moi le résultat de ces commandes :

lsmod | egrep "(fglrx|ait|radeon)"
grep -i EE /var/log/xorg.0.log
grep -i loading /var/log/Xorg.0.log | grep -i driver


Bonne chance
DextroyMax 821Messages postés mardi 31 août 2010Date d'inscription 21 septembre 2014 Dernière intervention - 1 oct. 2012 à 17:12
J'ai opté pour une récupération en urgence de mon DD avec un live CD. Et une réinstallation complète.

Je pense qu'avoir installé Catalyst + le driver conçu par la communauté linux étais pas une bonne idée.

Tout remarche à présent :). Merci encore pour ton aide, j'ai pu apprendre pas mal de choses.

Et oui, c'etais bien un soucis de driver mal installé :).
Répondre
mamiemando 25784Messages postés jeudi 12 mai 2005Date d'inscription ModérateurStatut 29 août 2015 Dernière intervention - 1 oct. 2012 à 19:59
L'important c'est que ton problème soit résolu, si en plus tu as appris des choses, et bien... c'est une bonne chose :-)

Bonne continuation sous linux !
Répondre
Ajouter un commentaire
Ce document intitulé «  Démarrage + ecran noir  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.