Excel NB.SI avec plusieurs critères [Résolu/Fermé]

Kirilov 99 Messages postés dimanche 15 mars 2009Date d'inscription 25 octobre 2017 Dernière intervention - 7 sept. 2012 à 09:23 - Dernière réponse :  kakatoes
- 27 nov. 2017 à 10:28
Bonjour,

J'essaie de monter une formule NB.SI avec plusieurs critères pour des données texte et ne trouve pas de solution sur le forum (ou je n'arrive pas à les adapter à mon cas...)
J'ai d'un côté (disons colonne A) une liste avec des mots et de l'autre (disons colonne B) une série de mots-clefs
Quant je cherche à connaître le nombre d'occurrence des mots-clefs un simple NB.SI me convient tout à fait. Mais j'aimerai connaître aussi le nombre d'occurrence des mots-clefs de la colonne B en fonction de critères de la colonne A en plus du total.

Je cherche donc à écrire quelque comme : si la colonne A contient « Toto» combien la colonne B contient de « Tartempion ».

Je précise que si les cellules de la colonne A contiennent un seul terme, celles de la cellule B en contiennent plusieurs.

Merci de votre aide !



Afficher la suite 

17 réponses

tontong 2215 Messages postés mercredi 3 février 2010Date d'inscription 10 janvier 2018 Dernière intervention - 7 sept. 2012 à 09:55
+8
Utile
9
Bonjour,
Essayez avec cette formule:
=SOMMEPROD((ESTNUM(CHERCHE("Tartempion";B2:B200))*(A2:A200="Toto"))
Cette réponse vous a-t-elle aidé ?  
Raymond PENTIER 44853 Messages postés lundi 13 août 2007Date d'inscription 18 janvier 2018 Dernière intervention - 21 oct. 2014 à 21:47
Si tu n'envoies pas ton fichier, ou au moins ta formule, on ne peut pas deviner ce que tu as fait ...
Mytå 2997 Messages postés mardi 20 janvier 2009Date d'inscriptionContributeurStatut 20 décembre 2016 Dernière intervention - 21 oct. 2014 à 21:57
Salut le Forum

Pour joindre un fichier utilise http://www.cjoint.com/
et recopie le lien fourni dans ton prochain message.

Mytå
Gounsso 2 Messages postés mardi 21 octobre 2014Date d'inscription 23 octobre 2014 Dernière intervention - 23 oct. 2014 à 09:51
Bonjour,
j'ais des problème avec cjoint je n'arrive pas a copier le lien, même après avoir installer Mozilla,
tontong 2215 Messages postés mercredi 3 février 2010Date d'inscription 10 janvier 2018 Dernière intervention - 23 oct. 2014 à 11:45
Bonjour,
Sur Cjoint.com:
Parcourir >>sélectionner le fichier >> ouvrir
Créer le lien
Sélectionner le lien avec la souris Copier (Ctrl+C)
Coller
gbinforme 14549 Messages postés lundi 18 octobre 2004Date d'inscriptionContributeurStatut 17 janvier 2018 Dernière intervention - 7 sept. 2012 à 09:31
+2
Utile
1
bonjour,

Tu devrais essayer avec SOMMEPROD :

=SOMMEPROD((A:A="x")*(B:B="y"))
Kirilov 99 Messages postés dimanche 15 mars 2009Date d'inscription 25 octobre 2017 Dernière intervention - 7 sept. 2012 à 09:37
Bonjour,
Cela ne fonctionne pas... Le retour est : #NOMBRE.
+1
Utile
3
=somme(si($a$1:$a$1000="toto";si($b$1:$b$1000="tartempion";1;0);0))

a valider par CTRL+SHIFT+ENTREE (défini que c'est une formule matricielle)
Kirilov 99 Messages postés dimanche 15 mars 2009Date d'inscription 25 octobre 2017 Dernière intervention - 7 sept. 2012 à 09:39
Bonjour,
Cela ne marche pas... Retour #N/A. Mais peut-être que je dois préciser que si A contient un seul terme de recherche, B lui en contient plusieurs. Je veux dire que ce n'est pas B=tartempion mais b contient tartempion.
ben oui là ça marche plus comme ça ....

c'est long le texte en B ?
Kirilov 99 Messages postés dimanche 15 mars 2009Date d'inscription 25 octobre 2017 Dernière intervention - 7 sept. 2012 à 09:43
Je viens de faire un nbcar : c'est compris entre 0 et 200 caractères environ. Chacun des mots sont séparés par une virgule.
0
Utile
Bonjour, il existe 2 solutions à ton problème le NB.SI.ENS et la fonction SOMMEPROD. Très bons tutos ici:

http://www.tutoenboite.fr/excel-compter-le-nombre-doccurrences-dune-ou-plusieurs-valeurs-nb-si-ens

et

http://www.tutoenboite.fr/excel-compter-le-nombre-doccurrences-dune-ou-plusieurs-valeurs-sommeprod