Excel - Comment écrire un nombre en lettre [Résolu/Fermé]

wixane - 11 janv. 2007 à 21:13 - Dernière réponse :  Admirateur
- 26 avril 2011 à 05:28
bonsoir
comment écrire un nombre en lettre sous excel ? et merci
ex: 1200 euros = mille deux cents euros
Afficher la suite 

12 réponses

+151
Utile
1
il existe une fonction excel ConvNumberLetter sur le site 01net astuce a incorporer a excel avec le mode d'emploi super
Cette réponse vous a-t-elle aidé ?  
Merci d'avance.
drangius 2 Messages postés dimanche 17 février 2008Date d'inscription 17 février 2008 Dernière intervention - 17 févr. 2008 à 17:22
+49
Utile
5
1) sélectionner l'ensemble du message ci-dessous et le copier sur une feuille Excel, en A1
2) sélectionner A2:A100 et faire Edition copier / Edition collage spécial / Formules / Transposer en B1
3) masquer les colonnes C:CT
4) effacer les cellules A2:A100
5) ajuster les largeurs des colonnes A et B
Le système est prêt à fonctonner :
Entrer en A1 le nombre en chiffres, et le résultat en lettres s'inscrit automatiquement en B1 (en€uros en centimes)
Valable pour valeurs comprises entre 0 et 999999999.99 (ce qui est suffisant pour la plupart d'entre nous !)


99,85
=MAJUSCULE(STXT(A98;1;1))&STXT(A98;2;168)
=ENT(A1/1000000)
=ENT((A1-A3*1000000)/1000)
=ENT(A1-A3*1000000-A4*1000)
=ARRONDI(A1-A3*1000000-A4*1000-A5;2)*100
=A3-A12*100

=A4-A15*100
=ARRONDI(A5-A18*100;0)
=A6
=ENT(A3/100)
=ENT((A3-A12*100)/10)
=A3-A12*100-A13*10
=ENT(A4/100)
=ENT((A4-A15*100)/10)
=A4-A15*100-A16*10
=ENT(A5/100)
=ENT((A5-A18*100)/10)
=A5-A18*100-A19*10
=ENT(A6/10)
=ARRONDI(A6-A21*10;0)
=SI(A12=0;"";SI(A12=1;"";SI(A12=2;"deux ";SI(A12=3;"trois ";SI(A12=4;"quatre ";SI(A12=5;"cinq ";A42))))))
=SI(A12=0;"";SI(A12<2;"cent ";A43))
=SI(A13=1;A44;SI(A13=7;A64;SI(A13=9;A80;A89)))
=SI(A7=11;"";SI(A7=12;"";SI(A7=13;"";SI(A7=14;"";SI(A7=15;"";SI(A7=16;"";A45))))))
=SI(A3=0;"";SI(A3<2;"million ";"millions "))
=SI(A8=1;"";SI(A15=0;"";SI(A15=1;"";SI(A15=2;"deux ";SI(A15=3;"trois ";SI(A15=4;"quatre ";SI(A15=5;"cinq ";A46)))))))
=SI(A15=0;"";SI(A15<2;"cent ";A47))
=SI(A16=1;A48;SI(A16=7;A66;SI(A16=9;A81;A90)))
=SI(A4=1;"";A49)
=SI(A4>0;"mille ";"")
=SI(ENT(A1)=0;"zéro ";SI(A18=0;"";SI(A18=1;"";SI(A18=2;"deux ";SI(A18=3;"trois ";SI(A18=4;"quatre ";SI(A18=5;"cinq ";A50)))))))
=SI(A18=0;"";SI(A18<2;"cent ";A51))
=SI(A19=1;A52;SI(A19=7;A68;SI(A19=9;A83;A91)))
=SI(A10=11;"";SI(A10=12;"";SI(A10=13;"";SI(A10=14;"";SI(A10=15;"";SI(A10=16;"";A53))))))
=SI(ENT(A1<2);"€uro ";"€uros ")
=SI(A6>0;"et ";"")
=SI(A21=1;A54;SI(A21=7;A70;SI(A21=9;A84;A92)))
=SI(A11=11;"";SI(A11=12;"";SI(A11=13;"";SI(A11=14;"";SI(A11=15;"";SI(A11=16;"";A55))))))
=SI(A6=0;"";SI(A6<2;"centime";"centimes"))
=SI(A3=0;" ";SI(A12=6;"six ";SI(A12=7;"sept ";SI(A12=8;"huit ";SI(A12=9;"neuf ";)))))
=SI(A7>0;"cent "; "cents ")
=SI(A7=10;"dix ";SI(A7=11;"onze ";SI(A7=12;"douze ";SI(A7=13;"treize ";SI(A7=14;"quatorze ";SI(A7=15;"quinze ";A56))))))
=SI(A7=17;"";SI(A7=18;"";SI(A7=19;"";A57)))
=SI(A15=6;"six ";SI(A15=7;"sept ";SI(A15=8;"huit ";SI(A15=9;"neuf ";))))
=SI(A9>0;"cent "; "cents ")
=SI(A9=10;"dix ";SI(A9=11;"onze ";SI(A9=12;"douze ";SI(A9=13;"treize ";SI(A9=14;"quatorze ";SI(A9=15;"quinze ";A58))))))
=SI(A9=11;"";SI(A9=12;"";SI(A9=13;"";SI(A9=14;"";SI(A9=15;"";SI(A9=16;"";A59))))))
=SI(A18=6;"six ";SI(A18=7;"sept ";SI(A18=8;"huit ";SI(A18=9;"neuf ";))))
=SI(A10>0;"cent "; "cents ")
=SI(A10=10;"dix ";SI(A10=11;"onze ";SI(A10=12;"douze ";SI(A10=13;"treize ";SI(A10=14;"quatorze ";SI(A10=15;"quinze ";A60))))))
=SI(A10=17;"";SI(A10=18;"";SI(A10=19;"";A61)))
=SI(A11=10;"dix ";SI(A11=11;"onze ";SI(A11=12;"douze ";SI(A11=13;"treize ";SI(A11=14;"quatorze ";SI(A11=15;"quinze ";A62))))))
=SI(A11=17;"";SI(A11=18;"";SI(A11=19;"";A63)))
=SI(A7=16;"seize ";SI(A7=17;"dix-sept ";SI(A7=18;"dix-huit ";SI(A7=19;"dix-neuf ";A64))))
=SI(A7=21;"et un ";SI(A7=31;"et un ";SI(A7=41;"et un ";SI(A7=51;"et un ";SI(A7=61;"et un ";A65)))))
=SI(A9=16;"seize ";SI(A9=17;"dix-sept ";SI(A9=18;"dix-huit ";SI(A9=19;"dix-neuf ";A66))))
=SI(A9=17;"";SI(A9=18;"";SI(A9=19;"";A67)))
=SI(A10=16;"seize ";SI(A10=17;"dix-sept ";SI(A10=18;"dix-huit ";SI(A10=19;"dix-neuf ";A68))))
=SI(A10=21;"et un ";SI(A10=31;"et un ";SI(A10=41;"et un ";SI(A10=51;"et un ";SI(A10=61;"et un ";A69)))))
=SI(A11=16;"seize ";SI(A11=17;"dix-sept ";SI(A11=18;"dix-huit ";SI(A11=19;"dix-neuf ";A70))))
=SI(A11=21;"et un ";SI(A11=31;"et un ";SI(A11=41;"et un ";SI(A11=51;"et un ";SI(A11=61;"et un ";A71)))))
=SI(A7=70;"soixante-dix ";SI(A7=71;"soixante et onze ";SI(A7=72;"soixante-douze ";SI(A7=73;"soixante-treize ";SI(A7=74;"soixante-quatorze ";SI(A7=75;"soixante-quinze ";A72))))))
=SI(A13=9;"";SI(A13=7;"";SI(A14=0;"";SI(A14=1;"un ";SI(A14=2;"deux ";SI(A14=3;"trois ";SI(A14=4;"quatre ";SI(A14=5;"cinq ";A73))))))))
=SI(A9=70;"soixante-dix ";SI(A9=71;"soixante et onze ";SI(A9=72;"soixante-douze ";SI(A9=73;"soixante-treize ";SI(A9=74;"soixante-quatorze ";SI(A9=75;"soixante-quinze ";A74))))))
=SI(A9=21;"et un ";SI(A9=31;"et un ";SI(A9=41;"et un ";SI(A9=51;"et un ";SI(A9=61;"et un ";A75)))))
=SI(A10=70;"soixante-dix ";SI(A10=71;"soixante et onze ";SI(A10=72;"soixante-douze ";SI(A10=73;"soixante-treize ";SI(A10=74;"soixante-quatorze ";SI(A10=75;"soixante-quinze ";A76))))))
=SI(A19=9;"";SI(A19=7;"";SI(A20=0;"";SI(A20=1;"un ";SI(A20=2;"deux ";SI(A20=3;"trois ";SI(A20=4;"quatre ";SI(A20=5;"cinq ";A77))))))))
=SI(A11=70;"soixante-dix ";SI(A11=71;"soixante et onze ";SI(A11=72;"soixante-douze ";SI(A11=73;"soixante-treize ";SI(A11=74;"soixante-quatorze ";SI(A11=75;"soixante-quinze ";A78))))))
=SI(A21=9;"";SI(A21=7;"";SI(A22=0;"";SI(A22=1;"un ";SI(A22=2;"deux ";SI(A22=3;"trois ";SI(A22=4;"quatre ";SI(A22=5;"cinq ";A79))))))))
=SI(A7=76;"soixante-seize ";SI(A7=77;"soixante-dix-sept ";SI(A7=78;"soixante-dix-huit ";SI(A7=79;"soixante-dix-neuf ";A80))))
=SI(A13=9;"";SI(A14=6;"six ";SI(A14=7;"sept ";SI(A14=8;"huit ";SI(A14=9;"neuf ";)))))
=SI(A9=76;"soixante-seize ";SI(A9=77;"soixante-dix-sept ";SI(A9=78;"soixante-dix-huit ";SI(A9=79;"soixante-dix-neuf ";A81))))
=SI(A16=9;"";SI(A16=7;"";SI(A17=0;"";SI(A17=1;"un ";SI(A17=2;"deux ";SI(A17=3;"trois ";SI(A17=4;"quatre ";SI(A17=5;"cinq ";A82))))))))
=SI(A10=76;"soixante-seize ";SI(A10=77;"soixante-dix-sept ";SI(A10=78;"soixante-dix-huit ";SI(A10=79;"soixante-dix-neuf ";A83))))
=SI(A19=9;"";SI(A20=6;"six ";SI(A20=7;"sept ";SI(A20=8;"huit ";SI(A20=9;"neuf ";)))))
=SI(A11=76;"soixante-seize ";SI(A11=77;"soixante-dix-sept ";SI(A11=78;"soixante-dix-huit ";SI(A11=79;"soixante-dix-neuf ";A84))))
=SI(A21=9;"";SI(A22=6;"six ";SI(A22=7;"sept ";SI(A22=8;"huit ";SI(A22=9;"neuf ";)))))
=SI(A7=90;"quatre-vingt-dix ";SI(A7=91;"quatre-vingt-onze ";SI(A7=92;"quatre-vingt-douze ";SI(A7=93;"quatre-vingt-treize ";SI(A7=94;"quatre-vingt-quatorze ";SI(A7=95;"quatre-vingt-quinze ";A85))))))
=SI(A9=90;"quatre-vingt-dix ";SI(A9=91;"quatre-vingt-onze ";SI(A9=92;"quatre-vingt-douze ";SI(A9=93;"quatre-vingt-treize ";SI(A9=94;"quatre-vingt-quatorze ";SI(A9=95;"quatre-vingt-quinze ";A86))))))
=SI(A16=9;"";SI(A17=6;"six ";SI(A17=7;"sept ";SI(A17=8;"huit ";SI(A17=9;"neuf ";)))))
=SI(A10=90;"quatre-vingt-dix ";SI(A10=91;"quatre-vingt-onze ";SI(A10=92;"quatre-vingt-douze ";SI(A10=93;"quatre-vingt-treize ";SI(A10=94;"quatre-vingt-quatorze ";SI(A10=95;"quatre-vingt-quinze ";A87))))))
=SI(A11=90;"quatre-vingt-dix ";SI(A11=91;"quatre-vingt-onze ";SI(A11=92;"quatre-vingt-douze ";SI(A11=93;"quatre-vingt-treize ";SI(A11=94;"quatre-vingt-quatorze ";SI(A11=95;"quatre-vingt-quinze ";A88))))))
=SI(A7=96;"quatre-vingt-seize ";SI(A7=97;"quatre-vingt-dix-sept ";SI(A7=98;"quatre-vingt-dix-huit ";SI(A7=99;"quatre-vingt-dix-neuf ";A89))))
=SI(A9=96;"quatre-vingt-seize ";SI(A9=97;"quatre-vingt-dix-sept ";SI(A9=98;"quatre-vingt-dix-huit ";SI(A9=99;"quatre-vingt-dix-neuf ";A90))))
=SI(A10=96;"quatre-vingt-seize ";SI(A10=97;"quatre-vingt-dix-sept ";SI(A10=98;"quatre-vingt-dix-huit ";SI(A10=99;"quatre-vingt-dix-neuf ";A91))))
=SI(A11=96;"quatre-vingt-seize ";SI(A11=97;"quatre-vingt-dix-sept ";SI(A11=98;"quatre-vingt-dix-huit ";SI(A11=99;"quatre-vingt-dix-neuf ";A92))))
=SI(A13=2;"vingt ";SI(A13=3;"trente ";SI(A13=4;"quarante ";SI(A13=5;"cinquante ";A93))))
=SI(A16=2;"vingt ";SI(A16=3;"trente ";SI(A16=4;"quarante ";SI(A16=5;"cinquante ";A94))))
=SI(A19=2;"vingt ";SI(A19=3;"trente ";SI(A19=4;"quarante ";SI(A19=5;"cinquante ";A95))))
=SI(A21=2;"vingt ";SI(A21=3;"trente ";SI(A21=4;"quarante ";SI(A21=5;"cinquante ";A96))))
=SI(A13=6;"soixante ";SI(A7=80;"quatre-vingts ";SI(A13=8;"quatre-vingt-";"")))
=SI(A16=6;"soixante ";SI(A9=80;"quatre-vingts ";SI(A16=8;"quatre-vingt-";"")))
=SI(A19=6;"soixante ";SI(A10=80;"quatre-vingts ";SI(A19=8;"quatre-vingt-";"")))
=SI(A21=6;"soixante ";SI(A11=80;"quatre-vingts ";SI(A21=8;"quatre-vingt-";"")))

=(A23&A24&A25&A26&A27&A28&A29&A30&A31&A32&A33&A34&A35&A36&A37&A38&A39&A40&A41)
nashate 7 Messages postés mardi 27 juillet 2010Date d'inscription 20 octobre 2016 Dernière intervention - 12 nov. 2010 à 12:26
merci bcp
Merci beaucoup Drangius, ta formule est super !
JE doit dire BRAVO! sa fais un bon moment que je me rend fou avec la macro convnumberletter et je me faisais chier avec le mot "virgule" que je substitué par euros mais c'était le bordel .ta formule est génial alors vraiment bravo!!! c grâce a des mecs comme toi qu'on avance. merci mec
Serge patrick.

Merci pour le coup de pousse et félicitation
Merci bc Drangius, la formule est plus que fantastique. Merci pour votre aide précieuse. Avec mes sentiments d'affectueuse reconnaissance./.
+12
Utile
Tu télécharges MOREFUNC, disponible gratuitement sur "Télécharger. com". Ce sont des macros complémentaires qui vont s'intégrer dans excel. Tu trouveras ensuite, parmi les nouvelles fonctions installées, une fonction nommée NBTEXTE. C'est tout.
+11
Utile
Bonjour,

Comment traduire en lettres le chiffre suivant :

16897846997545688963347858637537

La macro Excel "ConvNumberLetter" s'arrête au volume de 15 chiffres (celui-ci en compte 32).

En vous remerciant par avance.

Cdt.
+10
Utile
Bonjour,
en reponse a votre question (Existe-t-il une variable dans Excel permettant de selectionner les nombres et les basculer en chiffre)
ca existe une solution c'est la convertion des colonnes tu le trouve dans le menu donnees /convertir et ca apres avoir selectionner la colonne en formats texte. j'espere que c une bonne solution
+7
Utile
Bonjour,

J'importe des fichiers en mode txt incluant des chiffres que Excel ne reconnait pas en tant que tel ==> il est impossible d'effectuer des calculs tel que somme.
Existe-t-il une variable dans Excel permettant de selectionner les nombres et les basculer en chiffre.

Merci