Menu

Formule Excel si cellule contient un texte [Résolu/Fermé]

caba_44 92 Messages postés lundi 14 décembre 2009Date d'inscription 24 novembre 2016 Dernière intervention - 10 mai 2012 à 12:11 - Dernière réponse :  rouflous
- 29 nov. 2017 à 11:36
Bonjour à tous,

J'ai un léger soucis que je souhaiterais pouvoir faciliter par une formule.
Si ma cellule A1 contient le texte "NBR" alors écrire NBR en cellule B1
Sachant que la cellule A1 = O'Ring NBR 70 Shore A.

Comment faire ?

En attendant de vous lire,

Mathieu



Afficher la suite 

40 réponses

Vaucluse 21344 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 22 février 2018 Dernière intervention - 10 mai 2012 à 12:27
+216
Utile
16
Bonjour
en B1
=SI(NB.SI(A1;"*NBR*");"NBR";"")
attention aux signes
crdlmnt
Cette réponse vous a-t-elle aidé ?  
+10
Utile
Bonjour,
Je viens de lire les différentes informations et j'aurai besoin d'un renseignement,
Comment dois je m'y prendre pour dire : Si le mot de la colonne A2 et dans le texte de la colonne A1 alors c'est ok sinon rien. SVP merci.
PHILOU10120 4854 Messages postés lundi 16 avril 2012Date d'inscription 21 février 2018 Dernière intervention - 10 mai 2012 à 13:07
+2
Utile
une idée

=DROITE(SUPPRESPACE(GAUCHE($A$1;CHERCHE(CONCATENER(CAR(78);CAR(66);CAR(82));$A$1;1)+NBCAR($A$2)));NBCAR(A2))

ou CAR(78) = N
CAR(66) = B
CAR(82) = R
NBCAR(A2) = le nombre de caratère rechercher
cherche(CONCATENER(assemble les trois caratéres et donne la position de départ)
SUPPRESPACE enléve les espaces inutiles
Gauche prend un nombre de caratéres à partir de la gauche, ce nombre est défini par la fonction chercher dans A1
Droite prend un nombre de caractéres à partir de la droite défini par NBCAR A2
caba_44 92 Messages postés lundi 14 décembre 2009Date d'inscription 24 novembre 2016 Dernière intervention - 10 mai 2012 à 14:24
+2
Utile
Super ca fonctionne...

Je vous remercie pour votre retour

A très bientôt :)

Mathieu
brunettito - 8 mars 2014 à 17:50
+1
Utile
2
Salut Amaury,

=SI(NB.SI(A1;"*dimanche*");A2*1,2;"")

Voila
bonjour,
j'ai le même soucis, sauf que mon "samedi" vient d'une case qui comprend une formule qui permet d'afficher "samedi"

Case 1 = 13-12-2014 (sur feuil2)
Case 2 = =SI(Feuil2!A5="";"";Feuil2!A5) affichage de la cellule en [$-80C]jjjj
Case 3 = =SI(NB.SI(A15;"*samedi*");"40";"30")

Un grand merci si vous savez répondre.
Bonjour, tu as essayé de copier/coller ta cellule "samedi" en valeur ?
+1
Utile
3
Tu devrais pouvoir trouver ce que tu cherchers la :
http://www.yvoz.net/2010/09/excel-tester-chaine-caracteres-contient/
J'ai un soucis pour la première formule j'aimerais récupérer le *NBR* a partir de l'extraction d'une chaîne.
exple : je parcourir une liste d'element dans la colonne A, et trouver le nombre de fois qu'elle les elements de la colonne b. e
ssss pour compléter ma question
+NB.SI($H$12:$H$38;"*7*"),
la formule ci dessus pourrait répondre à mon besoin , mais "*7*" doit etre une variable qui est récupérer
dans une cellule.
Juste pour avoir un lien qui fonctionne
http://www.yvoz.net/2010/09/excel-tester-chaine-caracteres-contient/
0
Utile
1
Bonjour,

Dans la même lignée, comment faire :

Si cellule A1 contient "Dimanche" alors calculer "A2*1,2"

Ceci ne marche pas:
=SI(NB.SI(A1;"*dimanche*");"=A2*1,2";"")


Merci d'avance
=SI(NB.SI(A1;"*dimanche*");A2*1,2;"")
0
Utile
4
Bonjour,

Et si je veux que quand ma colonne A1 affiche FRANCE, ma colonne A2 mette FR, si elle n'affiche pas France, A2 affiche INT et si elle est vide, A2 reste vide?

Merci beaucoup
Bonjour Roxane,

Je pense que la réponse à ta question c'est les condition imbriquée comme précisait Ricky38.
=Si(A1="FRANCE";"FR";si(A1="";"";si(A1<>"FRANCE";"INT";)))

Quant à moi ma question serait :

Je veux faire : SI A1 = "TXT" ALORS A2 SINON 0
Et le TXT serait une case dans laquelle se trouve une liste déroulante. Est ce possible?

Merci par avance!
Réponse à ma propre question:
=SI(A1=K1;A2;0)
j'avais juste fait l'erreur d'écrire
=SI(A1="K1";A2;0)
Bonjour,

Je cherche une formule imbriquée qui me permette de saisir automatiquement l'adresse mail en me basant sur le prénom et nom des destinataires...

Si vs m'avais compris merci de m'aider :-)

Cordialement,
Salut tout le monde,
j'ai un problème aussi sur Excel c'est que il faut que je parcours chaque colone et vérifier si le contenu de chaque celulle contient des caractères spéciaux si oui, il le remplace par des caractères normaux. aidez moi svp
francesco - 26 mai 2014 à 08:41
0
Utile
Salut,

J'ai un problème, je souhaiterais quand j'ai 2 mots dans une cellule diviser le cout associé en 2.

Par exemple, j'ai BE + LIO pour un cout de 500 comment je peux faire pour avoir en A1 BE avec en A2 250 et en B1 LIO avec en B2 250
-1
Utile
Bonjour,

Je recherche une formule qui me permette de compter le nombre de case contenant une info exemple

SS AQ 010
SS AQ 011
SS AS 009
SS AT 003
SS AU 002
SS AU 008

La formule me permettrai de déterminer qu'il y'a 2 cellule contenant les lettre AQ, 1 cellule contenant les lettres AS etc

en espérant avoir bien exposé ma demande
Delaharpe6 - 22 oct. 2014 à 10:49
-1
Utile
Imaginons :
A1 SS AQ 010
A2 SS AQ 011
A3 SS AS 009
A4 SS AT 003
A5 SS AU 002
A6 SS AU 008


=COUNTIF(A1:A6;"*AQ*") 2 cellulles contiennent AQ

Utiliser "* TEXT*" signifie que je ne cherche pas un text exact mais bien dès que AQ apparait
-1
Utile
Bonjour,

J'aurai besoin d'une petite aide
J'aimerai afficher un 1 en I9 si en H9 j'ai ¨NP ou C ou E

J'arrive a avoir un 1 si j'ai NP mais je n'arrive pas a effectuer la fonction ou

=IF(COUNTIF(H9;ʺ*NP*ʺ);ʺ1ʺ;
admi.tools 17 Messages postés mardi 11 décembre 2007Date d'inscription 30 octobre 2016 Dernière intervention - Modifié par admi.tools le 30/10/2016 à 23:31
-1
Utile
1
bonjour
merci bien Vaucluse c'est resolu pour moi
ah merci j'ai enfin trouvé la réponse que je cherchais depuis 2 jours
Merci