Signaler

Quota et samba [Fermé]

Posez votre question Reman - Dernière réponse le 25 oct. 2006 à 16:25 par Reman
Bonjour,

J'ai un souci avec la gestion des quotas et samba lors de l'enregistrement d'un profil windows (xp) sur le serveur.

Cela fonctionne lorsque les quotas sont illimités ( 0 en soft et en hard limit)

Dès que je precise un quota, le profil ne s'enregistre plus :(.
Windows me renvoie une erreur 'Espace insuffisant sur le disque'

Le profil ne s'enregistre plus dans tous les cas !Que la taille des fichiers utilisateur soient inférieurs à la soft limit ou compris entre la soft et la hard limit.

Par contre, en local sous linux cela fonctionne parfaitement. Quand je crée un fichier en dépassement soft, j'ai un warning, et quand je dépasse la hard limit, impossible d'écrire.

Voilà, j'espère que vous avez déjà eu ce cas car je ne sais plus quoi faire. :(

Merci d'avance.
Utile
+0
plus moins
Salut,

As tu activé les ACL et la gestion des quotas lors du montage du système de fichier (j'imagine le point de montage /home), ca se voit dans /etc/fstab , les options de mount ...


Dans ton smb.conf, quelle est la valeur de :

inherit acls ? (pour le partage concerné)

forceunknownacluser ?

Enfin est ce que les ACL sont activés ds le noyau (certaines distrib de base l'ont) et as tu installé le paquet "quota" (je préfere poser la question mais je me doute que oui ...) ?

a+

Utile
+0
plus moins
Salut et merci de t'attarder sur mon problème.

Alors voilà, les quotas sont bien défini dans fstab, mais pas la gestion des acl

extrait du fstab :
/dev/cciss/c0d0p6 /data/profiles ext3 defaults,usrquota 1 2
/dev/cciss/c0d0p7 /data/partages ext3 defaults,grpquota 1 2


la 1ere partition devrait pemettre la gestion des quotas uniquement pour les profiles utilisateurs.
le 2eme permettra la gestion des repertoires partagés des différents groupes

le rpm quota est installé, mais concernant les ACLs j'ai rien du tout, ni dans la smb.conf ni dans le noyau.

En fait je savais pas qu'il fallait utilisé les ACLs.
Pourquoi faut il utilisé les ACLs dans le smb.conf ? je suis preneur pour toute explications.

Merci :) @+
Utile
+0
plus moins
Salut,

Essayes d'activer les ACLS ds ton fstab pour les pts de montage concernés, rajoute comme ceci ds /etc/fstab

/dev/cciss/c0d0p6 /data/profiles ext3 defaults,usrquota,acl 1 2

dans smb.conf

[global]
forceunknownacluser = yes

[profiles]
...
inherit acls = Yes


Remonte les pts de montage et relance les services de samba.


C'est tout ce que j'ai à te proposer ...

Ba Windows vient gérer son profil avec des droits particuliers, ainsi que les quotas sont gérés avec des droits particuliers. il faut pouvoir transcrire les droits de chaque coté (client et serveur) avec le même langage, à savoir les ACL's.

J'avais mis le nez dans une config assez similaire, et l'utilisation des ACL's était indispensable.

a+
Utile
+0
plus moins
Re,

Je te remercie de ton aide, je teste tout ca et je reviens

@+

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !