CommentCaMarche
Recherche
Posez votre question Signaler

Excel : multiplication de 2 colonnes [Résolu]

valtec - Dernière réponse le 6 janv. 2012 à 10:58
Bonjour,
En colonne A j'ai mon débit
En colonne B j'ai mon crédit
En colonne C j'ai mon taux de tva
J'aimerais trouver une formule qui me permette de faire :
A ou B * C = D (montant tva)
C'est le "ou" qui me pose problème...
Après il ne me reste qu'à faire A ou B + D = E (montant ttc)
Merci
Lire la suite 
Réponse
+3
moins plus
Bonjour,

logiquement, sur la même ligne, vous aurez soit A, soit B de rempli. Dans ce cas, il vous faut écrire en D :

=SI(ESTVIDE(Ax);Bx*Cx;Ax*Cx)

Remplacer x par le numéro de ligne.

Cordialement.
Ajouter un commentaire
Réponse
+1
moins plus
Bonjour,

Si c'est du débit/crédit je suppose que c'est A et que B est vide ou B et que à est vide.
Si oui c'est simple
=A*C + B*C

A ou B étant vide l'un des deux membres sera égal à 0.

Si non il faut plus d'info sur la condition du "ou".
Ajouter un commentaire
Réponse
+0
moins plus
Merci Chossette, ca a l'air de marcher, le seul problème c'est que A est négatif (j'ai donc précisé Format de cellule > Personnalisé > -0,00)

Mais lorsque A (débit) est rempli et que B (crédit) est vide (effectivement il est impossible que A et B soient remplis en même temps), le résultat de l'opération est positif, ce qui ne va pas puisque ça devrait être une tva qui s'ajoute au débit...
Ajouter un commentaire
Réponse
+0
moins plus
Bonjour
b^tement:
=(A1+B1)*C1

mais à mon avis il faudrait tenir compte de la TVA collectée ou déductible ou 2 colonnes crédit TTC et Débit TTC
Michel
Ajouter un commentaire
Réponse
+0
moins plus
Merci Tyrael, cette seconde formule marche aussi, mais le problème du négatif reste le même. D'ailleurs le total lui aussi ne prend pas en compte mon format personnalisé de cellule. Je suppose donc que c'est ça qui pose problème...
Ajouter un commentaire
Réponse
+0
moins plus
Bonjour Michel, je pars du principe que le résultat positif de la tva est "collectée", celui négatif est "déductible". Ca devrait marcher non ?
Ajouter un commentaire
Réponse
+0
moins plus
Je ne suis pas spécialiste mais il me semble que le Format de cellule "-0.00" ne sert que d'affichage.
Si tu tape 3 dans cette colonne tu as effectivement -3,00 mais à l'affichage si tu regarde la donnée elle est toujours à 3 donc la formule prendre le 3 et le pas le -3.

Je ne sais trop comment faire pas contre là désolé.
Ajouter un commentaire
Réponse
+0
moins plus
Oui Tyrael, c'est effectivement ca...
Ajouter un commentaire
Réponse
+0
moins plus
Bonjour,

et bien tu fais (A-B)*C
ou (B-A)*C selon où est ton négatif

Et pourquoi utiliser le format d'affichage pour le - plutôt que de taper la vraie valeur -xxx.xx ?

eric
Ajouter un commentaire
Réponse
+0
moins plus
=SI(A1>0;1;-1)*(A1+B1)*C1
ou l'inverse !
mais je vois que ma réponse ne t'as pas intéressé, donc...
chossette9 4432Messages postés lundi 20 avril 2009Date d'inscription ContributeurStatut 12 septembre 2014Dernière intervention - 6 janv. 2012 à 10:47
Bonjour,

il est possible de remplacer le SI(A1>0;1;-1) par SIGNE(A1) qui renvoie 1 quand A1 est positif, -1 quand A1 est négatif.

Cordialement.
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
Michel, je répondais plus haut à ta réponse pour laquelle je te remercie. En revanche je ne saisis pas bien la seconde proposition...

Eric, l'idéal pour moi serait que l'ensemble de la colonne A soit en négatif car il s'agit de Débit, ça m'éviterait donc de taper - à chaque fois

Le problème c'est que Format de cellule > Personnalisé > -0,00 ne change que l'affichage, pas la valeur (qui reste positive et donc le résultat aussi)
Ajouter un commentaire
Réponse
+0
moins plus
La réponse d'eriiic fonctionne.

=(B1-A1)*C1
valtec- 6 janv. 2012 à 10:58
Effectivement !
Encore merci à vous tous !
Répondre
Ajouter un commentaire
Ce document intitulé «  Excel : multiplication de 2 colonnes  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.