Excel : multiplication de 2 colonnes [Résolu/Fermé]

valtec - 6 janv. 2012 à 10:10 - Dernière réponse :  valtec
- 6 janv. 2012 à 10:58
Bonjour,

En colonne A j'ai mon débit
En colonne B j'ai mon crédit
En colonne C j'ai mon taux de tva

J'aimerais trouver une formule qui me permette de faire :
A ou B * C = D (montant tva)

C'est le "ou" qui me pose problème...

Après il ne me reste qu'à faire A ou B + D = E (montant ttc)

Merci
Afficher la suite 

14 réponses

0
Utile
Merci Chossette, ca a l'air de marcher, le seul problème c'est que A est négatif (j'ai donc précisé Format de cellule > Personnalisé > -0,00)

Mais lorsque A (débit) est rempli et que B (crédit) est vide (effectivement il est impossible que A et B soient remplis en même temps), le résultat de l'opération est positif, ce qui ne va pas puisque ça devrait être une tva qui s'ajoute au débit...
michel_m 14942 Messages postés lundi 12 septembre 2005Date d'inscriptionContributeurStatut 14 décembre 2017 Dernière intervention - 6 janv. 2012 à 10:24
0
Utile
Bonjour
b^tement:
=(A1+B1)*C1

mais à mon avis il faudrait tenir compte de la TVA collectée ou déductible ou 2 colonnes crédit TTC et Débit TTC
Michel
0
Utile
Merci Tyrael, cette seconde formule marche aussi, mais le problème du négatif reste le même. D'ailleurs le total lui aussi ne prend pas en compte mon format personnalisé de cellule. Je suppose donc que c'est ça qui pose problème...
0
Utile
Bonjour Michel, je pars du principe que le résultat positif de la tva est "collectée", celui négatif est "déductible". Ca devrait marcher non ?
-Tyrael- 101 Messages postés jeudi 10 septembre 2009Date d'inscription 14 août 2015 Dernière intervention - 6 janv. 2012 à 10:29
0
Utile
Je ne suis pas spécialiste mais il me semble que le Format de cellule "-0.00" ne sert que d'affichage.
Si tu tape 3 dans cette colonne tu as effectivement -3,00 mais à l'affichage si tu regarde la donnée elle est toujours à 3 donc la formule prendre le 3 et le pas le -3.

Je ne sais trop comment faire pas contre là désolé.
0
Utile
Oui Tyrael, c'est effectivement ca...
eriiic 21190 Messages postés mardi 11 septembre 2007Date d'inscriptionContributeurStatut 14 décembre 2017 Dernière intervention - Modifié par eriiic le 6/01/2012 à 10:34
0
Utile
Bonjour,

et bien tu fais (A-B)*C
ou (B-A)*C selon où est ton négatif

Et pourquoi utiliser le format d'affichage pour le - plutôt que de taper la vraie valeur -xxx.xx ?

eric
michel_m 14942 Messages postés lundi 12 septembre 2005Date d'inscriptionContributeurStatut 14 décembre 2017 Dernière intervention - 6 janv. 2012 à 10:34
0
Utile
1
=SI(A1>0;1;-1)*(A1+B1)*C1
ou l'inverse !
mais je vois que ma réponse ne t'as pas intéressé, donc...
chossette9 4429 Messages postés lundi 20 avril 2009Date d'inscriptionContributeurStatut 12 septembre 2014 Dernière intervention - 6 janv. 2012 à 10:47
Bonjour,

il est possible de remplacer le SI(A1>0;1;-1) par SIGNE(A1) qui renvoie 1 quand A1 est positif, -1 quand A1 est négatif.

Cordialement.
0
Utile
Michel, je répondais plus haut à ta réponse pour laquelle je te remercie. En revanche je ne saisis pas bien la seconde proposition...

Eric, l'idéal pour moi serait que l'ensemble de la colonne A soit en négatif car il s'agit de Débit, ça m'éviterait donc de taper - à chaque fois

Le problème c'est que Format de cellule > Personnalisé > -0,00 ne change que l'affichage, pas la valeur (qui reste positive et donc le résultat aussi)
-Tyrael- 101 Messages postés jeudi 10 septembre 2009Date d'inscription 14 août 2015 Dernière intervention - 6 janv. 2012 à 10:51
0
Utile
1
La réponse d'eriiic fonctionne.

=(B1-A1)*C1
Effectivement !
Encore merci à vous tous !
chossette9 4429 Messages postés lundi 20 avril 2009Date d'inscriptionContributeurStatut 12 septembre 2014 Dernière intervention - 6 janv. 2012 à 10:12
-1
Utile
Bonjour,

logiquement, sur la même ligne, vous aurez soit A, soit B de rempli. Dans ce cas, il vous faut écrire en D :

=SI(ESTVIDE(Ax);Bx*Cx;Ax*Cx)

Remplacer x par le numéro de ligne.

Cordialement.
-Tyrael- 101 Messages postés jeudi 10 septembre 2009Date d'inscription 14 août 2015 Dernière intervention - 6 janv. 2012 à 10:15
-1
Utile
Bonjour,

Si c'est du débit/crédit je suppose que c'est A et que B est vide ou B et que à est vide.
Si oui c'est simple
=A*C + B*C

A ou B étant vide l'un des deux membres sera égal à 0.

Si non il faut plus d'info sur la condition du "ou".