CommentCaMarche
Recherche
Posez votre question Signaler

[ubuntu 11.10] plus de mode graphique [Résolu]

hmid30 146Messages postés mardi 29 janvier 2008Date d'inscription 16 mai 2014Dernière intervention - Dernière réponse le 25 oct. 2011 à 09:45
Bonjour,
je viens de faire la mise à niveau vers ubuntu 11.10, je suis en dual boot avec seven.
AU démarrage du Grub, lorsque je sélectionne linux 3.0 impossible de démarrer avec l'interface graphique, j'ai un terminal qui s'affiche...
J'ai plusieurs choix de kernel (linux 2....) qui ne fonctionnent pas...
Je ne sais pas quoi faire et je ne peux plus me servir d'ubuntu...
Merci de votre aide.
J'ai un pc portable dell xps Dual core 2,2 GHZ, geforce 8600GT avec 3g de Ram.
Lire la suite 
Réponse
+2
moins plus
Oui il faut te câbler en ethernet car tant que tu n'as pas lancé ta session graphique, la connexion wifi n'est pas établie (a priori tu l'as configurée via network-manager qui n'est lui même lancé que quand ta session graphique est lancée).

En fait je crois que je viens de comprendre ce qui s'est passé. En ubuntu11.10, le bureau par défaut est devenu unity qui requiert la 3D. Pour peu que ton PC ne supporte pas la 3D gnome marchait jusque là. Mais depuis, plus de gnome, c'est unity.

Ça expliquerait pourquoi ça plante après la connexion. En effet, tant que tu n'es pas connecté, unity n'est pas lancé et donc le mode graphique n'a pas encore planté. C'était donc stupide de ma part de soupçonner xorg.conf, car si c'était lui tu n'aurais même pas eu al fenêtre graphique pour te connecter.

En général quand tu lances un bureau (gnome, kde, unity...) celui plante au lancement s'il n'y a plus de place et c'est pour ça que j'avais d'abord soupçonné ça.

Je te propose donc pour résoudre ton problème :
1) de te brancher en ethernet
2) de lancer ton PC
3) de t'identifier en mode texte
4) d'installer gnome.

Concrètement voici les commandes dont tu auras besoin. Si ta carte ethernet s'appelle eth0 et que tu n'as pas de réseau en mode texte lance :

sudo dhclient eth0


Je te rappelle que tu peux voir les différentes interfaces réseau avec la commande :

/sbin/ifconfig -a


Ensuite :

sudo apt-get update
sudo apt-get install aptitude
sudo aptitude update
sudo aptitude safe-upgrade
sudo aptitude install gnome
sudo service gdm restart


Si le paquet gnome n'est pas trouvé, c'est probablement qu'il faudra rajouter les dépôts universe dans /etc/apt/sources.list.

Dans la fenêtre de connexion veille en dessous le login et mot de passe à choisir gnome (ubuntu classique).

Note qu'une réinstallation ubuntu 11.10 ne résoudra rien puisqu'il installera sans doute unity. Ou alors il faut installer par exemple kubuntu 11.10 (ce sera un environnement KDE, qui lui marche que tu aies de la 3D ou pas).

Bonne chance
Ajouter un commentaire
Réponse
+1
moins plus
Ce que tu peux faire, c'est dégager tout l'ancien profil de ton compte corrompu dans un autre répertoire. Supposons que ce profil s'appelle tata, identifie-toi en mode texte après avoir quitté ta session graphique :

cd /home/tata

mkdir vieux_profil_tata

for x in $(ls -1a | grep "^\." | grep -v "^\.$" | grep -v "^\.\.$"); do mv $x vieux_profil_tata; done


Ensuite réidentifie toi en mode graphique. Cette manipulation ne fait rien perdre. On a juste déplacé ton profil, source du problème. Ensuite il faut rapatrier progressivement les morceaux de /home/tata/vieux_profil_tata dans /home/tata. Le plus simple c'est de lancer nautilus et d'afficher les fichiers cachés.

Par exemple, supposons que tu utilisais thunderbird et que quand tu lances celui-ci, tu ne vois plus tes mails. Alors il faudra déplacer /home/tata/vieux_profil_tata/.thunderbird dans /home/tata.

L'idée c'est que tu rapatries juste le nécessaire, car il y a une partie de ton profil qui est corrompue, donc attention à ne pas la remettre ! Comme je te le disais c'est probablement un truc en rapport avec gnome ou x.

À chaque fois que tu ramènes un morceau de ton ancien graphique, quitte ta session graphique et ré-identifie toi pour vérifier que tu n'as pas ramener cette partie corrompue.

Bonne chance
Ajouter un commentaire
Réponse
+1
moins plus
Salut,
Alors le fichier cacher qui pose problème chez moi ( et ailleurs je pense)
c'est .Xauthority
on peut donc adapter ce que suggère mamiemendo pour "supprimer/déplacer" le fichier Xauthority
donc de A à Z ça donne pour un débutant ça donne
&) On se logue en console ( ctrl+altr+f2)
2) On tue lightdm : sudo killall lightdm
3) On déplace le fichier Xauthority
mv ~/.Xauthority ~/Xauthority.backup
4) On relance X:
sudo lightdm

Et ensuite j'ai pu me logguer avec mon compte
..
Je sais pas exactement les infos du fichier Xauthority et à quoi il sert ?
A plus
Ajouter un commentaire
Réponse
+0
moins plus
C'est probablement que tu utilisais jusqu'ici un pilote propriétaire qui n'a pas été réinstallé lors de la mise à jour. Linux tente de le charger conformément au fichier /etc/X11/xorg.conf, hors le pilote en question n'existe pas pour un noyau 3.0.0.

Le remède est simple : en supprimant (ou en renommant) le fichier /etc/X11/xorg.conf et en relançant le mode graphique (ou en redémarrant), le mode graphique va se charger avec une configuration par défaut qui devrait marcher. Libre à toi de réinstaller un éventuel pilote propriétaire (qui sera nécessaire pour avoir les bureaux 3d, jouer à des jeux 3d etc...).

Pour ce faire passe en mode texte (ctrl alt f1) :
http://www.mistra.fr/tutoriel-linux-mode-texte.html

Identifie-toi et lance la commande :

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
sudo service gdm restart


... et normalement ça devrait marcher.

Pour réinstaller un éventuel pilote propriétaire, passe par jockey :
http://doc.ubuntu-fr.org/gestionnaire_de_pilotes_proprietaires

Bonne chance
Ajouter un commentaire
Réponse
+0
moins plus
J'ai supprimé le xorg.conf et bingo j'ai ldm qui apparait.
Par contre ta commande service gdm restart ne fonctionne pas (peut etre es ce parce que c'est ldm maintenant?)
Cependant lorsque je mets mon mot de passe sur l'ecran pour me logguer, rien ne se charge, on dirait que ça bloque...
Seul la session invité fonctionne et j'arrive sur l'espace de travail.

Je vais essayer jockey pour supprimer les pilotes proprietaires s'il y a...
Ajouter un commentaire
Réponse
+0
moins plus
Je viens d'essayer avec jockey-text -l puis jockey-text -d mais les pilotes ne semblent pas se supprimer malgré que la commande semble fonctionner...
Toujours le même souci, je peux seulement arriver sur un espace de travail avec la session invité.
Ajouter un commentaire
Réponse
+0
moins plus
Effectivement le service peut être kdm, xdm, gdm... ou ldm d'après ce que tu dis (que je ne connais pas). En tout cas il est dans /etc/init.d/.

Seul la session invité fonctionne et j'arrive sur l'espace de travail.

Là je pense que c'est un autre problème. Si c'était vraiment la carte graphique, tu n'aurais même pas eu la fenêtre pour t'identifier. Dans un premier temps lance en mode texte :

df -h


Regarde s'il reste de la place sur /. Si ce n'est pas le cas il faut faire du ménage. On peut déjà vider le cache d'apt :

sudo apt-get clean
sudo service ldm restart


Tente ta chance. Si ça ne change rien (et qu'il reste de la place), fais une mise à jour.

sudo apt-get update
sudo apt-get install aptitude
sudo aptitude update
sudo aptitude safe-upgrade


Par rapport aux commandes jockey, le fait que les pilotes propriétaires (s'il y en a) soient installés n'est pas gênant tant que tu ne les charges pas explicitement via /etc/X11/xorg.conf.

Peux-tu nous dire quel modèle de carte vidéo tu utilises ?

lspci
Ajouter un commentaire
Réponse
+0
moins plus
Effectivement tu dis bien puisqu'il semble manquer de place, il restait seulement 1g de libre.j'ai fait :
sudo apt-get clean qui me laisse maintenant 3g de libre.

Il est vrai que lors de la mise à niveau, un message est apparu en me disant qu'il y avait très peu de place et je n'ai pas nettoyé, j'ai même fait un reboot , peut etre la mise à niveau n'a pas été bien faite?

le sudo aptitude update ne semble pas marcher (peut etre faut-il une connexion internet?)

concernant ma carte c'est une geforce 8600GT.

En tout cas merci de ton aide.
Ajouter un commentaire
Réponse
+0
moins plus
Normalement 1Go c'est plus que suffisant.

Il est vrai que lors de la mise à niveau, un message est apparu en me disant qu'il y avait très peu de place et je n'ai pas nettoyé, j'ai même fait un reboot , peut etre la mise à niveau n'a pas été bien faite?

C'est ce que je soupçonne.

le sudo aptitude update ne semble pas marcher (peut etre faut-il une connexion internet?)

Oui, ainsi que pour le sudo aptitude safe-upgrade. Ces commandes cherchent respectivement la liste des mises à jour (update), puis les télécharge et les applique (safe-upgrade).

Vu que ta carte est une nvidia, tu peux essayer de lancer ces commandes :

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
sudo service gdm restart


Dis-moi si ça marche. Si oui, il faudra ensuite réinstaller le driver propriétaire si tu souhaites l'utiliser.

Bonne chance
Ajouter un commentaire
Réponse
+0
moins plus
la commande sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak et
sudo service gdm restart ne semblent pas fonctionner, tu me l'avais conseillé au tout début et j'ai accès à la fenetre de connexion mais cela bloque des lors que je mets mon mot de passe...

Je pense que mon install s'est mal dérouléee...comment je peux la refaire sans tout formater etc...la réparer simplement c'est possible?

Pour ce qui est du sudo aptitude update et sudo aptitude sage-upgrade, je dois cabler en ethernet ma connexion n'es ce pas car je suis sous un pc portable en wifi?

Merci encore.
Ajouter un commentaire
Réponse
+0
moins plus
Salut !

Dans le Terminal, tapes startx et vois si ça lance l'interface.
Ajouter un commentaire
Réponse
+0
moins plus
Mamiemando,

j'ai bien fait comme tu m'as dit, j'ai bien fait un sudo aptitude safe-upgrade et installé gnome.Celui-ci appariat bien sur l'ecran de connexion, j'ai tenté de selectionner gnome classic, gnome...mais toujours le même souci...ça bloque, je ne vois pas le bureau...
C'est bizarre si je choisi la session invité, cela fonctionne...je ne comprends vraiment pas...si tu as encore des solutions...
Merci.
Ajouter un commentaire
Réponse
+0
moins plus
AH. Si ça marche avec une session invité, c'est que quelque chose dans ton profil (un fichier de configuration) fait planter ta session. Pour s'en assurer crée un nouvel utilisateur :

sudo adduser toto


Puis essaye de te logguer en toto. Si ça marche, cela signifie effectivement que ton profil est corrompu. Lis ceci :
http://www.mistra.fr/tutoriel-linux-configuration.html

À la fin de cette lecture tu auras compris qu'un fichier ou un répertoire caché situé dans le home de l'utilisateur à problème est responsable du soucis, sans doute un truc en rapport avec le mode graphique (un truc dont le nom commencera par ".x") ou avec gnome (.gnome2 ?).

L'idée consisterait en fait à déplacer ces morceaux de profil dans un autre répertoire et de les remettre petit à petit dans ton home, jusqu'à déterminer lequel est coupable.

Si par exemple ton utilisateur à problème est mando :

mkdir /home/mando/profil
mv /home/mando/.x* /home/mando/.gnome* /home/mando/profil


... puis essaye de te relogguer. Si ça marche, déconnecte toi et essaye de rappatrier de /home/profil par exemple /home/profil/.x* dans /home/mando et tente de te réidentifier.

Bref de proche en proche tu auras isolé les fichiers cachés responsables du plantage.

Bonne chance
Ajouter un commentaire
Réponse
+0
moins plus
Bonsoir,
j'ai le même problème après upgrade vers 11.10
moi aussi la session invité marche et un nouveau compte utilisateur fonctionne
Ca sauve temporairement de la panade ( puisque je n'ai que ubuntu et que mon portable est mon outil de travail)
il faudrait maintenant avoir le courage d'identifier d'ou vient le problème pour l'instant j'ai pas énormément de temps je up si j'ai du nouveau.
Ajouter un commentaire
Réponse
+0
moins plus
Une précision : Le fichier Xauthority.back ( ma sauvegarde i.e. celui avec lequel je ne pouvais pas bouter) est vide.
Plus étrange seul le root peut le lire/écrire... peut-être était-ce la cause du problème : le fichier ayant les mauvaise permissions ... Puisqu'il semble juste que le système écrit dedans quand on se connecte mode graphique.
Ajouter un commentaire
Réponse
+0
moins plus
C'est possible que ce problème de droit fasse planter tout effectivement. Car a priori le fichier est destiné à être lu (s'il est présent) et éventuellement complété, et s'il n'existe pas, il est sensé être créé. Du coup à cause de ce problème de droit, X ne peut faire ni l'un ni l'autre.

Si ton login est toto je t'invite à lancer :

sudo chown -R toto /home/toto


Bonne chance
Ajouter un commentaire
Réponse
+0
moins plus
Bonsoir,

merci!!!j'y suis enfin arrivé grâce à vous, c'est super.
En effet Mamiemando, mon profil etait corrompu et la cause est ce fameux fichier .Xauthority . J'ai donc fait mv .Xauthority Xauthority.back et la bingo, je retrouve mon espace de travail !
Vraiment merci de votre aide et surtout de votre patience.

Mais qu'es ce donc ce fichier et pourquoi fait il planter tout ça?
Ajouter un commentaire
Réponse
+0
moins plus
Comme son nom l'indique .Xauthority est en rapport avec le mode graphique (ça commence par X = graphics = mode graphique). Il est donc lu au démarrage de ta session graphique. S'il a été créé c'est qu'il contient des informations importantes pour l'initialiser. Si ces informations sont corrompues, le mode graphique ne peut donc pas se charger correctement. Le fait de supprimer ou déplacer ce fichier fait que le mode graphique va en recréer un par défaut (qui pour le coup sera propre).

Bonne continuation !
Ajouter un commentaire
Ce document intitulé «  [ubuntu 11.10] plus de mode graphique  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.