[excel] formule de soustraction [Résolu/Fermé]

BB - 4 août 2006 à 00:51 - Dernière réponse :  GIGI
- 23 nov. 2017 à 01:25
Bonjour,

Question sur une soustraction toute simple.

J'ai une formule à écrire pour effectuer la soustraction du total d'une colonne (de la cellule C3 à C7) avec celui d'une autre colonne (de la cellule E3 à la cellule E7). Si j'effectue dans un premier temps le total de la première colonne dans une case (C9) et dans une autre le total de la deuxième colonne (E9), la formule suivante fonctionne très bien : =C9-E9

Mais j'aimerais savoir si l'on est obligé de passer par cette méthode.

En effet je ne comprends pas pourquoi, si je marque :
=(C3:C7)-(E3:E7), cela ne fonctionne pas, car cette formule me semble tout à fait compréhensible.

Quelqu'un pourrait-il m'aider à comprendre ce qui ne va pas dans cette formule?
Merci d'avance!!!
Afficher la suite 

14 réponses

Utilisateur anonyme - 4 août 2006 à 08:33
+91
Utile
9
Il faut écrire : =somme(c3:c7)-somme(e3:e7)
et moi je ne comprends pas comment on fait 10 moins 2 je n'arrive a trouver 8 !!!!!!
Raymond PENTIER 44507 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - 26 mai 2014 à 23:57
Si dans une cellule tu saisis "10 moins 2" c'est une phrase en format texte, et Excel (ni personne) ne peut deviner que tu avais l'intention de demander à effectuer une opération sur des valeurs numériques !
Mais ce n'est pas que de l'étourderie, j'en ai peur ...
Merci pour ce petit tuto, qui m'a bien remémoré cette formule.
^^Marie^^ 115971 Messages postés mardi 6 septembre 2005Date d'inscription 10 janvier 2017 Dernière intervention - 4 août 2006 à 07:05
+9
Utile
3
Salut,

Regarde sur ce lien
http://www.admexcel.com/guides/e9701.htm

A++
Merci beaucoup marie pour ce lien, il m'aidera certainement pour d'autres choses! C'est un bon pense bête, mais je n'y ai pas trouvé ma réponse. Faut que je regarde mieux, j'ai peut-être zappé quelque chose.
Merci encore et bonne journée.
Si jamais tu as trouvé, ça m'intéresse également, chaque fois que je met =SOMME(C2-B2) ou =SOMME(C2:C6)-SOMME(B2:B6) il me met "valeur"
Raymond PENTIER 44507 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention > titi - 25 sept. 2015 à 02:09
Pas la peine de mettre =SOMME(C2-B2) ; il suffît d'écrire =C2-B2
Mais si B2 ou C2 contient un texte, il est normal que s'affiche le message d'erreur #VALEUR!