Signaler

Installation OpenVPN [Résolu/Fermé]

Posez votre question cc13430 3970Messages postés mardi 3 juin 2008Date d'inscription 31 mars 2014 Dernière intervention - Dernière réponse le 7 déc. 2011 à 16:15 par cc13430
Bonjour,

je cherche à installer openVPN
mais bloque car la commande build-req ne fonctionne pas

Microsoft Windows [version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation. Tous droits réservés.

C:\Users\Administrateur>cd c:\program files (x86)\openvpn\easy-rsa

c:\Program Files (x86)\OpenVPN\easy-rsa>build-req
c:\Program Files (x86)\OpenVPN\easy-rsa
WARNING: can't open config file: c:\openssl/ssl/openssl.cnf
Unable to load config info from c:\openssl/ssl/openssl.cnf
'-config' n'est pas reconnu en tant que commande interne
ou externe, un programme exécutable ou un fichier de commandes.
'errors' n'est pas reconnu en tant que commande interne
ou externe, un programme exécutable ou un fichier de commandes.
Impossible de trouver c:\*.old

c:\Program Files (x86)\OpenVPN\easy-rsa>

j'ai surement oublié quelques choses mais je ne vois pas.
merci pour votre aide

j'ai suivi le tuto http://forum.hardware.fr/hfr/reseauxpersosoho/Tutoriels/windows-openvpn-tutoriels-sujet_2_1.htm

Merci pour votre aide

Utile
+2
plus moins
Bonjour,

Voici la solution que j'ai trouvée et appliquée et qui fonctionne sur windows 7 x64 et windows server 2008 x64:


En partant d'une installtion d'openvpn 2.2.1 venant jsute de se terminer:

ouvrir une invite de commande et se rendre dans le répertoire d'openvn

cd %programfiles(x86)%\openvpn\easy-rsa


ensuite tapez: init-config puis faites entrer

cela va simplement renommer le vars.bat.sample en vars.bat


Suite à ça, éditez avec notepad ++ (pas avec notepad car il ne gère pas les retour à la ligne UNIX contenus dans ce fichier)

Modifiez
%programfiles% en %programfiles(x86)%


Sous windows 7 x64 le répertoire d'installation des applications 32 bits (x86) est différent de celui sous windows 32 bits.


Prochiane étape: ne plus avoir l'erreur du fichier openssl.cnf introuvable.


Si dans votre invite de commande toujours ouverte, vous êtes toujours dans OpenVPN\easy-rsa normalement, tapez ce qui suit:

mkdir c:\openssl
ENTREE
cp openssl-1.0.0.cnf c:\openssl\openssl.cnf




Ensuite vous pourrez recréer vos certificats sans avoir d'erreurs.

J'espère que ça vous aura aidé.

Cette réponse vous a-t-elle aidé ?  
cc13430 3970Messages postés mardi 3 juin 2008Date d'inscription 31 mars 2014 Dernière intervention - 7 déc. 2011 à 16:15
c'est un problème d'adresse public que j'avais, car étant un particulier, il fallait que je fasse des modifications que je n'avait pas fait.... sans parlé de l'adresse qui change
Utile
+0
plus moins
Faut peut être installer OpenSSL ???

http://www.slproweb.com/products/Win32OpenSSL.html

Cordialement,
Utile
+0
plus moins
apparemment open vpn inclus onpenssl

voir http://openmaniak.com/fr/openvpn.php

et après une recherche je trouve un openssl.exe dans c://program files (x86)/openvpn/bin

mais pas de fichier openssl.cnf
bizarre

une fois installer openssl, via le lien donnée, rien de plus....
Utile
+0
plus moins
j'ai reinstallé openvpn et j'ai retrouvé openssl.cnf dans c://program files (x86)/openvpn/easy-rsa

on verra si ça règle le soucis...
Utile
+0
plus moins
la commande build-req ne fonctionne pas
mais build-key client fonctionne
donc j'ai bien ma clef client
c'était le but, lol

après j'ai des soucis pour régler les fichiers server.conf pareil pour client.conf

Vous y connaissez quelques choses??
Utile
+0
plus moins
Il faut avant tout exécuter vars.bat avant de lancer build-key ou build-req
Utile
+0
plus moins
oui, j'ai fait la commande vars avant

par contre j'arrive a le faire fonctionner en local
mais bien sûr, je ne sais pas du coup si ça fonctionne ....

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !