Posez votre question Signaler

Activer le son [Résolu]

benjamin1780 75Messages postés lundi 28 janvier 2008Date d'inscription 30 juin 2014Dernière intervention - Dernière réponse le 27 sept. 2011 à 22:20
Bonjour,
j'ai installé linux sur un pc mais je n'ai pas de son pourriez vous me guider car un peu perdu merci a tous
Lire la suite 
Réponse
+0
moins plus
Vérifie que le problème n'est pas d'ordre matériel (enceintes branchées, allumées, volume raisonnable). Idem au niveau du mixer.

Si tout semble bon, teste avec des écouteurs et des enceintes. Si ça marche dans un cas mais pas dans l'autre, tu as sans doute un problème commun sous linux et lié aux cartes son intel.

Sous linux l'équivalent des "drivers" s'appèlent des modules (fichiers .ko, placés dans /lib). Au moment de les charger (par exemple grâce à la commande modprobe), on peut passer au module des options pour influencer son comportement.

C'est typiquement ce qu'on fait avec alsa quand on a une carte intel (le module alsa est responsable du son sur les installations linux classiques et quand on a une carte son intel, il ne s'initialise pas toujours comme il faut).

Le seul soucis, c'est que linux charge automatiquement ce module. Il faut donc lui indiquer les fameuses options dans un fichier de configuration. Sous linux la configuration du système est rangée dans /etc, et comme ici il s'agit de la commande modprobe et que c'est le module alsa qui est en jeu, on sent assez fortement que le fichier /etc/modprobe.d/alsa-base.conf est sans doute celui qui va nous sauver la mise.

Encore faut-il savoir quoi mettre dedans, d'autant que les options dépendent de ton modèle de carte son ! Pour voir quel modèle de carte son tu utilises tu peux lancer un terminal :
http://doc.ubuntu-fr.org/terminal

... puis taper la commande :

lspci


La ligne qui nous intéresse contient probablement "Audio controller".

Exemple :

(mando@aldur) (~) $ lspci
...
00:02.2 USB Controller: nVidia Corporation nForce3 EHCI USB 2.0 Controller (rev a2)
00:06.0 Multimedia audio controller: nVidia Corporation nForce3 250Gb AC'97 Audio Controller (rev a1)
00:08.0 IDE interface: nVidia Corporation CK8S Parallel ATA Controller (v2.5) (rev a2)
...


Reporte-nous la ligne en question si tu as besoin de précisions.

Une fois le modèle de la carte identifié, il faut corriger le fichier de configuration /etc/modprobe.d/alsa-base.conf :

gksudo gedit /etc/modprobe.d/alsa-base.conf


Pour savoir quelle ligne y ajouter (en fin de fichier par exemple), tu peux te référer à cette page :
http://doc.ubuntu-fr.org/audio_intel_hda

A priori ça va être une ligne du genre "options snd-hda-intel model=..."

Une fois la ligne qui te semble correcte ajoutée à ce fichier redémarre (en réalité on pourrait se contenter de décharger les modules alsa et les recharger, mais on va faire au plus simple). Si tu as mis la bonne ligne, tu devrais avoir du son !

Bonne chance
benjamin1780- 26 sept. 2011 à 18:12
merci de m'avoior guide en fait le probleme etait tout bete il suffisait de selectionner les bonnes sorties dans son encore merci salutations
Répondre
mamiemando 25308Messages postés jeudi 12 mai 2005Date d'inscription ModérateurStatut 27 avril 2015Dernière intervention - 27 sept. 2011 à 22:20
Ah c'était donc beaucoup plus simple que ce que je craignais ! Bonne continuation :-)
Répondre
Ajouter un commentaire
Ce document intitulé «  activer le son  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.